Refurbished Epson 5040UB - $1,151.00 - Page 19 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 156Likes
Reply
 
Thread Tools
post #541 of 818 Old 06-25-2019, 09:45 PM
Senior Member
 
jamesyates's Avatar
 
Join Date: Oct 2013
Posts: 212
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Liked: 39
Just ordered one today. Hope I do not have to send it back 3x times and the free lamp offer works. It fall goes well this is a no-brainer for replacing a 9 year old Panasonic with the lamp replace light on.
jamesyates is offline  
Sponsored Links
Advertisement
 
post #542 of 818 Old 06-26-2019, 03:46 AM
Advanced Member
 
kedelbach's Avatar
 
Join Date: Sep 2001
Location: USA
Posts: 728
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 15
Ordered mine last night to replace a 6 year old Optoma HD131XE that just blew it's 2nd bulb (good excuse to upgrade!). She served us well, esp given the $700 purchase price, but really looking forward to all the improvements with this beast.

Used code EPF2S for free 2-day shipping, $1246 incl tax.

Question: should I be thinking about (or need to) replace my current HDMI cable:
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
Says it's good for 10gb/s, what if any limitations might that put on the source material?

Currently we watch 1080p signals almost exclusively. Only current 4K possibility is Netflix, at some point may get a 4K BR player but not anytime soon.

Edit: found this post 17524 that explains that the 5040 chipset is max 10gb/s, so my exisiting HDMI cable should be fine, at least until 4k60 HDR is widespread (at which point I'll need to upgrade my projector, AV receiver and cable):
https://www.avsforum.com/forum/68-di...l#post58175264

Last edited by kedelbach; 06-26-2019 at 06:50 AM. Reason: found info
kedelbach is offline  
post #543 of 818 Old 06-26-2019, 10:29 AM
Senior Member
 
jamesyates's Avatar
 
Join Date: Oct 2013
Posts: 212
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Liked: 39
Is the free lamp rebate still available? If so where can I get the rebate form? Thanks
jamesyates is offline  
Sponsored Links
Advertisement
 
post #544 of 818 Old 06-26-2019, 12:18 PM
Member
 
Dano2's Avatar
 
Join Date: Feb 2005
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 15
Quote:
Originally Posted by jamesyates View Post
Is the free lamp rebate still available? If so where can I get the rebate form? Thanks
https://www.avsforum.com/forum/199-f...l#post58211858
jamesyates likes this.

-Dano
Dano2 is online now  
post #545 of 818 Old 06-26-2019, 07:37 PM
Member
 
mrgigalevu's Avatar
 
Join Date: May 2012
Location: USA
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Liked: 29
More available now. Act fast.

Sent from my SM-N950U using Tapatalk

Mirage OMD Series
Onkyo AVR
mrgigalevu is offline  
post #546 of 818 Old 06-27-2019, 05:49 AM
Member
 
Join Date: Jun 2016
Posts: 49
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Liked: 6
Quote:
Originally Posted by kedelbach View Post
Ordered mine last night to replace a 6 year old Optoma HD131XE that just blew it's 2nd bulb (good excuse to upgrade!). She served us well, esp given the $700 purchase price, but really looking forward to all the improvements with this beast.

Used code EPF2S for free 2-day shipping, $1246 incl tax.

Question: should I be thinking about (or need to) replace my current HDMI cable:
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
Says it's good for 10gb/s, what if any limitations might that put on the source material?

Currently we watch 1080p signals almost exclusively. Only current 4K possibility is Netflix, at some point may get a 4K BR player but not anytime soon.

Edit: found this post 17524 that explains that the 5040 chipset is max 10gb/s, so my exisiting HDMI cable should be fine, at least until 4k60 HDR is widespread (at which point I'll need to upgrade my projector, AV receiver and cable):
https://www.avsforum.com/forum/68-di...l#post58175264
i ordered mine on saturday used free 2 day shipping and got it yesterday. Unboxed it and hooked it up. Everything looks good and i do have the free bulb offer that i will fill out.

Fingers crossed i got a good one.
kedelbach likes this.
carlb1 is offline  
post #547 of 818 Old 06-27-2019, 06:04 AM
Member
 
Join Date: Jun 2016
Posts: 49
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Liked: 6
Quote:
Originally Posted by jamesyates View Post
Is the free lamp rebate still available? If so where can I get the rebate form? Thanks
yes and you can get it on the epson site. its only good until june 30
carlb1 is offline  
post #548 of 818 Old 06-28-2019, 06:27 PM
Member
 
Join Date: Oct 2018
Posts: 158
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Liked: 24
Quote:
Originally Posted by carlb1 View Post
Quote:
Originally Posted by jamesyates View Post
Is the free lamp rebate still available? If so where can I get the rebate form? Thanks
yes and you can get it on the epson site. its only good until june 30
Purchase by June 30th and post-marked within 30 days.

Build Thread:https://www.avsforum.com/forum/19-de...m-wet-bar.html
Theatre Room: Samsung UN55KU7000F | Pioneer SP-FS52 x 2 | Polk MC80 x 2
Epson 5040UB | 120" Elunevision 4K Reference Tab 2.35:1 | Philharmonic Audio Affordable Accuracy Center Channel
phanttom is offline  
post #549 of 818 Old 06-29-2019, 03:13 PM
Advanced Member
 
kedelbach's Avatar
 
Join Date: Sep 2001
Location: USA
Posts: 728
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 15
Got mine yesterday and tested out on the coffee table. wow she's a BEAST!
Everything looks as new, and GREAT image. OK I am coming from a $700 Optoma 131Xe DLP ... not the worst PJ by any stretch but boy had she lost a lot of her original 2000lumens.
5040 has Razor sharp focus all the way to the corners. Couldn't find any "dust blobs" or other abnormalities. 0 hours reported on bulb.
Had to trade in the old Xfinity DVR for a new one that outputs 4k but even 1080p looked sweet.
Already have the new mount attached into the projector and ceiling, just waiting for the 2' mount extension to be delivered today and she'll be installed.

Using this mount: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
and this extension: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

Now to send in the rebate form for the extra bulb, which is nice.
Definitely watching a 4k UHD movie from Netflix or Amazon Prime tonight with the Mrs!
Attached Thumbnails
Click image for larger version

Name:	Image7315720845060855549.jpg
Views:	91
Size:	181.3 KB
ID:	2585668   Click image for larger version

Name:	Image8545933377243268930.jpg
Views:	86
Size:	189.4 KB
ID:	2585670   Click image for larger version

Name:	Image4663356816143692204.jpg
Views:	88
Size:	143.3 KB
ID:	2585672   Click image for larger version

Name:	Image3668043671267418715.jpg
Views:	99
Size:	159.5 KB
ID:	2585674  
Xavier3 likes this.
kedelbach is offline  
post #550 of 818 Old 06-30-2019, 12:15 AM
Newbie
 
Join Date: Jun 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Angry

So set mine up today, ceiling mount. Only was about 5 minutes in - connections tested. Sources worked.
Flip image upside and align to screen.
Then when I am taking a look at what the different colour modes. It gets to Cinema, i hear alot of clicking sounds and then the epson status light, lamp light and temp light start flashing. The fan turns on high speed and then after about 3-60 seconds the projector turns off. Nothing.
Now when I turn it on, no image, high speed fan, status light, lamp light and temp light start flashing and then it turns off.

Is this a broken one they did not check properly or something seen before? My searches bring up nothing so seems like a return they did not look at. Or there shipping is breaking these??!??
Allan Weinman is offline  
post #551 of 818 Old 06-30-2019, 06:41 AM
Senior Member
 
Join Date: Jun 2018
Posts: 458
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 245 Post(s)
Liked: 121
Quote:
Originally Posted by Allan Weinman View Post
So set mine up today, ceiling mount. Only was about 5 minutes in - connections tested. Sources worked.
Flip image upside and align to screen.
Then when I am taking a look at what the different colour modes. It gets to Cinema, i hear alot of clicking sounds and then the epson status light, lamp light and temp light start flashing. The fan turns on high speed and then after about 3-60 seconds the projector turns off. Nothing.
Now when I turn it on, no image, high speed fan, status light, lamp light and temp light start flashing and then it turns off.

Is this a broken one they did not check properly or something seen before? My searches bring up nothing so seems like a return they did not look at. Or there shipping is breaking these??!??
either you got a bum unit or something broke in shipping. get a RA and get a new one. Shouldn't be an issue as there are 61 left as i type this! 61! Sheesh, we go weeks and weeks trying to get in on this deal and for the last couple of them it's like they found a shipping container full in the back yard or something..
ipca204 is online now  
post #552 of 818 Old 06-30-2019, 08:58 AM
Newbie
 
Join Date: Jun 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Quote:
Originally Posted by ipca204 View Post
either you got a bum unit or something broke in shipping. get a RA and get a new one. Shouldn't be an issue as there are 61 left as i type this! 61! Sheesh, we go weeks and weeks trying to get in on this deal and for the last couple of them it's like they found a shipping container full in the back yard or something..
It was packaged very well with Styrofoam and plastic and all looked new. Except for the box. It did say refurb on the box. I get the feeling based on this thread that Epson takes back returns and just turns around and ships them out as refurbs. How can so many of us receive defective product from them so frequently if they are really checking them. It seems it is cheaper for them to keep on sending them out to us instead of checking them themselves!

When getting a replacement unit and having to ship the existing back (In Canada) are you able to hand the old one to the delivery company and have them take it when dropping off the replacement or do I have to go to a shipping drop off location to ship it out? I believe they used Purolator to ship it to me.
Allan Weinman is offline  
post #553 of 818 Old 06-30-2019, 11:24 AM
Member
 
Join Date: Oct 2018
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Liked: 30
Quote:
Originally Posted by Allan Weinman View Post
It was packaged very well with Styrofoam and plastic and all looked new. Except for the box. It did say refurb on the box. I get the feeling based on this thread that Epson takes back returns and just turns around and ships them out as refurbs. How can so many of us receive defective product from them so frequently if they are really checking them. It seems it is cheaper for them to keep on sending them out to us instead of checking them themselves!

When getting a replacement unit and having to ship the existing back (In Canada) are you able to hand the old one to the delivery company and have them take it when dropping off the replacement or do I have to go to a shipping drop off location to ship it out? I believe they used Purolator to ship it to me.
Your issue seems like the D3 colour filter got stuck as it was being moved into place. The Cinema mode engages this special filter which allows deep colour. Nothing you can do unfortunately as its too complex to open up and you would void your warranty anyways.

I often wonder about that D3 filter. There is quite a bit of action when its moved in and out of place. Just another thing to go wrong. Unfortunately, all the HDR projectors that support D3 colour require one as the UHP lamps cant produce a wide enough colour gamut on their own.

Regarding sending back the projector via Puralator, you would have to quickly package the projector and just ask the delivery guy to wait just a couple minutes. Have your packing tape and new shipping label ready and do it on the spot, taking the new one out of the packaging, and placing the old one back in the exact way. Give the driver a few bucks for his trouble and should be no problem.
Xavier3 is online now  
post #554 of 818 Old 06-30-2019, 05:46 PM
Member
 
Join Date: Oct 2018
Posts: 158
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Liked: 24
Quote:
Originally Posted by Allan Weinman View Post
It was packaged very well with Styrofoam and plastic and all looked new. Except for the box. It did say refurb on the box. I get the feeling based on this thread that Epson takes back returns and just turns around and ships them out as refurbs. How can so many of us receive defective product from them so frequently if they are really checking them. It seems it is cheaper for them to keep on sending them out to us instead of checking them themselves!

When getting a replacement unit and having to ship the existing back (In Canada) are you able to hand the old one to the delivery company and have them take it when dropping off the replacement or do I have to go to a shipping drop off location to ship it out? I believe they used Purolator to ship it to me.
When I returned my refurb due to a scratched lens from Edmonton, they shipped the new one to me via purolator and FedEx picked up the old one. All from my house, never had to lift a finger. Didn't even have to print off a RMA or packing slip for FedEx when they picked up the one going back to Epson Canada.

Build Thread:https://www.avsforum.com/forum/19-de...m-wet-bar.html
Theatre Room: Samsung UN55KU7000F | Pioneer SP-FS52 x 2 | Polk MC80 x 2
Epson 5040UB | 120" Elunevision 4K Reference Tab 2.35:1 | Philharmonic Audio Affordable Accuracy Center Channel
phanttom is offline  
post #555 of 818 Old 07-01-2019, 05:57 PM
AVS Forum Special Member
 
WynsWrld98's Avatar
 
Join Date: Nov 1999
Location: Puyallup, WA
Posts: 3,093
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 575 Post(s)
Liked: 217
In U.S. unboxed the refurb 5040, all looked really good with the image for 5 mins until a "projector is overheating" message displayed and light next to lamp flashing, took a long time until it shut down. I started it up and same thing happened on second attempt after about 5 minutes of watching. I checked the air filter it looks brand new and seated properly. I'm on hold with Epson right now...
WynsWrld98 is offline  
post #556 of 818 Old 07-02-2019, 01:41 PM
Newbie
 
g35king's Avatar
 
Join Date: Jul 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 10
I ordered one on Sunday and received it today (2 day shipping, USA). Few scuff's on the top of the projector and came with black foam and plastic. Checked the secret menu and bulb has been changed and the number it's showing is 2. Tested for 5 minutes and looks good. This thing is huge when compared to my 2045 and picture is bright and sharp.

For rest of the folks buy with confidence and I guess it comes with 2 year warranty and can be backed up with your credit card warranty for a year or two (after the 2 year manufacturer)...Makes it a good deal.

Can I use my old mount? Removing the extension column?

QualGear QG-PM-002-BLK-L Projector Ceiling Mount with Adjustable Extension Column Accessory

Last edited by g35king; 07-02-2019 at 01:48 PM.
g35king is offline  
post #557 of 818 Old 07-02-2019, 08:07 PM
Member
 
cfelicio's Avatar
 
Join Date: Jul 2011
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 28
Quote:
Originally Posted by g35king View Post
I ordered one on Sunday and received it today (2 day shipping, USA). Few scuff's on the top of the projector and came with black foam and plastic. Checked the secret menu and bulb has been changed and the number it's showing is 2. Tested for 5 minutes and looks good. This thing is huge when compared to my 2045 and picture is bright and sharp.

For rest of the folks buy with confidence and I guess it comes with 2 year warranty and can be backed up with your credit card warranty for a year or two (after the 2 year manufacturer)...Makes it a good deal.

Can I use my old mount? Removing the extension column?

QualGear QG-PM-002-BLK-L Projector Ceiling Mount with Adjustable Extension Column Accessory
I thought the extended warranty from the credit card only covers new items, and only up to $500. Would they cover this as well? Maybe I got a crappy CC
cfelicio is offline  
post #558 of 818 Old 07-02-2019, 08:18 PM
AVS Forum Special Member
 
WynsWrld98's Avatar
 
Join Date: Nov 1999
Location: Puyallup, WA
Posts: 3,093
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 575 Post(s)
Liked: 217
So my first refurb had the overheating and is on its way back to Epson. Yesterday they said they were overnighting me a replacement but I have not received any kind of e-mail notification from Epson or Fedex. Has this been others experience that the replacement just shows up? Also re: the lamp rebate (free lamp) the only receipt I have is for June with a serial # of the one I just returned. They ordered the replacement yesterday July 1 so does that change the purchase date from June to July? I have a lamp rebate form for June 1-30 and another for July 1-31, not sure which rebate form I'd use for the lamp once I get a working 5040? Anyone know?
WynsWrld98 is offline  
post #559 of 818 Old 07-03-2019, 12:56 AM
Senior Member
 
jamesyates's Avatar
 
Join Date: Oct 2013
Posts: 212
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Liked: 39
Received mine yesterday. All seems to work. The lens was a little dirty with possibly minor scratching (casually glancing at lens will clean and investigate soon). Casing is lightly used. I would rate the condition used but very good. Auto iris motor noise was driving me crazy on high. Set to medium and all is well. No pixel issues I can see. Watched first movie and it made it through. Diagnosticscreads second lamp.

Any suggestions on what problems to look for?
jamesyates is offline  
post #560 of 818 Old 07-03-2019, 02:51 PM
Newbie
 
Join Date: Jun 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Angry

Quote:
Originally Posted by WynsWrld98 View Post
So my first refurb had the overheating and is on its way back to Epson. Yesterday they said they were overnighting me a replacement but I have not received any kind of e-mail notification from Epson or Fedex. Has this been others experience that the replacement just shows up? Also re: the lamp rebate (free lamp) the only receipt I have is for June with a serial # of the one I just returned. They ordered the replacement yesterday July 1 so does that change the purchase date from June to July? I have a lamp rebate form for June 1-30 and another for July 1-31, not sure which rebate form I'd use for the lamp once I get a working 5040? Anyone know?

Sorry, just re-iterating your question. I don't have an answer but I do have the EXACT same question. Crazy that both of us received defective overheating projectors! My return was picked up today but my replacement was supposed to ship yesterday or today and I also have not received any email. Also wondering about the free lamp. Glad you mentioned the rebate form for July, just found it and printed. Now need to know which to use as well. I am guessing the July one as that is when the replacement will be shipped and it will come with a serial number. I was told that I would receive an email when it is shipped! I called them again today and again was told an email would be sent when shipped. Almost 5pm and still no email!

As WynsWrld98 asked, anyone know . . . .
Allan Weinman is offline  
post #561 of 818 Old 07-03-2019, 02:54 PM
AVS Forum Special Member
 
WynsWrld98's Avatar
 
Join Date: Nov 1999
Location: Puyallup, WA
Posts: 3,093
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 575 Post(s)
Liked: 217
Quote:
Originally Posted by Allan Weinman View Post
Sorry, just re-iterating your question. I don't have an answer but I do have the EXACT same question. Crazy that both of us received defective overheating projectors! My return was picked up today but my replacement was supposed to ship yesterday or today and I also have not received any email. Also wondering about the free lamp. Glad you mentioned the rebate form for July, just found it and printed. Now need to know which to use as well. I am guessing the July one as that is when the replacement will be shipped and it will come with a serial number. I was told that I would receive an email when it is shipped! I called them again today and again was told an email would be sent when shipped. Almost 5pm and still no email!

As WynsWrld98 asked, anyone know . . . .
I haven't called to check status (yet) but when he placed the replacement order he said it would be overnighted. That was Monday late afternoon so I'd think it would show up today but who knows. I think I'll call soon.
WynsWrld98 is offline  
post #562 of 818 Old 07-03-2019, 04:36 PM
Newbie
 
Join Date: Jun 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Exclamation

Quote:
Originally Posted by WynsWrld98 View Post
I haven't called to check status (yet) but when he placed the replacement order he said it would be overnighted. That was Monday late afternoon so I'd think it would show up today but who knows. I think I'll call soon.
Just called again and was told it has been shipped, 2 day delivery and was given the tracking number. Still no email. I asked if I will receive a new sales confirmation by email and was told they will request it be sent to my email.
They are very friendly on the phone and seem to try to keep the customer happy by quick acceptance of a return and replacement. But it just seems like their quality control and system generated email to keep their customers informed is quite lacking.
Maybe I am asking too much!
Allan Weinman is offline  
post #563 of 818 Old 07-03-2019, 04:40 PM
AVS Forum Special Member
 
WynsWrld98's Avatar
 
Join Date: Nov 1999
Location: Puyallup, WA
Posts: 3,093
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 575 Post(s)
Liked: 217
Quote:
Originally Posted by Allan Weinman View Post
Just called again and was told it has been shipped, 2 day delivery and was given the tracking number. Still no email. I asked if I will receive a new sales confirmation by email and was told they will request it be sent to my email.
They are very friendly on the phone and seem to try to keep the customer happy by quick acceptance of a return and replacement. But it just seems like their quality control and system generated email to keep their customers informed is quite lacking.
Maybe I am asking too much!
I just called and received a tracking # as well stating it will be delivered today. When the person ordered another swap refurb he gave me an order # which I kept so if I file the July lamp rebate form I should be able to use that. I also asked about which lamp rebate form to use (original purchase date 6/14 but replacement order 7/1) and she said she didn't know but gave me a number for Epson rebates but they're closed for the day in my time zone they're open 8-6 E.S.T. 800-277-6187

I have no faith in Epson's quality control. Considering this projector overheated twice within 5 mins that tells me the most they may do is fire these projectors up for a minute. I regret buying the refurb vs I should have just saved up for a 5050 when they go on a good sale probably around Thanksgiving.
WynsWrld98 is offline  
post #564 of 818 Old 07-04-2019, 05:41 AM
Member
 
jblade44's Avatar
 
Join Date: Oct 2004
Location: Canada
Posts: 81
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Liked: 17
Quote:
Originally Posted by WynsWrld98 View Post
I just called and received a tracking # as well stating it will be delivered today. When the person ordered another swap refurb he gave me an order # which I kept so if I file the July lamp rebate form I should be able to use that. I also asked about which lamp rebate form to use (original purchase date 6/14 but replacement order 7/1) and she said she didn't know but gave me a number for Epson rebates but they're closed for the day in my time zone they're open 8-6 E.S.T. 800-277-6187

I have no faith in Epson's quality control. Considering this projector overheated twice within 5 mins that tells me the most they may do is fire these projectors up for a minute. I regret buying the refurb vs I should have just saved up for a 5050 when they go on a good sale probably around Thanksgiving.
If you want a refund just keep returning...until after the 3rd or 4th...and then demand a refund... others have done this...mostly because they kept getting bad units but as you said they send replacement with no questions asked....
jblade44 is offline  
post #565 of 818 Old 07-04-2019, 06:23 AM
AVS Forum Special Member
 
rob80b's Avatar
 
Join Date: Sep 2007
Location: Toronto, Ontario
Posts: 1,988
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 210 Post(s)
Liked: 130
Believe I've almost talked myself out of getting one and just enjoy my 4030........but just in case one changes their mind there are currently only 159 refurbs in stock as of this morning....
Makes one wonder.....
Attached Thumbnails
Click image for larger version

Name:	July 4th refubs.png
Views:	53
Size:	125.3 KB
ID:	2587398  
rob80b is offline  
post #566 of 818 Old 07-04-2019, 01:26 PM
AVS Forum Special Member
 
WynsWrld98's Avatar
 
Join Date: Nov 1999
Location: Puyallup, WA
Posts: 3,093
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 575 Post(s)
Liked: 217
Quote:
Originally Posted by rob80b View Post
Believe I've almost talked myself out of getting one and just enjoy my 4030........but just in case one changes their mind there are currently only 159 refurbs in stock as of this morning....
Makes one wonder.....
Holy moly 159 in stock?!?!? Kind of scary where all of those came from. Well my latest one looks like a winner so far great bright sharp pic I don't see anything wrong so far.
WynsWrld98 is offline  
post #567 of 818 Old 07-04-2019, 02:30 PM
AVS Forum Special Member
 
rob80b's Avatar
 
Join Date: Sep 2007
Location: Toronto, Ontario
Posts: 1,988
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 210 Post(s)
Liked: 130
Quote:
Originally Posted by WynsWrld98 View Post
Holy moly 159 in stock?!?!? Kind of scary where all of those came from. Well my latest one looks like a winner so far great bright sharp pic I don't see anything wrong so far.

Who's to say how accurate those numbers are but just for fun (slow day in the shop ) I looked at the quantities of other refurbs available, the Home Cinema 4000 had 232, the 2100 at 105 and the 2150 has 555..... so no shortage of refurbished projectors to go round...maybe time for a 4th of July fire sale.
rob80b is offline  
post #568 of 818 Old 07-05-2019, 09:44 AM
Member
 
jblade44's Avatar
 
Join Date: Oct 2004
Location: Canada
Posts: 81
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Liked: 17
Quote:
Originally Posted by rob80b View Post
Who's to say how accurate those numbers are but just for fun (slow day in the shop ) I looked at the quantities of other refurbs available, the Home Cinema 4000 had 232, the 2100 at 105 and the 2150 has 555..... so no shortage of refurbished projectors to go round...maybe time for a 4th of July fire sale.
It is very strange that after waiting months and months for them to show up .. they now have hundreds of them in the past few weeks... not sure what the reason is.... I suspect they cannot not all be refurb's and some have to be new that they had sitting in stock and cannot sell after the release of the 5050.. but if that were true why would they just not sell them as new at reduced price? The only answer would be ... they do not allow refund's on refurb.. but do allow on new.. so maybe there are a mixture of new and returned units being sold... who knows... we can only guess as they will never tell us...
jblade44 is offline  
post #569 of 818 Old 07-05-2019, 02:46 PM
AVS Forum Special Member
 
WynsWrld98's Avatar
 
Join Date: Nov 1999
Location: Puyallup, WA
Posts: 3,093
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 575 Post(s)
Liked: 217
I called the Epson rebate line at 800-277-6187 to ask about my situation bought 5040 refurb in June, it was defective, a replacement was shipped in July so should I use the June or July lamp rebate form. The person told me the lamp rebate cannot be used for refurb purchases. Of course I'll submit it anyway and hope for the best. So I asked her if the projector had been new for this situation which form to submit and she said July so that's what I'll do.

But those buying the refurb 5040s and submitting the free lamp form are you actually getting the free lamps?
WynsWrld98 is offline  
post #570 of 818 Old 07-05-2019, 02:52 PM
Newbie
 
Join Date: Jun 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Just received my 2nd one and so far so good. No issues so far but have to go through the total setup and testing to determine then calibration but no big issues over the last hour.

For those that believe they are receiving new ones, did yours come in a box that says refurb? Both my first and 2nd were in refurb boxes but packages properly with foam, etc. Just wondering if everyone's comes in the refurb box or not?
Allan Weinman is offline  
Sponsored Links
Advertisement
 
Reply Front Projectors Great Found Deals!

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off