Refurbished Epson 5040UB - $1,151.00 - Page 25 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 149Likes
Reply
 
Thread Tools
post #721 of 765 Old 09-05-2019, 02:05 PM
Member
 
Join Date: Jul 2019
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 0
How long before we see 5050 refurbs? I feel sorta stupid for missing out on the $2699 deal for the 5050 but now I've been waiting so long I'm thinking I should hold out for an EVEN BETTER deal, haha.
sirius_basterd is offline  
Sponsored Links
Advertisement
 
post #722 of 765 Old 09-06-2019, 07:44 AM
AVS Forum Special Member
 
Ladeback's Avatar
 
Join Date: Apr 2015
Location: Kansas City
Posts: 2,528
Mentioned: 74 Post(s)
Tagged: 0 Thread(s)
Quoted: 1368 Post(s)
Liked: 500
Send a message via MSN to Ladeback
Quote:
Originally Posted by sirius_basterd View Post
How long before we see 5050 refurbs? I feel sorta stupid for missing out on the $2699 deal for the 5050 but now I've been waiting so long I'm thinking I should hold out for an EVEN BETTER deal, haha.
I would think it would be another year when it gets closer to a new model coming out. The 5050 is still rather new. Now I have seen some people say that Epson has sent them a 5050 in exchange of the 5040 if they have had a lot of problems. The 5050 may go on sale around Christmas if you can wait.

Klipsch KPS-400’s FR/FL with built in 15” 300 watt side firing subs, RC-7 Center, RS-3 Surrounds.
Integra DHC-60.5, 5- Marantz MA700 Mono Blocks, Pioneer DV-F727 301 Disk DVD CD Changer, Pioneer DVL-909 Laserdisc/DVD/CD Player, Sony PS3.
https://www.avsforum.com/forum/19-ded...ck-cinema.html
Ladeback is offline  
post #723 of 765 Old 09-06-2019, 02:17 PM
AVS Forum Special Member
 
rob80b's Avatar
 
Join Date: Sep 2007
Location: Toronto, Ontario
Posts: 1,986
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 210 Post(s)
Liked: 129
Quote:
Originally Posted by BillyBarcode` View Post
Hi, Rick...My 5040UB refurb showed up yesterday. This thing is a Monster! Unbelievable blacks, brightness and sharpness...so much more than my old HC3020. Some examples are attached. I couldn't be happier. Looks like I got a good one!

Does look good.....nice upgrade! .........curious, light controlled room?
rob80b is offline  
Sponsored Links
Advertisement
 
post #724 of 765 Old 09-06-2019, 03:18 PM
Member
 
BillyBarcode`'s Avatar
 
Join Date: Jan 2016
Location: Carvel, Alberta, Canada
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Liked: 2
Quote:
Originally Posted by rob80b View Post
Does look good.....nice upgrade! .........curious, light controlled room?
Unfortunately; no. Right in the middle of the space is a HUGE skylight that I have to hire a pro to deal with (it's 20 feet up), so my viewing is currently limited to dark hours. It's on the "list" though...
BillyBarcode` is offline  
post #725 of 765 Old 09-06-2019, 05:14 PM
Newbie
 
uga96gal's Avatar
 
Join Date: Feb 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Do we have any idea if Epson will ever have these refurbished units in Stock again?

Unfortunately missed out when they did have stock. I called but got the standard "we have no idea, keep checking back on the website" answer from the service rep.

Worried I may have missed out for good considering they sold a bunch of them over the summer and I would guess they aren't producing them anymore as they have moved on to the 5050ub.

Sent from my SM-N960U using Tapatalk
uga96gal is offline  
post #726 of 765 Old 09-08-2019, 04:09 PM
Member
 
Join Date: Oct 2018
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Liked: 30
Quote:
Originally Posted by uga96gal View Post
Do we have any idea if Epson will ever have these refurbished units in Stock again?

Unfortunately missed out when they did have stock. I called but got the standard "we have no idea, keep checking back on the website" answer from the service rep.

Worried I may have missed out for good considering they sold a bunch of them over the summer and I would guess they aren't producing them anymore as they have moved on to the 5050ub.

Sent from my SM-N960U using Tapatalk
They will definitely come back in stock. When I got mine in June, I had to wait two or three weeks to snag one. Sometimes they will stock just a few at a time, at odd hours of the day. Then after getting mine, they were out of stock for a solid month I think.

So just keep tabs on this thread, or have the Epson page loaded in your browser and just refresh once in a while.
Xavier3 is offline  
post #727 of 765 Old 09-09-2019, 03:37 PM
Advanced Member
 
aasoror's Avatar
 
Join Date: Dec 2007
Location: ON, Canada
Posts: 754
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 38
A quick question re the Canadian bulb rebate. Did you guys send the UPC from the box? The form PDF calls for one despite the US form (same promo id) mentioning nothing about it.

TIA
Dano2 likes this.
aasoror is offline  
post #728 of 765 Old 09-10-2019, 04:07 AM
Member
 
Join Date: Apr 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 1
Quote:
Originally Posted by aasoror View Post
A quick question re the Canadian bulb rebate. Did you guys send the UPC from the box? The form PDF calls for one despite the US form (same promo id) mentioning nothing about it.

TIA
I didn't send the actual UPC, but I did send a pic of it. Whole process took about 2 months.
aasoror likes this.
Rick Lajeunesse is offline  
post #729 of 765 Old 09-10-2019, 05:55 AM
Member
 
danger dan's Avatar
 
Join Date: Jan 2005
Location: Chicago
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 18
Welp, lost at refurb roulette game. Just finished a new 2.35:1 accoustically transparent screen theater build and now projector is shutting itself down. Started happening at the 87 hour mark. Back it goes. Was working fine up until this point.

Edit: Spoke to Epson. Apparently the latest gen Apple TV 4K streamer I just introduced into my system is the culprit. It's sending an ir blast when in sleep mode that is shutting off the projector. Workaround is to go into settings-general and change sleep mode to never. Also need to turn off the control receiver function. Problem appears to be solved.

DANger

Last edited by danger dan; 09-11-2019 at 05:18 AM.
danger dan is offline  
post #730 of 765 Old 09-10-2019, 09:00 AM
Advanced Member
 
aasoror's Avatar
 
Join Date: Dec 2007
Location: ON, Canada
Posts: 754
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 38
Quote:
Originally Posted by Rick Lajeunesse View Post
I didn't send the actual UPC, but I did send a pic of it. Whole process took about 2 months.
Thanks, I appreciate the reply
aasoror is offline  
post #731 of 765 Old 09-12-2019, 10:02 AM
Member
 
BillyBarcode`'s Avatar
 
Join Date: Jan 2016
Location: Carvel, Alberta, Canada
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Liked: 2
Quote:
Originally Posted by aasoror View Post
A quick question re the Canadian bulb rebate. Did you guys send the UPC from the box? The form PDF calls for one despite the US form (same promo id) mentioning nothing about it.

TIA
Nope...I don't think they have that offer for Canadians. I didn't get one. I bought a refurb just over a week ago, and it came with the projector, a remote with batteries and a power cord.
BillyBarcode` is offline  
post #732 of 765 Old 09-12-2019, 10:12 AM
Member
 
BillyBarcode`'s Avatar
 
Join Date: Jan 2016
Location: Carvel, Alberta, Canada
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Liked: 2
Quick question for any 5040UB owners....

I purchased a refurb just over a week ago, and while the projector throws a beautiful image, every once in awhile, the picture suddenly and unexpectedly goes black for a few seconds, and the comes back. This happens on both broadcast and Bluray. Before I call Epson, has anyone else had this happen?
BillyBarcode` is offline  
post #733 of 765 Old 09-12-2019, 11:21 AM
Member
 
Nightwing-DG's Avatar
 
Join Date: Nov 2012
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 12
Quote:
Originally Posted by BillyBarcode` View Post
Quick question for any 5040UB owners....

I purchased a refurb just over a week ago, and while the projector throws a beautiful image, every once in awhile, the picture suddenly and unexpectedly goes black for a few seconds, and the comes back. This happens on both broadcast and Bluray. Before I call Epson, has anyone else had this happen?
Hasn't happened to me. Could be an HDMI issue. Have tried swapping to a different cable?
Nightwing-DG is offline  
post #734 of 765 Old 09-12-2019, 01:40 PM
Member
 
Join Date: Oct 2018
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Liked: 30
Quote:
Originally Posted by BillyBarcode` View Post
Nope...I don't think they have that offer for Canadians. I didn't get one. I bought a refurb just over a week ago, and it came with the projector, a remote with batteries and a power cord.
The lamp rebate is in fact valid for Canadians. I got a lamp recently from submitting mine, although it took 2.5 months.

Here is the link for the Canadian form, make sure you fill it out. That’s a $250 lamp for free!

https://mediaserver.goepson.com/ImCo...MIR%20(EN).pdf
aasoror and BillyBarcode` like this.
Xavier3 is offline  
post #735 of 765 Old 09-12-2019, 02:18 PM
Advanced Member
 
aasoror's Avatar
 
Join Date: Dec 2007
Location: ON, Canada
Posts: 754
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 38
Quote:
Originally Posted by BillyBarcode` View Post
Nope...I don't think they have that offer for Canadians. I didn't get one. I bought a refurb just over a week ago, and it came with the projector, a remote with batteries and a power cord.
The offer doesn't come in the box, if your purchase date is before Sep 1st, then you qualify.
BillyBarcode` likes this.
aasoror is offline  
post #736 of 765 Old 09-12-2019, 02:49 PM
Member
 
BillyBarcode`'s Avatar
 
Join Date: Jan 2016
Location: Carvel, Alberta, Canada
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Liked: 2
Quote:
Originally Posted by Nightwing-DG View Post
Hasn't happened to me. Could be an HDMI issue. Have tried swapping to a different cable?
Kinda hard to do. When we renovated, I installed a 25 foot HDMI cable that goes from my AV receiver through the wall, under the floor, and up a pillar to where the projector is hanging. (This happened about 6 years ago when I bought my first projector, and HC3020, and it was fine, however when I got my 5040UB, the "blanking" started happening). It'll be a pain to change the cable, but I can get a newer one that is 16 Gbit and 4K compatible, and if it stops the problem, I guess I have to find a way to replace the existing one. I saw a 25 footer the other day that was 4K compatible, and it was just 40 bucks Canadian, so it may be worth a try. I guess I'll call Epson Tech Support before I do, and see what they say. I have a feeling that you are right, though.

Thanks for the help.

Last edited by BillyBarcode`; 09-12-2019 at 03:04 PM.
BillyBarcode` is offline  
post #737 of 765 Old 09-12-2019, 02:51 PM
Member
 
BillyBarcode`'s Avatar
 
Join Date: Jan 2016
Location: Carvel, Alberta, Canada
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 27 Post(s)
Liked: 2
Quote:
Originally Posted by Xavier3 View Post
The lamp rebate is in fact valid for Canadians. I got a lamp recently from submitting mine, although it took 2.5 months.

Here is the link for the Canadian form, make sure you fill it out. That’s a $250 lamp for free!

https://mediaserver.goepson.com/ImCo...MIR%20(EN).pdf
Well, I guess I missed it. The projector was purchased the first week of September.
BillyBarcode` is offline  
post #738 of 765 Old 09-12-2019, 04:03 PM
Advanced Member
 
aasoror's Avatar
 
Join Date: Dec 2007
Location: ON, Canada
Posts: 754
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 38
Quote:
Originally Posted by BillyBarcode` View Post
Kinda hard to do. When we renovated, I installed a 25 foot HDMI cable that goes from my AV receiver through the wall, under the floor, and up a pillar to where the projector is hanging. (This happened about 6 years ago when I bought my first projector, and HC3020, and it was fine, however when I got my 5040UB, the "blanking" started happening). It'll be a pain to change the cable, but I can get a newer one that is 16 Gbit and 4K compatible, and if it stops the problem, I guess I have to find a way to replace the existing one. I saw a 25 footer the other day that was 4K compatible, and it was just 40 bucks Canadian, so it may be worth a try. I guess I'll call Epson Tech Support before I do, and see what they say. I have a feeling that you are right, though.

Thanks for the help.
You will be asked to check with another HDMI cable, HDMI source and to try both ports, you might want to do that first (with a shorter cable and/or a fireTV stick or something and get your existing setup out of the equation) to rule out a defective HDMI port.
aasoror is offline  
post #739 of 765 Old 09-13-2019, 04:57 AM
AVS Forum Special Member
 
rob80b's Avatar
 
Join Date: Sep 2007
Location: Toronto, Ontario
Posts: 1,986
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 210 Post(s)
Liked: 129
Quote:
Originally Posted by BillyBarcode` View Post
Quick question for any 5040UB owners....

I purchased a refurb just over a week ago, and while the projector throws a beautiful image, every once in awhile, the picture suddenly and unexpectedly goes black for a few seconds, and the comes back. This happens on both broadcast and Bluray. Before I call Epson, has anyone else had this happen?

Hi Billy....yep had this same thing happen with my new 4030 and then started inquiring about a new HDMI cable...but before replacing the 50' cable, which worked fine for the last few years before swapping projectors, I cleaned all the contacts on the HDMI cables and devices...presto problem went away.

Now the 5040 is a different beast but if your only transmitting 1080p hopefully yours is a similar issue, I'd give a try.
https://www.avsforum.com/forum/68-di...l#post57903652


Quote:
Originally Posted by rob80b View Post
Hi Guys......

Just a follow....before investing in new cables in a situation where all was well but then things start to act up.....I figured that if my audio connections, RCA, balanced and speaker spades need periodic cleaning to remove any oxidization to improve signal flow the tiny HDMI pins are definitely candidates for a bit of house cleaning.

Having on hand some Credit Card cleaning cards in my shop I thought I'd give my cables and connections a once over by just using the corner ....by delicately inserting the moistened corner of the card in the opening of the cable or component just give a gentle sweeps back and forth a few times, I imagine one could also use a thicker porous business card with the corner dipped in alcohol or invest in some blotter paper.
Needless to say any errant dropouts appear to have stopped. (for now)
rob80b is offline  
post #740 of 765 Old 09-13-2019, 12:51 PM
Senior Member
 
starlights's Avatar
 
Join Date: Nov 2003
Location: Under the nearest Rock
Posts: 366
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Liked: 36
Quote:
Originally Posted by BillyBarcode` View Post
Kinda hard to do. When we renovated, I installed a 25 foot HDMI cable that goes from my AV receiver through the wall, under the floor, and up a pillar to where the projector is hanging. (This happened about 6 years ago when I bought my first projector, and HC3020, and it was fine, however when I got my 5040UB, the "blanking" started happening). It'll be a pain to change the cable, but I can get a newer one that is 16 Gbit and 4K compatible, and if it stops the problem, I guess I have to find a way to replace the existing one. I saw a 25 footer the other day that was 4K compatible, and it was just 40 bucks Canadian, so it may be worth a try. I guess I'll call Epson Tech Support before I do, and see what they say. I have a feeling that you are right, though.

Thanks for the help.

If you find that its indeed your HDMI cable that needs replacement, and that its a tough job to change the inwall HDMI cable frequently, it would be a good idea to go forward one time with an optical HDMI cable to future proof yourself. Just a suggestion.
BillyBarcode` likes this.
starlights is offline  
post #741 of 765 Old 09-14-2019, 06:31 AM
Senior Member
 
Join Date: Jun 2018
Posts: 344
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 198 Post(s)
Liked: 88
Quote:
Originally Posted by danger dan View Post
Welp, lost at refurb roulette game. Just finished a new 2.35:1 accoustically transparent screen theater build and now projector is shutting itself down. Started happening at the 87 hour mark. Back it goes. Was working fine up until this point.

Edit: Spoke to Epson. Apparently the latest gen Apple TV 4K streamer I just introduced into my system is the culprit. It's sending an ir blast when in sleep mode that is shutting off the projector. Workaround is to go into settings-general and change sleep mode to never. Also need to turn off the control receiver function. Problem appears to be solved.
Holy CRAP! You may have just diagnosed my problem! Mine was doing the same thing. I am headed down to check out my appletv settings!
ipca204 is offline  
post #742 of 765 Old 09-15-2019, 10:50 AM
Member
 
Join Date: Oct 2018
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Liked: 30
Quote:
Originally Posted by ipca204 View Post
Holy CRAP! You may have just diagnosed my problem! Mine was doing the same thing. I am headed down to check out my appletv settings!
Isn’t this also referred to as HDMI CEC? It’s an equipment control protocol for streaming boxes etc., and can control power and certain functions to connected TV and projector. That is certainly a good idea to turn that off. Seems the Apple TV is a bit more aggressive with this feature.
Xavier3 is offline  
post #743 of 765 Old 09-15-2019, 02:06 PM
Senior Member
 
Join Date: Jun 2018
Posts: 344
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 198 Post(s)
Liked: 88
Quote:
Originally Posted by Xavier3 View Post
Isn’t this also referred to as HDMI CEC? It’s an equipment control protocol for streaming boxes etc., and can control power and certain functions to connected TV and projector. That is certainly a good idea to turn that off. Seems the Apple TV is a bit more aggressive with this feature.
no, I ALWAYS have CEC is turned off. It causes me more problems than it is worth. I guess what I am wondering is how the apple tv is emitting IR? and why?
ipca204 is offline  
post #744 of 765 Old 09-16-2019, 03:47 PM
Member
 
Join Date: Oct 2018
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Liked: 30
Quote:
Originally Posted by ipca204 View Post
no, I ALWAYS have CEC is turned off. It causes me more problems than it is worth. I guess what I am wondering is how the apple tv is emitting IR? and why?
Oic....that is very odd

I’ve had a 4K Fire Stick connected to my 5040ub without issues. Seems like a software or firmware glitch with the Apple TV.
Xavier3 is offline  
post #745 of 765 Old 09-17-2019, 02:19 PM
Newbie
 
davvos's Avatar
 
Join Date: Feb 2011
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
10 refurbished added to stock earlier today - down to 6 left (2pm PST)


EDIT: back up to 13 available so more being added apparently

Last edited by davvos; 09-17-2019 at 03:20 PM.
davvos is offline  
post #746 of 765 Old 09-17-2019, 03:02 PM
Member
 
Suburban1's Avatar
 
Join Date: Nov 2008
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Liked: 10
Got one. Advice on what to look for to make sure it's a good one
Suburban1 is offline  
post #747 of 765 Old 09-17-2019, 06:26 PM
Senior Member
 
tibimakai's Avatar
 
Join Date: Dec 2011
Location: Los Angeles CA
Posts: 328
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 173 Post(s)
Liked: 49
How do you guys know, how many are in stock?

Living Room: Samsung UN65JS8500, Onkyo TX-NR656, Klipsch R-28F, Klipsch RC-62II, Klipsch R-14S, Polk Audio 80 FX/RT(Atmos)
Bedroom: Samsung UN55MU6290, Onkyo TX-RZ610, Onkyo & Fluance speakers
Garage: Benq HT2050A, Elite Screens 125" motorized screen, Klipsch RP-160M, Klipsch RP-150M, Klipsch RP-450C , 2 x Klipsch CDT-3800 II for Atmos, Klipsch RW10
tibimakai is offline  
post #748 of 765 Old 09-17-2019, 06:47 PM
Senior Member
 
Join Date: Jun 2018
Posts: 344
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 198 Post(s)
Liked: 88
Quote:
Originally Posted by tibimakai View Post
How do you guys know, how many are in stock?
I use several super computers linked together to break into the encryption on the Epson website. Some other people simply type 999 in the order box and then it will come back and say only "X" are available. I feel the second way is too lazy and lacks imagination... :-)
Archaea likes this.
ipca204 is offline  
post #749 of 765 Old 09-17-2019, 06:54 PM
Senior Member
 
tibimakai's Avatar
 
Join Date: Dec 2011
Location: Los Angeles CA
Posts: 328
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 173 Post(s)
Liked: 49
Ha ha ha. I have tried almost the same thing and it came back with 4. The 4th is mine. I have just placed an order.
I see, that there is no more free bulb rebate.

Living Room: Samsung UN65JS8500, Onkyo TX-NR656, Klipsch R-28F, Klipsch RC-62II, Klipsch R-14S, Polk Audio 80 FX/RT(Atmos)
Bedroom: Samsung UN55MU6290, Onkyo TX-RZ610, Onkyo & Fluance speakers
Garage: Benq HT2050A, Elite Screens 125" motorized screen, Klipsch RP-160M, Klipsch RP-150M, Klipsch RP-450C , 2 x Klipsch CDT-3800 II for Atmos, Klipsch RW10
tibimakai is offline  
post #750 of 765 Old 09-18-2019, 04:08 AM
Member
 
Join Date: Jun 2016
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 23 Post(s)
Liked: 6
Well its been a little over 8 weeks and i just got a notice from ups that my bulb is on the way.
carlb1 is offline  
Sponsored Links
Advertisement
 
Reply Front Projectors Great Found Deals!

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off