AVS Forum | Home Theater Discussions And Reviews (https://www.avsforum.com/forum/)
-   Blu-ray Player Great Found Deals! (https://www.avsforum.com/forum/202-blu-ray-player-great-found-deals/)
-   -   Sony - UBP-X700 On Sale for $128 (https://www.avsforum.com/forum/202-blu-ray-player-great-found-deals/3100780-sony-ubp-x700-sale-128-a.html)

tarzan1234 11-07-2019 07:58 AM

Sony - UBP-X700 On Sale for $128
 
It's on sale pretty much everywhere for around 128 to 130 bucks.

https://www.bhphotovideo.com/c/produ...d_blu_ray.html

84lion 11-07-2019 02:33 PM

I noticed this in the Target Black Friday ad for $130. Amazon's got it for $128. I'm tempted to pull the trigger. Looks like a great deal.

caz33 11-12-2019 06:56 PM

Along the same lines the X800M2 is on the Best Buy Black Friday ad for $199. Also really tempting.

Mike__P 11-26-2019 08:56 AM

Back to $128 at Amazon

pilotart 11-26-2019 12:54 PM

Great deal and so's the 800 at $198
 
Quote:

Originally Posted by Mike__P (Post 58875758)
Back to $128 at Amazon

Ordered this $128 plus tax deal with guaranteed tomorrow delivery
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

and canceled successfully in 20 minutes to order the Sony Ubp-X800M2 at $198 w/o tax, delivered next Tuesday instead.

https://smile.amazon.com/Sony-Ubp-X8...y%2C170&sr=1-1

Don't need Bluetooth but my BX510 (also a 'lightweight' model) had failed. Hope the heavy version holds up better.
Art

Ericglo 11-29-2019 08:16 PM

Amazon has a refreshed version of this player for $75. I assume it is a refurb. Any one try these?

GoLaLakers 11-30-2019 05:52 PM

Managed to pick up a manufactured refurbished unit on Ebay for $60. They went quick, 713 units sold. Comes with 90 day warranty so that should tell me if I have a faulty unit.

DirkBelig 12-02-2019 10:15 AM

Quote:

Originally Posted by pilotart (Post 58877098)
Don't need Bluetooth but my BX510 (also a 'lightweight' model) had failed. Hope the heavy version holds up better.

FWIW, my X800 (purchased July 2017) was always flaky and appears to have died on me. Had frequent freeze-ups requiring unplugging the power cord which was a PITA when the power strip was easily accessible, but is a MAJOR PITA now that I have the strip buried behind my TV stand. It was stored for over a year while I house-hunted and then moved, but had been perfectly behaved at my new house since April until a couple nights ago when it wouldn't turn on and unplugging (even leaving unplugged for over 12 hours) had no effect. Extremely disappointing.


Pulled the trigger on an X700 because it's $75 cheaper than the X800M2 and obviously being built like a tank didn't prevent my X800 from defecating the sleeping place. :mad:

UHDFAN1 12-02-2019 01:01 PM

Quote:

Originally Posted by DirkBelig (Post 58902372)
FWIW, my X800 (purchased July 2017) was always flaky and appears to have died on me.

Pulled the trigger on an X700 because it's $75 cheaper than the X800M2 and obviously being built like a tank didn't prevent my X800 from defecating the sleeping place. :mad:

You're not the 1st person to report transitioning away from the X800 to the X700...there are other posts.


All times are GMT -7. The time now is 08:36 AM.

Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.