AVS Forum | Home Theater Discussions And Reviews (https://www.avsforum.com/forum/)
-   Digital Hi-End Projectors - $3,000+ USD MSRP (https://www.avsforum.com/forum/24-digital-hi-end-projectors-3-000-usd-msrp/)
-   -   Official JVC RS520/RS620 (X7500/X9500) Owner's Thread (https://www.avsforum.com/forum/24-digital-hi-end-projectors-3-000-usd-msrp/2729761-official-jvc-rs520-rs620-x7500-x9500-owners-thread.html)

desertdome 01-26-2017 01:51 PM

Official JVC RS520/RS620 (X7500/X9500) Owner's Thread
 
6 Attachment(s)

Javs 01-26-2017 02:06 PM

Congrats! The 420 is a diff projector with large enough differences that owners may get confused if we talk about things in here that those projectors lack.

Best to leave them out as per the last series of threads.

Craig Peer 01-26-2017 03:27 PM

Quote:

Originally Posted by desertdome (Post 50235745)
My new JVC RS520 has just arrived! I am upgrading from the RS500. I can add the RS420/X5500 to this thread if desired.

https://www.avsforum.com/forum/attach...1&d=1485466285

Unboxing pics will be added.

CES 2017 News Release regarding new models

DLA-RS520/X7500 Brochure

DLA-RS620/X9500 Brochure

JVC 2017 DLA Projector Manual

JVC Projector Calibration Software V9 (Note: Cannot be used with RS500/RS600 or X7000/X9000)

Nice ! Let me know what the " graphics " setting does.

Javs 01-26-2017 03:36 PM

I have an X9500 on order now, I will not get it until mid Feb though, but luckily I will be away on a tropical island until the 10th!

But those last 5-7 days when I get back are going to suck with no PJ in the house!

jedimastergrant 01-26-2017 03:57 PM

1 Attachment(s)
Ditto

Thanks to High Impact AV for getting this baby here fast! @desertdome

Michael will be doing a professional calibration on my 520 right before the KC Home theater crawl next month!

Now for the unboxing!!!

Javs 01-26-2017 04:05 PM

Quote:

Originally Posted by jedimastergrant (Post 50239177)
Ditto

Thanks to High Impact AV for getting this baby here fast! @desertdome

Michael will be doing a professional calibration on my 520 right before the KC Home theater crawl next month!

Now for the unboxing!!!

OK,

I am just going to say this now, EVERYONE who buys one of these puppies has to do the thumbs up with the box. Bonus points for the box being in the trunk of your car.

This is going to be hilarious.

http://i.imgur.com/0B91UvG.jpg

jedimastergrant 01-26-2017 04:54 PM

4 Attachment(s)
Let's see what's inside!

Ooooh shiny!!!!!!

jedimastergrant 01-26-2017 04:56 PM

Quote:

Originally Posted by Javs (Post 50239433)
Quote:

Originally Posted by jedimastergrant (Post 50239177)
Ditto

Thanks to High Impact AV for getting this baby here fast! @desertdome

Michael will be doing a professional calibration on my 520 right before the KC Home theater crawl next month!

Now for the unboxing!!!

OK,

I am just going to say this now, EVERYONE who buys one of these puppies has to do the thumbs up with the box. Bonus points for the box being in the trunk of your car.

This is going to be hilarious.

http://i.imgur.com/0B91UvG.jpg

Haha! Yeah it was just a spontaneous thing I did when I posted to the KC crawl thread. Then Michael did it too when he started this thread.

Love it!!!

jedimastergrant 01-26-2017 05:15 PM

14 Attachment(s)
And so it takes its rightful place alongside Pinata Lord Vader!

2 Stangs 01-26-2017 05:32 PM

I can't wait to hear how you think this compares to your old RS500.

Tom Bley 01-26-2017 06:41 PM

Quote:

Originally Posted by 2 Stangs (Post 50241177)
I can't wait to hear how you think this compares to your old RS500.

Old RS500 :D

Naylorman32 01-26-2017 06:46 PM

i get my 620 tomorrow. still have my lightly used 600 for sale if anyone's looking for a bargain :)

jedimastergrant 01-26-2017 07:25 PM

19 Attachment(s)
Of course the pictures never look exactly like what I am seeing on screen. But here is the obligatory iPhone pics of 1080p material from 2016 Dolby demo disc. I am just rolling with natural mode untouched.

So far I am very very impressed. And that is coming from an rs 400!!!

jedimastergrant 01-27-2017 05:09 AM

I like the automatic switching to HDR. So far the mode appears to look very natural without any tweaking.

http://i163.photobucket.com/albums/t...a.jpg~original

http://i163.photobucket.com/albums/t...j.jpg~original

batman31 01-27-2017 09:06 AM

I have the same projector and connected it a few days ago! In trying to connect my roku ultra I noticed I wasnt getting 4k UHD (option was grayed out). Lat night I tried to connect my OPPO DVD and couldnt get a picture. I removed my receiver from the equation and same result?

HDMI Cable??

Any thoughts? Supposedly the cable was certified for 18gbps per second?? Is there a setting on the projector I am missing? Or do I need to run a new cable in the wall?

If I do need a new HDMI does anyone have any recommendations??

Craig Peer 01-27-2017 09:08 AM

Quote:

Originally Posted by jedimastergrant (Post 50249081)
I like the automatic switching to HDR. So far the mode appears to look very natural without any tweaking.

[IMG]http://i163.photobucket.com/albums/t...ps9gaupfta.jpg[/IMG]

[IMG]http://i163.photobucket.com/albums/t...psxvxupywj.jpg[/IMG]

That's excellent news !

stanger89 01-27-2017 09:23 AM

Can the masking be tied to the lens memories? Eg so the masking is automatically applied when you pick a scope lens memory?

Naylorman32 01-27-2017 05:23 PM

havent set mine up yet. anyone have any initial thoughts on the low lag mode?

Javs 01-27-2017 05:27 PM

Quote:

Originally Posted by jedimastergrant (Post 50249081)
I like the automatic switching to HDR. So far the mode appears to look very natural without any tweaking.

Looking good. What are your settings here, is this literally default HDR ? Because I heard that clips at 2000nits by default? Do you have your contrast on 0?

You should be able to bump it up to around +8 or so to clip 1200nits.

Do you find you need to be in high lamp, what iris position etc?

desertdome 01-27-2017 06:13 PM

I added some pictures to the first post. I'll be swapping my RS500 for the RS520 tonight.

The remote has changed for 2017.

https://www.avsforum.com/forum/attach...1&d=1485569486

jedimastergrant 01-27-2017 06:22 PM

Quote:

Originally Posted by Javs (Post 50270857)
Looking good. What are your settings here, is this literally default HDR ? Because I heard that clips at 2000nits by default? Do you have your contrast on 0?

You should be able to bump it up to around +8 or so to clip 1200nits.

Do you find you need to be in high lamp, what iris position etc?

Literally default HDR. I have done no changes to any settings. It is 100 percent out of the box. I was pressed for time last night. I will try to do some more tinkering here soon. I actually did not even check to see what the default HDR settings are! So I will get back to you. My RS 400 did need to be in high lamp for HDR for sure.

BTW I am using a 110'' wide 2.35:1 EN4K screen. So the gain is advertised at 1.0 but has been measured closer to 0.8.

Tonight I am going to try to close the iris to -4 or -5 on 16:9 as was suggested to me. It seems very very bright right now. Don't get me wrong.......I love it. But, I don't want to get used to an overly bright screen. It will be calibrated in 3 weeks by Michael who started this thread. I do have a light meter so I guess I could check if I had some time. I suspect it is more than the recommended 14-17 foot lamberts at the moment when in LOW lamp mode for 16:9. I had the sides masked for those pictures so it was a bit smaller than my 2.35 image.

kaotikr1 01-27-2017 08:00 PM

Quote:

Originally Posted by Naylorman32 (Post 50270769)
havent set mine up yet. anyone have any initial thoughts on the low lag mode?



I am very happy with the low latency mode. I came from an RS500 and HW45ES and this is an excellent all in one projector.

desertdome 01-27-2017 08:08 PM

Quote:

Originally Posted by Craig Peer (Post 50238401)
Nice ! Let me know what the " graphics " setting does.

MPC had "Original Resolution" on the old models and it is now called "Graphic Mode." There are two options: 4K or 2K. Auto is no longer an option. See page 34 of the manual. Is this what you are asking about?

afss_br 01-28-2017 03:03 PM

Is CMD Improved ?
 
I am a big fan of CMD (I currently have an RS4910) - I have read that CMD does not work very well in 4K on the RS500 (it definitively does not work well on my RS4910 in 4K, even thought it's really good in 1080p).

Please, could you report if it is it improved on the RS520 ?

This would be a good incentive for me to consider an upgrade.

Regards.

Craig Peer 01-28-2017 07:28 PM

Quote:

Originally Posted by afss_br (Post 50293073)
I am a big fan of CMD (I currently have an RS4910) - I have read that CMD does not work very well in 4K on the RS500 (it definitively does not work well on my RS4910 in 4K, even thought it's really good in 1080p).

Please, could you report if it is it improved on the RS520 ?

This would be a good incentive for me to consider an upgrade.

Regards.

I haven't found that to be true in my case with my RS600.

jedimastergrant 01-29-2017 01:08 PM

Quote:

Originally Posted by Naylorman32 (Post 50270769)
havent set mine up yet. anyone have any initial thoughts on the low lag mode?

I tried it out today and I cannot detect any lag at all. I am not a pro gamer but Resogun is a very demanding twitch shooter.

http://i163.photobucket.com/albums/t...d.jpg~original

http://i163.photobucket.com/albums/t...w.jpg~original


This was the setting I changed. It is off by default. This was a big reason I upgraded from the RS 400. I guess I can't blame my bad gaming skills on my projector any more!

Javs 01-29-2017 01:18 PM

Quote:

Originally Posted by jedimastergrant (Post 50315561)
I tried it out today and I cannot detect any lag at all. I am not a pro gamer but Resogun is a very demanding twitch shooter.

This was the setting I changed. It is off by default. This was a big reason I upgraded from the RS 400. I guess I can't blame my bad gaming skills on my projector any more!

Do you notice any change at all in image quality or even flicker when low lag mode is on?

I am thinking it the image is just as sharp I will just permanently leave this mode on.

I noticed in the Cine4Home comparison that the pendulum in the video actually appeared to have better motion with the low lag mode on.

jedimastergrant 01-29-2017 01:24 PM

Quote:

Originally Posted by Javs (Post 50270857)
Looking good. What are your settings here, is this literally default HDR ? Because I heard that clips at 2000nits by default? Do you have your contrast on 0?

You should be able to bump it up to around +8 or so to clip 1200nits.

Do you find you need to be in high lamp, what iris position etc?

Here is a pic of at least some of my default HDR settings. I did not change anything.

http://i163.photobucket.com/albums/t...q.jpg~original

http://i163.photobucket.com/albums/t...y.jpg~original

So the lamp is in high mode with HDR and I like it that way. However, for any other content I have been in low lamp mode and been very pleased. We will see how that changes if at all post calibration.

On 1080p content I played around with the manual iris settings and even at -6 I had PLENTY of brightness. I am pretty sure I will end up closing it down even further.

jedimastergrant 01-29-2017 01:29 PM

Quote:

Originally Posted by Javs (Post 50315833)
Do you notice any change at all in image quality or even flicker when low lag mode is on?

I am thinking it the image is just as sharp I will just permanently leave this mode on.

I noticed in the Cine4Home comparison that the pendulum in the video actually appeared to have better motion with the low lag mode on.

Oh, good to know. I did not try the low latency mode with any other content besides games. But, I didn't notice anything out of the ordinary with it. It would be nice to leave it in that setting and save an extra step every time you want to play a game.

I will try it out with some other stuff tonight if I get a chance. For now the kids just got back and I am officially on duty!

Javs 01-29-2017 01:31 PM

Quote:

Originally Posted by jedimastergrant (Post 50316145)
Oh, good to know. I did not try the low latency mode with any other content besides games. But, I didn't notice anything out of the ordinary with it. It would be nice to leave it in that setting and save an extra step every time you want to play a game.

I will try it out with some other stuff tonight if I get a chance. For now the kids just got back and I am officially on duty!

Great, if you get a chance, find a still frame with lots of complexity in it and see if toggling the mode on and off reduces any of the sharpness. I am sure it wont, but good to check, Then you can look at actual motion.


All times are GMT -7. The time now is 12:08 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.