Turtle Beach SPDIF USB. Shows 5.1 but Stereo - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 04-18-2016, 11:05 AM - Thread Starter
AVS Forum Special Member
 
PanamaMike's Avatar
 
Join Date: Nov 2000
Location: Austin, TX, US
Posts: 2,803
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Question Turtle Beach SPDIF USB. Shows 5.1 but Stereo

I'm using a MS Surface 1.0 as an HTPC so that I can miracast to a PicoAir and get 5.1 via TOSLink SPDIF via Turtle Beach.


I'm using Media Center Classic to playback a DVD. Things seem to be working fine meaing I've been able to get the receiver to see the digital signal and it even lights up all of the separate channels. However, it's only playing two channels? Displays Stereo on the receiver.


I go to Sound/Playback/Configure and have set the 5.1 configuration test and send a sound signal L, R, C ect. and the sound only plays via the L, R. Note, it only allows me to do that in the Speaker Device Icon, not the SPDIF Digital Out Icon.


I've got the TB hooked up via the Digital Out device. I turned on SPDIF output on the Media Player Classic. TB device has a check box on the DD and DTS formats. In Advance I have 16 bit, 48000 Hz (DVD Quality). I don't see an option for multi channel. I also have sub out off since I don't have a sub connected.


Any thoughts on how I can get the 5.1 working?


Regards,

Mike
PanamaMike is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-20-2016, 01:44 PM
Advanced Member
 
SteelWill's Avatar
 
Join Date: Jan 2003
Posts: 624
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 79 Post(s)
Liked: 39
Sounds like it's not bitsreaming, which you'll have to do to get 5.1 channels over toslink. There's a setup guide here to show you what to do in mpc-hc.
https://www.avsforum.com/forum/26-hom...tup-guide.html
SteelWill is offline  
post #3 of 3 Old 04-24-2016, 07:58 AM - Thread Starter
AVS Forum Special Member
 
PanamaMike's Avatar
 
Join Date: Nov 2000
Location: Austin, TX, US
Posts: 2,803
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Quote:
Originally Posted by SteelWill View Post
Sounds like it's not bitsreaming, which you'll have to do to get 5.1 channels over toslink. There's a setup guide here to show you what to do in mpc-hc.
https://www.avsforum.com/forum/26-hom...tup-guide.html
Thanks for the suggestion. Turns out I had things working fine on the PC side, I just needed to make an adjustment on the receiver side. I had it setup to pro logic, DPL II and this was causing the issue. When I flipped the mode on the receiver I was able to find DD. I thought I had tried that the first go around, but the setting was under a different menu. Happily the Turtle beach is working fine for pass thru mode.
PanamaMike is offline  
Sponsored Links
Advertisement
 
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off