Help with Kodi and LG 65C9 Oled with HDR - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
Reply
 
Thread Tools
post #1 of 40 Old 06-07-2019, 04:40 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Help with Kodi and LG 65C9 Oled with madVR

I got my LG 65C9 two days ago. I had no idea Kodi would look so terrible playing any 4k HDR mkv files. I have a GTX 1050 Ti in my Win 10 PC. I played a few mkv's via the USB port on the LG and it looks spectacular.

Many of the threads I find are very old about Kodi and HDR. I see lots of talk on madVR but I see some of the Kodi devs suggesting things have changed and you don't need to run dsplayer/madVR. So I have no idea where to start, what to do.

What can I do to get Kodi to play HDR without a lot of hassles? Is that possible?

Last edited by Gary Quiring; 06-08-2019 at 01:16 PM.
Gary Quiring is offline  
Sponsored Links
Advertisement
 
post #2 of 40 Old 06-07-2019, 04:47 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
Unfortunately, if you are using Kodi, there is some hassle on PC.

These are your two best options:

https://forum.kodi.tv/showthread.php?tid=209596

https://forum.kodi.tv/showthread.php?tid=222576
Onkyoman is offline  
post #3 of 40 Old 06-07-2019, 05:10 PM
Advanced Member
 
brazen1's Avatar
 
Join Date: Mar 2008
Posts: 880
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 568 Post(s)
Liked: 328
Here is HDR to SDR using Kodi v.19 on a 3 yr old Samsung with no special settings or extra components:



HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
W10 1903 / MPC-BE\HC / PotPlayer / PowerDVD 19 / DVDFab Player 3 / KODI 19 videoplayer
GTX960 4GB / RGB Full 4:4:4 / 8bit Desktop mode =60Hz / 10/12bit Video mode = Matched Refresh rates IE 23,24,25,60Hz
65JS8500 UHD HDR 3D / Denon S720W
brazen1 is offline  
Sponsored Links
Advertisement
 
post #4 of 40 Old 06-08-2019, 01:21 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
So I installed Kodi DSplayer edition and madVR. I am using Avatar 4k HDR mkv as my test. When I play the movie on a USB drive plugged directly into the LG TV the colors/clarity are beyond stunning. With DSPlayer, it's just ok. The colors are bland and it's not too sharp. I'm not sure where to start. I tried changing to HDR passthrough instead of letting madVR make that decision, it was a slight improvement. I tried changing the gamma settings with ctrl-S options and it does nothing.

So where do I start, what will tweak the colors?

https://imgur.com/a/RLmlLIL
Gary Quiring is offline  
post #5 of 40 Old 06-08-2019, 05:05 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
Did HDR mode engage on the TV? Are you using PC mode on the TV for the HTPC (I would recommend starting with the other video modes)?

I don't think Avatar was ever released in HDR. I don't know if that is a legitimate HDR test video.

If you configure the video levels correctly at the PC and TV and select passthrough HDR to display, you shouldn't have to do anything to the colors.
Onkyoman is offline  
post #6 of 40 Old 06-08-2019, 05:07 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Avatar is HDR, if I play the video off the USB port it shows the HDR logo in the upper right corner. And it's not just Avatar, all the movies have a bland color.
Gary Quiring is offline  
post #7 of 40 Old 06-08-2019, 05:08 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Quote:
Originally Posted by Onkyoman View Post
If you configure the video levels correctly at the PC and TV and select passthrough HDR to display, you shouldn't have to do anything to the colors.
Where would you do that?
Gary Quiring is offline  
post #8 of 40 Old 06-08-2019, 05:14 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
Under properties in madVR and in the picture menu in the LG. Set the Black Level on the TV to High and madVR to RGB 0-255. Same with the GPU: RGB 0-255.

The colors should be nearly identical if everything is working correctly.
Onkyoman is offline  
post #9 of 40 Old 06-08-2019, 05:17 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
Quote:
Originally Posted by Gary Quiring View Post
Avatar is HDR, if I play the video off the USB port it shows the HDR logo in the upper right corner. And it's not just Avatar, all the movies have a bland color.
I would guess that the input on the TV is set to PC mode.
Onkyoman is offline  
post #10 of 40 Old 06-08-2019, 06:03 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Quote:
Originally Posted by Onkyoman View Post
Under properties in madVR and in the picture menu in the LG. Set the Black Level on the TV to High and madVR to RGB 0-255. Same with the GPU: RGB 0-255.

The colors should be nearly identical if everything is working correctly.
I guess I'm confused where I should be making changes. Kodi has options and also I have the ctrl-S popup madVR options. What should Kodi be set to for Video Render, Manage Settings? (I have set to Load and Save DSplayer database)

In the Picture menu on the LG I don't have a black level for High. I do have a HDMI ULTRA HD Deep Color option.

Pressing control-S, madVR was set to RGB 0-255, where do I find the GPU setting?

Also Direct3D presentation, I changed that to DX11 (it was on 9) and now I get full oversaturated HDR colors. The skin tones are ok but probably a tad too strong. What should Direct3D be set to?
Gary Quiring is offline  
post #11 of 40 Old 06-09-2019, 04:57 AM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
DSPlayer should be set to Load from madVR active profile and not Load and Save with DSPlayer database. Video Renderer must be set to madVR, but only after you have installed madVR externally.

On the LG C9, Black Level is under Picture -> Picture Mode Settings. It should be set to High to match the PC.

I don't think you should be getting a poor HDR picture from any source with the C9.
Onkyoman is offline  
post #12 of 40 Old 06-09-2019, 05:06 AM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
These are my options for Picture Mode Settings:

https://imgur.com/a/M6fP8jH
Gary Quiring is offline  
post #13 of 40 Old 06-09-2019, 05:19 AM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
I can see the correct setting in the image posted under JUDDER SETTINGS in this review:

https://www.rtings.com/tv/reviews/lg/c9-oled/settings
Onkyoman is offline  
post #14 of 40 Old 06-09-2019, 11:38 AM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Ok, finally it's working well. Thank you for Onkyoman for pointing out the issues, that LG article on rtings.com really helped.

I still feel the LG internal media player is better but Kodi is close now. The main problem was my HDMI port was not set for PC. When I changed that the colors got corrected.

FYI, not sure how many know this but the LG media player is network friendly. I was able to configure my Synology NAS with their media server to work with the LG TV. It works very well and for anyone that does not use Kodi this is a nice alternative.
Gary Quiring is offline  
post #15 of 40 Old 06-09-2019, 12:15 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
I would still use the other video modes if possible. It should only be a matter of getting the correct video levels on one of the video modes. Using PC mode might cause a slight difference in color compared to the internal player. I think the two should be very close.
Onkyoman is offline  
post #16 of 40 Old 06-09-2019, 12:22 PM
Advanced Member
 
Snoogleheimer's Avatar
 
Join Date: Apr 2016
Location: Indpls. IN
Posts: 923
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 441 Post(s)
Liked: 211
Have you ever tested/auditioned an Nvidia Shield?

Epson 5040ub 125" 2.35:1 Silver Ticket (white)
Pioneer Elite SC-99, Pioneer Elite A-20, Pioneer Elite SP-EFS73 (L,R,C) / SP-EBS73 (S & RS) / SW-E10 (4)
Sony UBP-X800, Tablo TUNER, nVidia Shield Pro
Snoogleheimer is offline  
post #17 of 40 Old 06-10-2019, 12:17 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
My new receiver arrived today. My old was not 4k compatible. So since I programmed the HDMI port on the LG as 'PC' can I have other devices like my STB go into that 'PC' HDMI port? I was assuming I would have all HDMI go to the receiver first and then one cable to the LG.
Gary Quiring is offline  
post #18 of 40 Old 06-10-2019, 04:30 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
It should still work. There are plenty of LG OLED users out there who don't use the PC setting, so I still don't know why you would have to rely on it.

PC mode gives you 4:4:4 chroma, but the color representation can be a little different and you might have a higher chance of seeing color banding.
Onkyoman is offline  
post #19 of 40 Old 06-10-2019, 04:58 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
It's even more confusing, I found the option of the LG to show the resolution (left corner double click) and the receiver is down converting the 4k to 1080.
Gary Quiring is offline  
post #20 of 40 Old 06-10-2019, 05:13 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,578
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 893 Post(s)
Liked: 547
I did see your other thread.

A color space conversion could mean that you haven't set up the Pioneer receiver correctly for HDMI passthrough, you don't have the correct HDMI cables at both ends or the receiver is auto-detecting the PC and doing a color space conversion.

I haven't looked at the manual for your AVR, so I don't know how to configure it for 4K HDMI passthrough. It could be under inputs where you set the label for each source, but I don't know.

Your HDMI cables must be rated to carry an 18Gbps signal. They should indicate that they are compatible with 4K UHD content.

The color space conversion means the video levels are incorrect at the receiver. You need a chain of video levels from the PC to the AVR to the TV that ends in the same video levels.

This is the general idea:

https://kodi.wiki/view/Video_levels_and_color_space

If Black Level on the TV is set to High (0-255), you need to set all of your devices to RGB 0-255. If Black Level on the TV is set to Low (16-235), you need to set all of your devices to RGB 16-235 or YCbCr 16-235.

On the PC, you can get RGB 16-235 in two different ways.

The options that give you correct video levels are described here:

https://forum.kodi.tv/showthread.php...438#pid2739438
Onkyoman is offline  
post #21 of 40 Old 06-10-2019, 05:53 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
The cables are all the same and they do work when I plug them directly into the TV. So far I can't find anything in the Pioneer manual about 4k pass-through configuration.

These are what I have:
https://www.bhphotovideo.com/c/produ...s_HDMI_to.html
Gary Quiring is offline  
post #22 of 40 Old 06-11-2019, 08:20 AM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
I called Pioneer, 100% useless tech support and unfriendly jerk to top if off. Insisted it's the cable without hearing or wanting to know any details.

So off to BestBuy I went and bought a RocketFish 4ft HDMI cable 4k Ultra HD and HDR. It's labeled a Premium Certified Cable Y39 CNAEPVR, 18gps and to no surprise did nothing. The Pioneer receiver is still down converting the 4k to 1080.
Gary Quiring is offline  
post #23 of 40 Old 06-11-2019, 09:35 AM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Another test. I have an older PC with Intel graphics. Plugged that into the Pioneer and it passes 4k video! So this is an issue with NVidia and Pioneer.
Gary Quiring is offline  
post #24 of 40 Old 06-11-2019, 10:19 AM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Another interesting development, when the PC with Nvidia is going through the Pioneer the Nvidia panel shows the device as DVI.
Gary Quiring is offline  
post #25 of 40 Old 06-11-2019, 10:41 AM
AVS Forum Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 2,213
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 281 Post(s)
Liked: 110
Are the Pioneer and LG running the latest firmware?

Is the receiver able to pass a 4k signal to the tv from another source?

Tried all HDMI inputs on the tv?

I believe it is an issue with the receiver because I can last a 4k/60 signal through my receiver to an LG c7 using win 10 and an nVidia 1050Ti.

Last edited by audit13; 06-11-2019 at 02:59 PM.
audit13 is offline  
post #26 of 40 Old 06-11-2019, 11:59 AM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
So next step, I pulled the SSD, installed a spare SSD and reinstalled Windows. Same issue.

I took my Core i7 PC, pulled the drive and put a blank drive in and installed Windows with the GTX 1050 Ti. Same problem. I removed the GTX 1050 and ran off the M/B HDMI (Intel) and the Pioneer passes the 4k video.

In every case going through the Pioneer the PC with the GTX 1050 thinks it is using the DVI port.

So it's a handshake problem between Nvidia and Pioneer. At this point I see no options besides leaving the PC directly connected to the LG and using the ARC for audio. I don't seem to get all the Atmos stuff with ARC. Not sure what else won't work correctly.

And yes the LG and Pioneer have the latest firmware updates.
Gary Quiring is offline  
post #27 of 40 Old 06-11-2019, 12:35 PM
Advanced Member
 
brazen1's Avatar
 
Join Date: Mar 2008
Posts: 880
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 568 Post(s)
Liked: 328
Do you have your HDMI cable from your 1050 Ti into your HDMI port number 5 (4k HDR/HDCP) on your AVR?

HOW TO - Kodi 2D - 3D - UHD (4k) HDR Guide Internal & External Players
W10 1903 / MPC-BE\HC / PotPlayer / PowerDVD 19 / DVDFab Player 3 / KODI 19 videoplayer
GTX960 4GB / RGB Full 4:4:4 / 8bit Desktop mode =60Hz / 10/12bit Video mode = Matched Refresh rates IE 23,24,25,60Hz
65JS8500 UHD HDR 3D / Denon S720W
brazen1 is offline  
post #28 of 40 Old 06-11-2019, 12:53 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
Quote:
Originally Posted by brazen1 View Post
Do you have your HDMI cable from your 1050 Ti into your HDMI port number 5 (4k HDR/HDCP) on your AVR?
It's in port 1, label is BD/DVD. I also tried port 2. On the LX503 all the ports in the rear are the same.
Gary Quiring is offline  
post #29 of 40 Old 06-11-2019, 03:03 PM
AVS Forum Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 2,213
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 281 Post(s)
Liked: 110
This should work too: run an HDMI cable between the video card's HDMI port and the tv, run a DVI-to-HDMI cable between the video card and receiver, select the receiver as the sound device in win 10, extend the desktop to the receiver. I was doing this until I got a new Anthem receiver.
audit13 is offline  
post #30 of 40 Old 06-11-2019, 04:20 PM - Thread Starter
Advanced Member
 
Gary Quiring's Avatar
 
Join Date: Nov 2000
Location: Summerville, SC USA
Posts: 831
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Liked: 18
This is what the nVidia control panel is showing when the receiver is in the loop. I cannot understand why it thinks it's DVI.

https://imgur.com/a/YaHjqxO
Gary Quiring is offline  
Sponsored Links
Advertisement
 
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off