madVR audio sync - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 08-04-2019, 01:44 AM - Thread Starter
Newbie
 
Join Date: Nov 2018
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
madVR audio sync

Hi,

I just installed a new PC with madVR (MPC-BE), but I can't seem to eliminate audio sync problems with the picture.

I tried to use 23p, but the sync problem is crazy there.
If I go to 60p, the sync is improving, but still there (and I'm forced to use 8bit instead of 12bit).

I'm using RTX 2080 Ti (Corsair i160), Denon 3400 and JVC RS520.

(I was also fighting crazy judder by changing frame rates, somehow its now bearable, and I'm not sure what exactly fixed it)

Your help is much appreciated!

Thanks
Yaron Galula is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-04-2019, 05:18 AM
AVS Forum Special Member
 
markmon1's Avatar
 
Join Date: Dec 2006
Posts: 6,391
Mentioned: 112 Post(s)
Tagged: 0 Thread(s)
Quoted: 5368 Post(s)
Liked: 3487
Quote:
Originally Posted by Yaron Galula View Post
Hi,

I just installed a new PC with madVR (MPC-BE), but I can't seem to eliminate audio sync problems with the picture.

I tried to use 23p, but the sync problem is crazy there.
If I go to 60p, the sync is improving, but still there (and I'm forced to use 8bit instead of 12bit).

I'm using RTX 2080 Ti (Corsair i160), Denon 3400 and JVC RS520.

(I was also fighting crazy judder by changing frame rates, somehow its now bearable, and I'm not sure what exactly fixed it)

Your help is much appreciated!

Thanks
8 Bit is fine. I prefer it. MadVR processes in the RGB color space and there's dithering etc. I have my desktop set to 4k/23/RGB 8bit/full, madVR set to FULL and the display set to FULL.

For audio, I am assuming you are bitstreaming the audio out. You should be. At 23hz on your RS520, you'll probably want to delay audio in your receiver by about 90ms. If you use CMD then make that about 180MS. At 60hz, you'll get some judder, but you wont need any delay at all without CMD and only about 90 with CMD on. I run CMD on and 180MS delay.

Video: JVC RS4500 135" screen in pure black room no light, htpc nvidia 1080ti.
Audio: Anthem mrx720 running 7.1.4, McIntosh MC-303, MC-152, B&W 802d3 LR, B&W HTM1D3 center, B&W 805d3 surround, B&W 702S2 rear, B&W 706s2 x 4 shelf mounted for atmos, 2 sub arrays both infinite baffle: 4x15 fi audio running on behringer ep4000 + 4x12 fi audio running on 2nd ep4000.
markmon1 is online now  
post #3 of 5 Old 08-04-2019, 12:11 PM - Thread Starter
Newbie
 
Join Date: Nov 2018
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Quote:
Originally Posted by markmon1 View Post
8 Bit is fine. I prefer it. MadVR processes in the RGB color space and there's dithering etc. I have my desktop set to 4k/23/RGB 8bit/full, madVR set to FULL and the display set to FULL.

For audio, I am assuming you are bitstreaming the audio out. You should be. At 23hz on your RS520, you'll probably want to delay audio in your receiver by about 90ms. If you use CMD then make that about 180MS. At 60hz, you'll get some judder, but you wont need any delay at all without CMD and only about 90 with CMD on. I run CMD on and 180MS delay.
Thanks, I tried to follow you advice. My audio renderer is set to the MPC audio renderer, with WASAPI exclusive mode, with bit-exact output.
I have added the 90ms delay and switched to 23p, 12bit.

The sync is now good, but the judder is back. madVR says display is at 23.9795, movie at 23.976, no delayed, dropped or deleted frames (smooth motion is off, no CMD on the JVC).

Any suggestions as to how to eliminate the judder?

Thanks
Yaron Galula is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 08-04-2019, 01:11 PM
AVS Forum Special Member
 
Onkyoman's Avatar
 
Join Date: Aug 2007
Location: Canada
Posts: 1,930
Mentioned: 54 Post(s)
Tagged: 0 Thread(s)
Quoted: 1131 Post(s)
Liked: 666
There is an issue with madVR and RTX cards. It is either a driver issue or a Windows issue. The best you can do is try some of the tips in this thread and try other driver versions:

https://forum.doom9.org/showthread.php?t=176013

A couple of people got the stutter to stop by deselecting use Direct3D 11 for presentation under general settings in madVR and outputting from madVR and the GPU at 8-bit RGB. A simple fix worth trying.
Onkyoman is offline  
post #5 of 5 Old 11-01-2019, 03:41 PM
Newbie
 
Join Date: Nov 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Untick use Direct3D 11 for presentation works!

Quote:
Originally Posted by Onkyoman View Post
There is an issue with madVR and RTX cards. It is either a driver issue or a Windows issue. The best you can do is try some of the tips in this thread and try other driver versions:
A couple of people got the stutter to stop by deselecting use Direct3D 11 for presentation under general settings in madVR and outputting from madVR and the GPU at 8-bit RGB. A simple fix worth trying.

Had the same problem with GeForce GTX 750, MPC-HC and madVR on 4K TV.
Audio out of sync with video. Actually it seems that video was out of sync because the subtitles were always in sync with audio.
Just to tell you that this solved it.

I unticked "use Direct3D 11 for presentation" in madVR and video and audio are now in sync!
Thanks for the tip!


However, my setup is rather complicated, I use CPU's Intel HD graphics 630 only for decoding and GeForce as a display device.
LAV decoder is set to use D3D11 hardware decoder in order to use Intel GPU only for decoding.
The fix might not work for everyone.


Greetings.
BJovke is offline  
Sponsored Links
Advertisement
 
Reply Home Theater Computers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off