NuVo Grand Concerto NV-18GM power problem - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 01-04-2020, 11:08 AM - Thread Starter
Newbie
 
Join Date: Jan 2020
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
NuVo Grand Concerto NV-18GM power problem

I have a GC system installed in 2015 and has worked fine until now. Here is the problem.

WHen I power the system on the blue power indicator light stays on for about 30 seconds and then goes off. No keypads seem to work or any sound coming out.
I figured one of the speaker wires had a short and the unit cut off to protect system. SO I unplugged the network cable and all the speaker connections. Same result.
Fuse at the AC connection is not blown.

What could be wrong here?
Any diagnostics I could try?

Thanks Paul G
Paul Garber is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-11-2020, 07:32 AM
Member
 
brantmacga's Avatar
 
Join Date: Dec 2009
Posts: 177
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Liked: 23
Could be a bad PSU.


Sent from my iPhone using Tapatalk
brantmacga is offline  
Sponsored Links
Advertisement
 
Reply Home A/V Distribution

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off