Cant get 1080i to display. Ws-55315 Mitsubishi - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 03-02-2020, 04:49 AM - Thread Starter
Member
 
rptvtomi52's Avatar
 
Join Date: Jan 2015
Posts: 28
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 1
Cant get 1080i to display. Ws-55315 Mitsubishi

I have a Mitsubishi ws-55315 from 2004. I used to be able to sync and mirror the display from my chromebook laptop to the tv via hdmi to dvi-d adapter...in 1080i resolution with no issues. Now the only clear resolution I can get is 480i...which still doesn't look right. I've tried a couple different sources such as my blue ray player..a hdmi to component converter and my computer...and the tv wont switch to 1080i. The picture is just all distorted and wavy and flickering except for 480i. Both component inputs and dvi-d input are doing this. With the blue ray player I'll set the output resolution using yellow video output to either 480p or 1080i...and when I connect either digital signal from it it to dvi or component input on the tv...I just get the crazy distorted blur. Is there a chip of fuse in the tv that could have gone bad possibly? Any advice would be greatly appreciated...thanks
rptvtomi52 is offline  
Sponsored Links
Advertisement
 
Reply Video Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off