Radiance XE stuck in standy - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 04-13-2020, 10:31 PM - Thread Starter
Member
 
Glen911's Avatar
 
Join Date: Aug 2004
Location: oc, ca
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Radiance XE stuck in standy

Hey,

Has anyone ever had their Radiance XE just get stuck in standby? The red light is on but it won't seem to switch to on.. tried the remote and the rs-232 input. Wondering if it might just be the power supply needs replacing or is there some magic reset trick?

Thanks
Glen911 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-14-2020, 10:06 AM
AVS Forum Special Member
 
Gordon Fraser's Avatar
 
Join Date: Dec 1999
Location: U.K.
Posts: 1,956
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 259 Post(s)
Liked: 381
Most likely the power supply if it will not even come on from serial control. You can get them from amazon for not much if it's a 4 pin din version. If it's a normal barrel socket then Lumagen will likely sell you a current Radiance supply that will work.

Convergent-AV
ISF, Home Theater Consultants and Distribution, U.K.
Gordon Fraser is online now  
post #3 of 3 Old 04-17-2020, 10:14 AM - Thread Starter
Member
 
Glen911's Avatar
 
Join Date: Aug 2004
Location: oc, ca
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Thanks Gordon, managed to get one off amazon and it now turns on again. Can't seem to get any kind of video output from it though and there's a nasty hum from my speakers when connected to the prepro so maybe something got fried inside :-(
Glen911 is offline  
Sponsored Links
Advertisement
 
Reply Video Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off