Ripping UHD 4k discs with Makemkv: Instructions How-to - Page 102 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 1180Likes
Reply
 
Thread Tools
post #3031 of 3043 Old 05-22-2020, 10:03 AM
AVS Forum Special Member
 
SeeMoreDigital's Avatar
 
Join Date: Jul 2003
Location: Nott'm, UK
Posts: 3,689
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1179 Post(s)
Liked: 1021
Quote:
Originally Posted by Taxcheat View Post
The Shield 2019 can play DV mkv with lossless atmos and subs right now, with a patched copy of exoplayer. Proposed code was just updated to the new mkv spec, so this should all work out of the box soon. Exoplayer runs on any android device, and in theory it'll play DV & lossless atmos as long as the devicemaker has paid the appropriate Dolby Tax.
Given that the nVidia Shield runs on Android, all media files are parsed using software decoder filters and not ones built into the hardware decoding chip-set...

I SUPPORT 'FAIR USE'. MY MORALS PREVENT ME FROM HELPING ANYONE WHO OBTAINS COPYRIGHTED CONTENT ILLEGITIMATELY
TV: LG 65UH770V | DISC SPINNER: OPPO UDP-203 | STB: VU+ UNO 4K SE
AMPS: 1No Audiolab 6000A, 3No Audiolab M-PWR | SPEAKERS: 2No KEF 103.2, 6No Wharfedale Diamond 10
ISP: Virgin Media @ 100Mbps | NETWORK: 1000Mbps | NAS: Synology DS212+
SeeMoreDigital is offline  
Sponsored Links
Advertisement
 
post #3032 of 3043 Old 05-22-2020, 10:13 AM
Member
 
oniiz's Avatar
 
Join Date: Jul 2008
Posts: 163
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 133 Post(s)
Liked: 39
@SeeMoreDigital I had posted this over in the OPPO 203 thread in case you may have missed it, "just thought I'd mention that I got your 1080/25p test file to play back via a BDMV rip after excluding the aac audio stream & it still plays back as 50i Interlaced NOT the 25p that you claim the OPPO will flag and output correctly at it's native 25 frame rate."

Could you please tell me what I may possibly be doing wrong with tsMuxeR GUI as I'm curious to see it play back correctly at 25p.
Attached Files
File Type: zip Speaker Test [email protected][email protected] [9secs].zip (622.9 KB, 2 views)
oniiz is online now  
post #3033 of 3043 Old 05-22-2020, 10:20 AM
AVS Forum Special Member
 
SeeMoreDigital's Avatar
 
Join Date: Jul 2003
Location: Nott'm, UK
Posts: 3,689
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1179 Post(s)
Liked: 1021
Quote:
Originally Posted by oniiz View Post
@SeeMoreDigital I had posted this over in the OPPO 203 thread in case you may have missed it, "just thought I'd mention that I got your 1080/25p test file to play back via a BDMV rip after excluding the aac audio stream & it still plays back as 50i Interlaced NOT the 25p that you claim the OPPO will flag and output correctly at it's native 25 frame rate."

Could you please tell me what I may possibly be doing wrong with tsMuxeR GUI as I'm curious to see it play back correctly at 25p.
Please give a rest... I really don't have the time to look into why the OPPO plays some video formats at 25p and not others...

I SUPPORT 'FAIR USE'. MY MORALS PREVENT ME FROM HELPING ANYONE WHO OBTAINS COPYRIGHTED CONTENT ILLEGITIMATELY
TV: LG 65UH770V | DISC SPINNER: OPPO UDP-203 | STB: VU+ UNO 4K SE
AMPS: 1No Audiolab 6000A, 3No Audiolab M-PWR | SPEAKERS: 2No KEF 103.2, 6No Wharfedale Diamond 10
ISP: Virgin Media @ 100Mbps | NETWORK: 1000Mbps | NAS: Synology DS212+
SeeMoreDigital is offline  
Sponsored Links
Advertisement
 
post #3034 of 3043 Old 05-22-2020, 11:18 AM
Advanced Member
 
Taxcheat's Avatar
 
Join Date: Mar 2003
Location: Washington, D.C.
Posts: 555
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 527 Post(s)
Liked: 417
Quote:
Originally Posted by SeeMoreDigital View Post
Given that the nVidia Shield runs on Android, all media files are parsed using software decoder filters and not ones built into the hardware decoding chip-set...
The last thing I worry about when watching streaming Dolby Vision content on my Shield is, "wow, I really wish this were playing with a hardware decoder." But maybe I'm missing your point? The mkv devs are getting serious now about making this official. Direct quote: "I don't expect the discussion to take a lot of additional time; probably a couple of days."

XBR-75Z9D fed by Oppo 203. Decrapifying the X1 Extreme
Taxcheat is offline  
post #3035 of 3043 Old 05-22-2020, 12:01 PM
AVS Forum Special Member
 
SeeMoreDigital's Avatar
 
Join Date: Jul 2003
Location: Nott'm, UK
Posts: 3,689
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1179 Post(s)
Liked: 1021
Quote:
Originally Posted by Taxcheat View Post
The last thing I worry about when watching streaming Dolby Vision content on my Shield is, "wow, I really wish this were playing with a hardware decoder." But maybe I'm missing your point?
Indeed most people don't think about or (want to) understand the differences between hardware and software (front-end) playback devices... But when it comes to media file playback support, the differences are, well different...

I SUPPORT 'FAIR USE'. MY MORALS PREVENT ME FROM HELPING ANYONE WHO OBTAINS COPYRIGHTED CONTENT ILLEGITIMATELY
TV: LG 65UH770V | DISC SPINNER: OPPO UDP-203 | STB: VU+ UNO 4K SE
AMPS: 1No Audiolab 6000A, 3No Audiolab M-PWR | SPEAKERS: 2No KEF 103.2, 6No Wharfedale Diamond 10
ISP: Virgin Media @ 100Mbps | NETWORK: 1000Mbps | NAS: Synology DS212+
SeeMoreDigital is offline  
post #3036 of 3043 Old 05-23-2020, 12:50 AM
Newbie
 
Join Date: May 2020
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Hi guys,

I have a number of 4k UHD dolby atmos rips, each one of them contains different streams i.e. 4k, 1080p etc etc - is there a way to extract just the 4k stream along with the dolby atmos audio file?

If so how?

Thanks in advance
Adrian Davies is offline  
post #3037 of 3043 Old 05-23-2020, 01:12 AM
AVS Forum Special Member
 
SeeMoreDigital's Avatar
 
Join Date: Jul 2003
Location: Nott'm, UK
Posts: 3,689
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1179 Post(s)
Liked: 1021
Quote:
Originally Posted by Adrian Davies View Post
Hi guys,

I have a number of 4k UHD dolby atmos rips, each one of them contains different streams i.e. 4k, 1080p etc etc - is there a way to extract just the 4k stream along with the dolby atmos audio file?

If so how?
It would be helpful to know more detail about these media files and why you feel you need to remove certain streams. Please run one (or more) of these media files through an application called MediaInfo (set to text mode) and post what it reports 'in full' as a text file.


Cheers

I SUPPORT 'FAIR USE'. MY MORALS PREVENT ME FROM HELPING ANYONE WHO OBTAINS COPYRIGHTED CONTENT ILLEGITIMATELY
TV: LG 65UH770V | DISC SPINNER: OPPO UDP-203 | STB: VU+ UNO 4K SE
AMPS: 1No Audiolab 6000A, 3No Audiolab M-PWR | SPEAKERS: 2No KEF 103.2, 6No Wharfedale Diamond 10
ISP: Virgin Media @ 100Mbps | NETWORK: 1000Mbps | NAS: Synology DS212+
SeeMoreDigital is offline  
post #3038 of 3043 Old 05-23-2020, 01:58 AM
AVS Forum Special Member
 
SeeMoreDigital's Avatar
 
Join Date: Jul 2003
Location: Nott'm, UK
Posts: 3,689
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1179 Post(s)
Liked: 1021
Quote:
Originally Posted by Adrian Davies View Post
Apologies, Please see attached details for one of the files
Hmmm...

It's quite clear from you MediaInfo file report that you have not backed-up this particular movie from a disc yourself using MakeMKV (which is the purpose of this particular topic). Indeed, the video stream has been completely re-encoded!

Nobody here can help you with illegitimately downloaded media files, as such discussions bring unwanted attention to the forum!
aaronwt, giomania, DrDon and 3 others like this.

I SUPPORT 'FAIR USE'. MY MORALS PREVENT ME FROM HELPING ANYONE WHO OBTAINS COPYRIGHTED CONTENT ILLEGITIMATELY
TV: LG 65UH770V | DISC SPINNER: OPPO UDP-203 | STB: VU+ UNO 4K SE
AMPS: 1No Audiolab 6000A, 3No Audiolab M-PWR | SPEAKERS: 2No KEF 103.2, 6No Wharfedale Diamond 10
ISP: Virgin Media @ 100Mbps | NETWORK: 1000Mbps | NAS: Synology DS212+
SeeMoreDigital is offline  
post #3039 of 3043 Old 05-25-2020, 08:14 PM
Audio/Video Enthusiast
 
alexcoluzzi32's Avatar
 
Join Date: Jan 2018
Location: California
Posts: 414
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 274 Post(s)
Liked: 215
Awe man I wanted to see those...
aaronwt likes this.

Living Room: Xfinity XG1v4-A cable box + Apple TV 4K > Sony HT-ST5000 Atmos/DTS:X Soundbar > Sony XBR-65X900F Television
Office: Oppo UDP-203 + Apple TV 4K > Sony HT-Z9F Atmos/DTS:X Soundbar (with rears) > Sony XBR-55A1E Television
alexcoluzzi32 is offline  
post #3040 of 3043 Old Yesterday, 01:39 PM
AVS Forum Club Gold
 
giomania's Avatar
 
Join Date: Nov 2001
Location: Chicago, Illinois
Posts: 4,195
Mentioned: 35 Post(s)
Tagged: 0 Thread(s)
Quoted: 865 Post(s)
Liked: 670
Quote:
Originally Posted by ManMower View Post
MakeMKV has just released a new version that appears to fix audio dropouts on Disney titles with atmos (Ralph Breaks the Internet, The Incredibles 2, many many more)

Probably a good time to upgrade...
Quote:
Originally Posted by aaronwt View Post
Is that a common problem? Because I have not run into the audio dropouts with my older versions of MakeMKV with Disney titles.
Quote:
Originally Posted by rdgrimes View Post
If it really works, great.





Depends on the playback device. Some are not bothered, some lose audio synch, some have dropouts, it varies. This is with branching and DTHD audio combined. Disney authors them with a glitch build in, don't think its an accident.
Quote:
Originally Posted by rdgrimes View Post
Just tested this by making an MKV of Cars 4K. As I expected, this update did nothing to fix the audio glitches. Playback on my Oppo still results in many dropouts, but as before my Zappiti has no trouble with the files.
Quote:
Originally Posted by ManMower View Post
Version 1.15.1?

It fixed the glitch I had in Ralph Breaks the Internet. That would cause a loud snap sounds in a software player on windows, as well as causing a permanent loss in audio playing on my Vero 4k+ through my AVM-60.

He definitely fixed *something*...

I still need to retry The Incredibles 2, but I'd have to re-rip that one.

Some recent Disney titles also have some kind of higher than normal bitrate for their audio tracks that broke a few players for a while - is there any chance the problem is with your Oppo? Does it play back MKVs made with CloneBD properly?
i just encountered this issue while watching the 4K version of Incredibles 2 via my OPPO UDP-203 the other day. There were a bunch of constant drops throughout the movie. I re-ripped it using MakeMKV version 1.15.1, and tested it briefly via the opening scene, and it seems to be fixed. I have a bunch of Disney 4K titles, but is there a list somewhere containing which specific titles are afflicted, so I don't have to re-rip everything?

Thanks.

Mark

Lumagen Radiance Pro HDR Tone Mapping Guide: Click Here

Lumagen Radiance Pro Setup & Calibration Tips: Click Here

UHD-BD Backup & Playback Guidance Link
giomania is offline  
post #3041 of 3043 Old Yesterday, 01:55 PM
Senior Member
 
Natrix1973's Avatar
 
Join Date: Nov 2007
Posts: 284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 84 Post(s)
Liked: 59
Anyone have an issue ripping Top Gun? I am getting intermittant video artifacts with my MKV file but no issues when watching the disk though any of my standalone players. I have two different drives that I tried ripping it with and also tried cleaning the disk.
Natrix1973 is offline  
post #3042 of 3043 Old Yesterday, 02:07 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 36,829
Mentioned: 78 Post(s)
Tagged: 0 Thread(s)
Quoted: 9917 Post(s)
Liked: 6550
Quote:
Originally Posted by Natrix1973 View Post
Anyone have an issue ripping Top Gun? I am getting intermittant video artifacts with my MKV file but no issues when watching the disk though any of my standalone players. I have two different drives that I tried ripping it with and also tried cleaning the disk.
I watched it last night. I used MakeMKV to rip it to an MKV since ANY DVD HD had not been updated yet with the key. (I use their CLoneBD program to create an MKV if ANy DVD has the decryption key.)

I used the native Plex app with a 2017 Shield TV for playback.

The entire movie played back with zero issues. HDR10 and Atmos looked and sounded great.

57TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme

Last edited by aaronwt; Yesterday at 02:10 PM.
aaronwt is offline  
post #3043 of 3043 Old Yesterday, 05:25 PM
Advanced Member
 
Taxcheat's Avatar
 
Join Date: Mar 2003
Location: Washington, D.C.
Posts: 555
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 527 Post(s)
Liked: 417
Quote:
Originally Posted by Natrix1973 View Post
Anyone have an issue ripping Top Gun? I am getting intermittant video artifacts with my MKV file but no issues when watching the disk though any of my standalone players. I have two different drives that I tried ripping it with and also tried cleaning the disk.

No issues here, either. Top Gun looked and sounded great streamed in DV from NAS via Oppo. Same with War of the Worlds and Days of Thunder.

Update from the makemkv forum: Both Kodi and Emby devs have confirmed they will implement Dolby Vision playback in the mkv container once the mkv spec is finalized (and they're putting the finishing touches on that right now). Very good things are happening.

XBR-75Z9D fed by Oppo 203. Decrapifying the X1 Extreme
Taxcheat is offline  
Sponsored Links
Advertisement
 
Reply Networking, Media Servers & Content Streaming

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off