MKV subtitle issues - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 04-14-2019, 01:03 PM - Thread Starter
AVS Forum Special Member
 
pstrisik's Avatar
 
Join Date: Dec 2004
Location: Anchorage
Posts: 1,498
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Liked: 34
MKV subtitle issues

I'm trying to convert a ton of ISOs, all DVD, to MKV for broader compatibility with servers and players. I'm using DVDFab DVD Ripper module. All goes well until I stream them to Dune or Sony BDP. Doing normal English subs remuxed in does give me the ability to turn subs on or off, but they are persistent. That is, the last subtitle text remains on screen until the next dialog.


The only way that seems to work is using forced, normal and forced both:





I then get two streams. One works, the other shows no subs. Both are named VOBSUB EN.


I could go with this, but I'm afraid something isn't standard and I'll run into unpredicted issues later.


So far DVDFab support says this is typically a player issue. That may be true as the normal subs work properly played in VLC on Windows. But two different hardware players, one a mainstream consumer Sony BDP, having problems? Doesn't seem right to me.


Anyone have ideas about what is going on here and how to make proper MKV files with no loss from the source, and with subs that turn on or off?


I tried MakeMKV, but the results have broken up video, even played on my computer.


Thanks

.
. . . . . . . . . . . Peter
pstrisik is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-15-2019, 12:42 PM
AVS Forum Special Member
 
Jon S's Avatar
 
Join Date: Nov 1999
Location: Sunny Hawaii
Posts: 4,381
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 1095 Post(s)
Liked: 385
I use Handbrake to re-encode the MKV file... There is a subtitle tab there. You can have Handbrake "burn" the subs into the end file so it will always appear when the video is played. This means you cannot "toggle" the subs on or off.



I always disable the "forced" option, enable "burn". You have to determine which subtitle track is the correct one on most videos, as most movies have various subtitles for different languages. Once you determine which is the correct subtitle, you can select it in Handbrake and proceed from there.

If it's not a BIG screen, it's not a theater...
Jon S is offline  
post #3 of 6 Old 04-15-2019, 02:20 PM - Thread Starter
AVS Forum Special Member
 
pstrisik's Avatar
 
Join Date: Dec 2004
Location: Anchorage
Posts: 1,498
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Liked: 34
Quote:
Originally Posted by Jon S View Post
I use Handbrake to re-encode the MKV file... There is a subtitle tab there. You can have Handbrake "burn" the subs into the end file so it will always appear when the video is played. This means you cannot "toggle" the subs on or off.



I always disable the "forced" option, enable "burn". You have to determine which subtitle track is the correct one on most videos, as most movies have various subtitles for different languages. Once you determine which is the correct subtitle, you can select it in Handbrake and proceed from there.

Selecting the correct sub stream is no problem. And my preference is to not have the subs burned in, rather allow them to be turned on and off. Just this particular wierd symptom I'm trying to troubleshoot.

.
. . . . . . . . . . . Peter
pstrisik is offline  
Sponsored Links
Advertisement
 
post #4 of 6 Old 04-17-2019, 08:23 AM
Senior Member
 
Join Date: Dec 2014
Posts: 366
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 16
Quote:
Originally Posted by pstrisik View Post
Selecting the correct sub stream is no problem. And my preference is to not have the subs burned in, rather allow them to be turned on and off. Just this particular wierd symptom I'm trying to troubleshoot.
When you create the MKV, there is an option for the sub stream. Set it to forced for the track you want.

Then the player should already know to play the forced subtitles.

I do that, but I only select the foreign language subtitle, and set that to forced.
cowbodude99 is offline  
post #5 of 6 Old 04-17-2019, 08:28 AM
Senior Member
 
Join Date: Dec 2014
Posts: 366
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 212 Post(s)
Liked: 16
Sorry, I misunderstood. I use MKV ToolNix to create the MKV file. That is where I select to force the subtitles on/off.

Forced = always on. There is a 'default' option, which I guess would allow the player to turn it off if needed.
cowbodude99 is offline  
post #6 of 6 Old 04-21-2019, 08:41 AM - Thread Starter
AVS Forum Special Member
 
pstrisik's Avatar
 
Join Date: Dec 2004
Location: Anchorage
Posts: 1,498
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Liked: 34
The DVDFab company was of no help. There is a glitch there in their conversion process. I have however, successfully converted ISO to MKV using MakeMKV and BatchMKV. Subtitles are preserved, work properly and can be switched on and off. Phew!

.
. . . . . . . . . . . Peter
pstrisik is offline  
Sponsored Links
Advertisement
 
Reply Networking, Media Servers & Content Streaming

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off