AVS Forum | Home Theater Discussions And Reviews (https://www.avsforum.com/forum/)
-   Microsoft UltimateTV PVR (https://www.avsforum.com/forum/41-microsoft-ultimatetv-pvr/)
-   -   My UTV is dead - can I load a new HD? (https://www.avsforum.com/forum/41-microsoft-ultimatetv-pvr/1179374-my-utv-dead-can-i-load-new-hd.html)

ICUDoc 09-14-2009 06:12 AM

Hi, Everyone

I have an old UTV unit that I adore - it has worked fine all these years - lately having hard drive problems - it powers on OK - but I hear a clicking - and the screen shows that it is trying to connect to WebTV - hook up a phone line and nothing works - it will only give me options to change dialing options or dial. This happened last month and I was able to get it working by repeatedly taking the power cod out, and once it booted it was OK - but all recordings lost. Now even that does not work.

I think it is the hard drive - and want to put in a new one (it has the original). I have read to buy a WD 120GB Caviar - but my concern is that when I go to plug it in - and it tries to dial MSN to load the 3.7 updated software - that there will be no answer at the other end and I will have spent $100 on a drive for nothing.

Anyone know if you can still update the software by phone? Is there another way?

I am hoping to keep this one going for a while - UTV still has the best software and recording quality of all my DVRs.

Thanks for the help in advance!!


guitars911 09-14-2009 07:44 AM

Yes you can replace the drive. It's pretty easy too. Your problems sound drive related to me as well. Here is a thread that shows the software is still out there for down loading over a phone line. Less than a month old.


It contains instructions, links to photos, and such. The FAQ thread is another great resource for learning more about this aging DVR.

Good luck and report back.

lgodave 09-14-2009 08:57 AM

As guitars911 has mentioned...

The link does give you a good idea of what you'll need to do.

Glad to see the blind squirrel link is still alive... it was very helpful for me back in the day. http://www.blindsquirrel.org/UTV/

Virtually any new IDE Drive (not just WD brand) should do... keep in mind the 137GB Barrier so while a 500GB IDE drive should work... it may be a bit wasteful. If you have an older drive in your PC (Say 200GB IDE) then maybe it's time to upgrade your PC hard drive and swap the 200 into the UTV...

OS 3.8 (Summer 2007 upgrade) is still available via dial up... it had been available for Sat download for a year (at least?) for anyone still running 3.7 or earlier versions. I swapped out a drive a few months ago and the download went smoothly. If your phone line (old school hard line) is "clean" you should have no real issues. If you don't have a "hard line" you might try borrowing a friend or family members line for a few hours.

Kazak 09-14-2009 09:34 AM

Also, if you just cannot get the phoneline download to work there are instructions in the FAQ to show you how to apply it to your new drive from your PC.

Good luck.


ICUDoc 09-14-2009 10:25 AM

Thanks - I will be plugging my phone line direct into the home phone line so it should be clean - but the info you have all given me is very, very helpful - if anyone would suggest a specific drive that would be great - am looking for drives and not easy to find 120GB drives so may go with a 160GB drive. Don't really care about wasting space or $$ - I love the UTV so much it is worth it and I have already gotten my $$ worth over the last 10 years!!

Thanks again and will report back when I get the drive and do the installation.


lgodave 09-14-2009 01:44 PM

My UTVs might be a bit "old school" as far as Hard Drive brands... but I've been happy with my Seagate and WD (Western Digital) drives (80GB-160GB range AB,BB and Seagate Barracuda class).

In the recent past (2005?) Seagate and some of the other Hard Drive providers began offering 5 year warranties (up from 1-3 year warranties). I had a bad Seagate go bad during an upgrade (not sure if I screwed it up or if it was a true hardware failure) and the replacement still has at least 1-2 years still left on it's replacement warranty should it fail. I had a good experience with them replacing the drive and would recommend them.

So as the choices of IDE maybe less I would simply recommend a "name" brand with a long warranty coverage. If your new drive should die before the UTV does, say in 2 years you might find WD/Seagate/Maxtor can get you a replacement IDE drive easier then you might have finding one on the shelves (in 2011/2012).

charlcas 09-14-2009 05:25 PM

One of my UTVs had a hard drive go flaky recently. It works sometimes, but not other times. When it's not working, the unit won't power up and the light just flashes. The UTV always powers up with the new hard drive.

I've been able to connect to web tv or msn tv or whatever it's called when the old drive works, so it appears that the modem is operational. When it's trying to update, it connects to web tv, disconnects, and then claims it is calling msn. It connects and after about 10 seconds, the tv goes black. About 20 seconds later, the unit powers down. Has anyone heard of this before? Is my entire UTV toast?

If it's just a modem problem going along with the questionable hard drive, should I try to reimage my new drive based on the old image? I can't reimage it based on one of my working UTVs can I, since the drive is tied to the unit?


charlcas 09-14-2009 07:03 PM

One more thing....does anyone know where I might find an image for UTV x.x? (whatever is available is better than I've got!)


lgodave 09-14-2009 09:44 PM

You might try and test your tuners by pulling all the SAT cable connections and try and "power up" the UTV. If it can power up normally and act as it should there may be a Tuner aspect involved. I'd take one good Sat cable connection and individually check each tuner (one at a time). Using the System Test and Signal Strength meter should let you know if either are bad.

When one of my RCA UTVs lost a tuner... it would "black screen" during a power up if I were running solely on the dead tuner.

So check your tuners and then avoid the "bad" tuner... if the tuners are OK or the problem is still popping up... try a hard drive swap.

charlcas 09-14-2009 10:20 PM

Both of my tuners work on this Sony unit. (I'm trying to replace an RCA unit that had one tuner go out.) The problem with this Sony is that it can't record ANYTHING (hard drive issues, I guess). It doesn't always power up (allegedly a hard drive issue). It always powers up with the new hard drive, but I can't seem to download a new OS over the modem. It only "black screens" when I'm trying to install a new operating system via phone line.

lgodave 09-15-2009 08:15 AM

Have you verified that your Jumper Settings are set correctly?

Many newer Drives are set with the Cable Select Option which UTV doesn't recognize properly.

You'll want to make certain it is set to Single or Master. Usually you'll receive a "Repair" error screen for a bad jumper setting but it isn't 100%.

The UTV can actually operate without the Hard Drive installed... It will attempt to download the OS over the modem (as if the drive existed) and then repeat itself until it can see a drive and successfully download the OS. So if you want to try a "dry run" without the drive to confirm if the UTV is working properly...

If you still get the "black screens" then you have a problem with the UTV or maybe a bad Video Cable or TV issue. If you can swap the Cables/TV... you can be sure it isn't the Hard Drive/Cables/TV... you'll narrow it down to something specific to the UTV itself. You might try alternative Video Outputs (RCA/S-Video/Coax) to make sure the "black screen" is happening on all outputs.

Good luck. Keep us posted.

ICUDoc 09-16-2009 04:45 AM

OK - so I bought a Western Digital WD1600 drive and the installation went very smoothly thanks to all the helpful suggestions I got here - especially about the jumper settings.

Now - I hook up and it already looks like it has recognized that there is a working drive there because I can go further with the dialing and connect than before - it hooks up to MSN and starts downloading the update - but it disconnects in the middle somewhere. There are 297 parts to the download - the first time I got up to 77 but since then can't get much beyond the 40s and sometimes it only downloads 3 parts and it loses the connection. I am using a direct connection to my main phone outlet on a land line - and, after making the dialing audible - the line sounds clean - but it still disconnects.

Short of uninstalling the drive and setting it up on a computer - are there any other ways I can download the software onto the drive in the UTV case?

Thanks for all the help!!


charlcas 09-16-2009 01:30 PM

ICUDoc, I'm in essentially the same spot you are. I only got 15 out of 297 parts downloaded, and that was on the best line in my house. (Boy I love Verizon!)

The bad news is the drive now appears to be locked. If I stick it into my PC, I can't initialize it. I've tried putting it back into the UTV and pulling the cable while it's powered up, but the damn thing is still locked. Unless I can unlock it somehow, it's either get yet another HD and try to install the image from the PC, or rely on the phone to successfully download 297 parts. I'm not looking forward to either.

fwiw since this might come up again, my black screen after calling in went away when I changed the jumpers on the HD to "single" (actually no jumper) rather than "master".

guitars911 09-16-2009 02:20 PM

Guys, just keep trying to dial out for the OS. A lot of people have reported it took quite a few tries over several days to finally get the entire 297 parts. Some say the MSN servers get overloaded, but I think some UTV's modems are just picker than others. Try it at a friends or family members house. That does the trick on occasion.

The last time I dialed out for the OS I must have been lucky as mine took on the 3rd or 4th try at about 4pm on a Sat or Sun afternoon, can't remember which, but it was over the weekend.

charlcas, your drive is locked. The new drive has married / locked itself to the UTV. Just reinstall it and keep trying to dial out. Just be patient and try at different times of the day.

The unlocking instructions are in the FAQ thread if you want to try and unlock the drive so you can load the OS from a computer. I have the 3.8 OS file somewhere, let me know if you may need it and I'll look for it.

Don't give up! It'll work out...

lgodave 09-16-2009 02:23 PM


Glad you pointed out the "Single" Jumper Setting. Many drives don't even mention a "Single" setting... So if the "Master" setting is somehow not working... some addtional research or experimentation is called for. WD's "Single" setting has in the past been to pull the Jumper(s), but check your manual/drive.

Traditionally to "unlock" a UTV drive you need to "unmarry" that drive from the receiver. So if you want to use a UTV "locked" drive on a PC... you'll need to either replace the UTV Drive with another (long process) and then perform the "unlock" procedure after the UTV has "remarried"... IF you have a spare or alternative UTV that is already "married" you can use that UTV to perform the unlock procedure and afterwards restore the UTV's "original" drive without losing it's recordings/settings (if you performed the unlock properly).

As far as options when trying to get a clean download using a phone line...

Have you tried using the "NID" (Network Interface Device) Box and it's test jack that effectively overrides all the in-house wiring and provides the "cleanest" connection?

Have you disabled call-waiting? (either inside the UTV or manually?) Do you notice any "cross-talk" or noticeable interference on the line? It might seem "clean" but it might not be. Double check your telephone cables... just because the extension you tested is "good" doesn't mean the line/jack you are using to the UTV is just as good. Check for bad contacts/plugs/surge protectors/etc. that might be between the UTV and the "good" source.

Best of luck.

guitars911 09-16-2009 05:39 PM

^^^ Good tip on disabling call waiting. I over looked that one earlier. That one alone fixed a few of my friends dialing out troubles over the years.

Here is a copy of the current version OS 3.8. Good for the first 10 downloads or 90 days. If you DON"T need it, please leave the 10 uses for those in need. Thanks...

http://rapidshare.com/files/281093261/utv_3.8.bin.html ( click free user, wait 45 sec's or so then hit download )

Kazak 09-17-2009 08:01 AM

There is also a drive utility that you can use to unlock a married drive. You can get it at
The best way to use this is to make a DOS boot floppy with this util installed on it. Unplug all drives but the one you want to unlock. That way you don't screw up and erase your system drive. Read what it says, it takes 30 min + to unlock a 40 gig drive even if the util looks like its finished. 1.5 hours for a 120 gig, etc.

If you can't get this for any reason I'll be happy to make it available.


ICUDoc 09-18-2009 05:02 AM

Have tried 40 or 50 times so far - get up as high as 68 parts of 297 and it disconnects. Disabled the call waiting - have tried two different phone outlets including the one directly on the Verizon FiOS box in my living room.

Will keep trying but don't think this is going to work - and don't have the time to try to now unlock the drive and then to install the OS 3.8 directly.

Looks like I will have to use the DirectTV new DVR they sent me as a replacement. Farewell, UTV!!

Thanks for all the help.


lgodave 09-18-2009 06:23 AM

Howdy Doc,

This might be the "Oh yeah that engine light HAS been on the whole time, but I didn't mention that. Is that causing the sucky performance?" moment. It isn't the "cause" of the problem but it points to a symptom that is...

Correct me if I'm wrong ICUDoc, but your Verizon FiOS box and "phone service" are VOIP based and not a traditional phone line service?

If that is the case traditional dial-up modems don't do so hot getting a stable connection with Voip "phone service". Think of it like one of those old "Wireless Jack" extenders. They work OK on old "Call home" Directv receivers (or for a spare phone) but a UTV needs a "cleaner" line for a stable higher speed connection. If you have tried running a system test (Checks Phone/Signal/Both Tuners/Access Card) you might even see the Phone connection "fail" it's test while on the FiOS box, or "Wireless Jack"... Even if it does "Pass", the quality of the connection may still not be good enough for a stable OS download.)

I'd suggest finding a "traditional" phone line someone can let you use for a few hours and your UTV can live on...

Good Luck,

charlcas 09-18-2009 12:58 PM

mhd3 did indeed unlock my drive. Being 120gb, I gave it a couple of hours.

Moving right along, I used FlexHEX to load the 3.8 image. Since I included the "zero" step, it ran all night. A couple of hours ago, it finished up, or so it appeared.

I put the hd into my UTV and......damn, it said it needed to dial out to check for the latest update. I wasn't expecting that. I'm guessing the image didn't get properly loaded since it's currently trying to download 297 parts of my new software. Wow, it got the whole way to part 3 this time.

There is no way I will ever download 297 parts with the Verizon service in my neighborhood. When I get some time, I'll pull the hd out again, unlock it, and try to image it again.

An interesting note about my downloading failures: It fails after receiving part N. The first two tries today N was 3. The last time I actually got to a personal best, 81. I'll get some message telling me that I've been disconnected, and I'm asked if I want to reconnect. When I reconnect, it dials out and apparently gets connected to MSN. However, it just keeps saying "Receiving part 81 of 297". It never increments beyond it's failure point. It looks like I'll need to get all 297 parts in one try, which is not possible in my neighborhood.

ICUDoc 09-19-2009 11:14 PM

Thanks for the suggestion about the phone line and the Verizon FiOS. I hooked up to my landlord's phone and it went through on the first shot! Now have gotten the software loaded and working fine.

Next problem - seems like one of my tuners is fried - only one tuner will pick up a signal no matter what I choose as a satellite choice - and on the system test tuner #2 fails.

Anything I can do for this?

Also - all channels below 80 - which are all the local channels - are not showing up - I think it might be because DirectTV has disabled something with the access card - they have already sent me a new DVR but I would rather keep the UTV until the DIrectTV TiVO units are available,

Thanks again!!


Kazak 09-20-2009 11:39 AM

Originally Posted by ICUDoc View Post

Thanks for the suggestion about the phone line and the Verizon FiOS. I hooked up to my landlord's phone and it went through on the first shot! Now have gotten the software loaded and working fine.

Next problem - seems like one of my tuners is fried - only one tuner will pick up a signal no matter what I choose as a satellite choice - and on the system test tuner #2 fails.

Anything I can do for this?

Tuner chips CAN be replaced but it's not for the faint of heart. I did it one time and so did others but it's a VERY tiny chip with many pins. I don't recommend it. The repair place can do it. Is it CCT? I forget.

Also - all channels below 80 - which are all the local channels - are not showing up -

How long has it been since you powered it back up? It sometimes takes a day for locals to show up for me.


charlcas 09-20-2009 01:26 PM

I too have had success. I unlocked again with mhd3 and then used FlexHEX to image the disk. The only thing (intentionally) that I did differently this time was that I didn't zero the disk since it appears that mhd3 does that already.

Loading that small of an image went really quickly, and I visually compared the file with the image stored on the disk (looked for a couple of interesting text strings).

Powered up and...........IT WORKED!!!!! As ICUDoc pointed out, I'm not getting the local channels right now (it's been about an hour now). Hopefully they show up tomorrow, since I'm planning to use this 2-working-tuner Sony unit to replace my 1-working-tuner RCA unit on my primary TV, and most of the new shows start tomorrow night.

The only downside to this is that I've had to pull the IDE cables off my computer drives a bunch of times, and it's taken me an hour to get the computer back up. (I don't think the cables like being taken off and on.) But currently, all is well with the world.

Thank you to everyone, especially the two of you who made the 3.8 image available. All of my neighbors have crappy Verizon service, so I doubt that I could ever had downloaded 297 parts.

As far as tuners are concerned....keep us informed on who is doing this for a decent price. I supposed I'll need to do that at some point in the future (unless I move to HD). My RCA unit lost a tuner a month ago, and my other Sony has some pixelization that leads me to believe one of its tuners is going soon. I have an HD TV as my primary system, but I love the UTV so much I'm still not replacing it.

lgodave 09-20-2009 02:46 PM

RE: Repairs of RCA/Sony UTVs

Most recognized option is CCS for $130 (includes repair of both tuners,a 40GB drive replacement if the old one is bad, a 6 month warranty on the entire receiver, and return shipping)

Check the details here:

Here is CCS's "UltTv" page which goes over some good Troubleshooting tips for common problems they've seen with UTVs coming in the door.

Also check the UTV FAQ on this forum (along with the Repairs thread for discussion of other options/ideas to care for your UTV) for concerns about keeping a UTV in good condition.

To "fix" or prevent tuner failure you should increase or maintain good air flow around the UTV. Keep the vents clean, elevate the bottom, make sure the internal fan is running, consider adding a fan (Internal or external). A reboot and/or cool down (several hours) may bring back an "overheated" tuner. Also make sure it isn't a bad cable run or contacts by testing each tuner with a single cable... one at a time.

As far as "local channels" not showing up... The best way to get this "fixed" is to call DirecTV or using your online DirecTV account and have them "refresh" your Access Card. The local channels should come back almost immediately. (3-5 minutes officially)

Logging in to your account then go to Support/Troubleshooting/Refresh Your Receivers

charlcas 09-26-2009 04:50 PM

Unfortunately all is not rosy. I successfully imaged a 120gb WD drive and for almost 24 hours, I had somewhere around 105 hours of recording to do. Sadly that drive now has some issues. It was an old drive that I hadn't used for a couple of years, but now shows a SMART error (I haven't bothered to see what the error was). I'm a little concerned about this since the reason I'm playing with this UTV right now is that the original hd failed. Being optimistic, I'll consider this a coincidence.

I have a couple of used 40gb drives (one Seagate, one WD) that support security in my spare parts pile. I imaged both of them with FlexHEX. When installed in the UTV, the WD said that it needed to update, and after a few parts downloaded, it told me that there was a problem with my Internet Terminal and the only option was to power off.

The Seagate also wants to dial out. I IMAGED BOTH OF THESE EXACTLY THE WAY I DID THE 120gb WD! (This process appears to be non-deterministic.) I've tried repeating the process twice with both of these (mdh3 to unlock, FlexHEX the 3.8 image). Same results.

Right now, I've got the UTV and a TV on my back patio 3 feet from the phone junction box (short cable to minimize issues). The highest I've gotten today is 39. Inside earlier this week, I got up to 95.

Question: When it's downloading the 297 parts and fails, it gives me the option to reconnect. Let's say I get to 39. If I reconnect (the obvious option), it appears that it's trying to pick up at that point. However, it never goes beyond that part no matter how many times I click reconnect. Has anyone ever had it fail downloading part N, reconnected, and had it go beyond N, or do you always need to start from scratch?

lgodave 09-27-2009 09:08 AM

Originally Posted by charlcas View Post

Question: When it's downloading the 297 parts and fails, it gives me the option to reconnect. Let's say I get to 39. If I reconnect (the obvious option), it appears that it's trying to pick up at that point. However, it never goes beyond that part no matter how many times I click reconnect. Has anyone ever had it fail downloading part N, reconnected, and had it go beyond N, or do you always need to start from scratch?

I have had it happen both ways...

Consider it just like "Getright" (an early download/resume PC program that was helpful for the dialup users that wanted the BIG file but didn't want to have to start over if the connection failed say 1-2 hours in) or even the download manager built in to Firefox (which I've actually had more problems with then Getright)...

It may have to do with the availability of the file(s) or the time difference between reconnects, but I've had it happen both ways.

Have you tried/tested other Telephone Cables from the Jack to the UTV? Do you have Call Waiting enabled/disabled? The UTV might be getting some noise on the line and disconnecting early...

As for your imaging issues... I'm not the expert but I'd suspect the WD's jumpers might have been set wrong (Master/Single mode on ANY UTV Drive) to explain why the "Repair issue call Sony/RCA 1-800-XXX-XXXX" error.

As for the imaging someone who's actually done it might go over your procedure but if you made your 120GB and 40GB drives EXACTLY the same I've had the impression you needed to "adjust" the settings for the specific drive size...

charlcas 09-27-2009 01:12 PM

The imaging process takes care of the size difference. You "select-all" and zero the entire drive. That's where the size difference comes in, and causes a much longer imaging process with the 120gb drive. After zeroing you load the 38mb (I think) image beginning at a specified sector.

I've tried various phone cords with really no difference in success. I was surprised that plugging into the the phone junction box didn't improve anything. I have turned off call waiting, but that doesn't seem to make any difference.

I think you might be right about the jumpers. With the Seagate I have, Master/Single are the same thing. For the 120gb WD, Master means the jumper is in a specific location, and Single is done with no jumper. I assumed the 40gb WD was the same (no diagram on the drive), but I'll have to search for an owners manual to see if that's correct.

I guess I'll start looking at all of my old computers to see if any of them have a drive that I can take.

lgodave 10-14-2010 10:06 AM

It's an old thread... but I thought since my Primary Sony Died (WITH all it's Recordings and Series/Auto Recordings)... I'd bring it back. (FYI, if you need tuner repairs please recheck the FAQ and Repair Threads as repair services from CSS are now discontinued.)

Hard Drive is not being recognized by the UTV (Verified by using UTV Code 411) and is attempting a dialout when I power up. I'm in process of installing a different UTV in it's place until I can verify if the Drive is actual garbage (and maybe still under warranty?) or if the UTV itself has decided to die...

I've been hearing some occasional "hard drive chirp"... which I've played off as possible fan noise (I've adapted a PC Option Card Blower installed above the tuners). This UTV has always been a bit "flakey" (A bit slow on response and occasional reboots)... so I may have just pushed my luck a bridge too far.

I'll keep you posted.

lgodave 10-25-2010 05:18 PM


Well I finally got around to giving my "dead" Sony a few moments of TLC.

Cleaned out the UTV with some compressed Air (cleaned out an oily dust mess under my PC Card Slot Blower which had collected near the tuner chips)...Reinstalled the "junk" drive (didn't attempt to "marry" another drive to the UTV thankfully...) and powered it up.

IT WORKED! So I reconnected it to the SAT. The "Chirping" returned... and the UTV locked up. Pulled the plug and attempted a reboot... got a "Green Light of Death". Disconnected SAT and rebooted it came back to life. Hoped on directv and got to the troubleshooting section. Found my Access Card... reconnected the SAT and reauthorized the card. Card was Activated... Checked a Recording. Stopped it... UTV "chirped" and locked up. Disconnected SAT again and rebooted. Works on several Recordings.

Crossing my fingers and hoping I've got enough time to dump recordings "offline".

I've always thought "Green Light of Death" was Tuner related but this chirping and lockup (with disappearing Drive) seems HD related. Guess only thing I can do is get what recordings I can off, swap Hard Drives and see what happens. Otherwise another UTV goes on the "spare parts" pile.

lgodave 11-02-2010 07:59 AM

Well yesterday my "replacement" Sony decided to pull the same "play dead" with the hard drive and try dialing out for an update.

So it's back to putting my "dead" UTV back into Primary Service again. At the moment it seems to be behaving. The "replacement" UTV really could have used an extra internal fan... but I really liked how "quiet" it was compared to my modified version.

I guess I'll need to try some modifications for "next time".

All times are GMT -7. The time now is 10:55 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
vBulletin Security provided by vBSecurity (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.