DUST BLOBS ON THE 5010 LCD PANELS - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 03-13-2014, 10:15 AM - Thread Starter
Senior Member
 
Gil Arroyo's Avatar
 
Join Date: Feb 2002
Location: SEATTLE, WA
Posts: 328
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Liked: 32
4065 Hours on my Epson 5010 projector.

Recently, 5 or 6 dust blobs show up on the LCD panel during scene changes or in very dark scenes. When almost black, many more blobs can be seen.
The blobs are mostly gray and about 2 inches round on a 100 inch screen, possible hint of green. Near in focus with limit focus setting and picture far out of focus.

Sanyo had a 'port' for dust removal.

Epson advises a trip to a professional repair company.

The 5010 is a great projector. My replacement lamp (from China) is about as bright as the original with 4065 hours on it (did not fail).

I would like it to be perfect until the 4K and/or LED lamp replaces the 5010.

My Question: Has anyone had good results either brushing or blowing at the LCD panels? Full advisory needed if this is a practical approach.

gil:confused:
Gil Arroyo is offline  
Sponsored Links
Advertisement
 
Reply Digital Projectors - Under $3,000 USD MSRP

Tags
Epson 5010 Powerlite Home Cinema 3d Front Projector

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off