Official Epson 5040ub/6040ub owners thread - Page 597 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 26950Likes
Reply
 
Thread Tools
post #17881 of 18068 Old 08-24-2019, 02:15 PM
Advanced Member
 
AdamAttewell's Avatar
 
Join Date: Sep 2014
Location: UK
Posts: 945
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 739 Post(s)
Liked: 160
Quote:
Originally Posted by gacomeau View Post
Thanks for the response. I should have mentioned that I unplugged both HDMI cables from the projector and the line is still there.

Sent from my LG-H831 using Tapatalk

Looks like your in Epson's hands now then, good luck.
AdamAttewell is online now  
Sponsored Links
Advertisement
 
post #17882 of 18068 Old 08-24-2019, 03:21 PM
Member
 
marffeus's Avatar
 
Join Date: Sep 2009
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 10
Quote:
Originally Posted by 314carpenter View Post
Top notch customer service. Contact the California office for even better service. They even have an agent who reads this thread. You will not have any problems getting a warranty replacement with only a couple of weeks expired. I know because they told me so. I would expect that original owners from authorized retailers with warranties expiring to continue to be offered refurbs for the rest of 2019 as well.
Is there a direct number to reach them? I've searched and only can find the 1800 number which sends me over seas and so far they have not been helpful

Sent from my GM1917 using Tapatalk
marffeus is offline  
post #17883 of 18068 Old 08-24-2019, 07:31 PM
Member
 
Brettmckinney's Avatar
 
Join Date: Jun 2005
Posts: 70
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 52 Post(s)
Liked: 42
I've noticed the last couple of nights when watching some movies that I can see the light beam moving across the screen. For example, we were watching The Matrix 4k bluray and when there were HDR highlights or bright spots, I could see small light beams move across the image to hit that spot. I've noticed noticed this before and was really irritating! One thing to note, it's been really cold here (Australia) and I've had our wood fire going a lot - could it be light hitting smoke or something?
I did notice it disappear towards the end of the film.

Screen wise I'm using a pretty cheap portable screen on a tripod and it's not very flat, it as a few creases etc.

Any thoughts?
Brettmckinney is offline  
Sponsored Links
Advertisement
 
post #17884 of 18068 Old 08-24-2019, 10:12 PM
Newbie
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 0
Yes pick up at least an elite screen and make sure that there's no light bleed going through the screen.. I made my own screen with an Amazon 1.0 gain screen with my own border and the light bleed just ruin the picture. Get a good screen and your uniformity on brightness and colour should be great
Pearcebud is offline  
post #17885 of 18068 Old 08-25-2019, 09:57 AM
Newbie
 
luc182's Avatar
 
Join Date: Feb 2006
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 14
I'm considering the 5040UB, but I'm confused on the HDMI limitations. I know it can't do 4K HDR at 60 fps, but what limitations does that translate to in terms of content I can't watch? I've heard people mention gaming, but I don't game.
luc182 is offline  
post #17886 of 18068 Old 08-25-2019, 01:54 PM
AVS Forum Special Member
 
roland6465's Avatar
 
Join Date: Apr 2001
Location: NC, USA
Posts: 1,574
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 416 Post(s)
Liked: 412
Quote:
Originally Posted by luc182 View Post
I'm considering the 5040UB, but I'm confused on the HDMI limitations. I know it can't do 4K HDR at 60 fps, but what limitations does that translate to in terms of content I can't watch? I've heard people mention gaming, but I don't game.

If you can set your source to max output 4K/HDR/30, you will be covered. 24fps movies and American shows, as well as UK shows that should be downrezzed to 4K/HDR/25 will play as intended. I use AppleTV4K, and sometimes British HDR shows play fine, and sometimes I have to go into the video settings and force 4K/HDR/25 to my projector.
roland6465 is offline  
post #17887 of 18068 Old 08-25-2019, 10:47 PM
Newbie
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 0
Hi everyone. So I just recently picked up the 5040ub and I'm noticing that with some TV shows and movies I'm able to see a lot of pixels. Any reason for this in the settings? Also does anybody have a Baseline calibration for the projector for colour etc?
Pearcebud is offline  
post #17888 of 18068 Old 08-26-2019, 03:41 AM
AVS Forum Special Member
 
Cattledog's Avatar
 
Join Date: Oct 2003
Location: Atlanta
Posts: 1,855
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked: 44
Quote:
Originally Posted by Pearcebud View Post
Hi everyone. So I just recently picked up the 5040ub and I'm noticing that with some TV shows and movies I'm able to see a lot of pixels. Any reason for this in the settings? Also does anybody have a Baseline calibration for the projector for colour etc?
You said "some" please explain, because I have never seen any pixels sitting 12 ft from my 92" screen with a 1080p source.

Reality Based.
Cattledog is online now  
post #17889 of 18068 Old 08-26-2019, 03:47 AM
Newbie
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 0
Yes. I am sitting about eleven feet back with a hundred inch elite screen. I find when I watch TV I can makeout alot of pixels. 4K Blu-ray movies for really good quality Netflix shows are the ones that I can't see any pixels whatsoever. Not sure what the cause is. Screen or settings? I do find when I turn on Pixel enhancement 4 TV I'm able to pick out the pixels more also..
Pearcebud is offline  
post #17890 of 18068 Old 08-26-2019, 04:14 AM
AVS Forum Special Member
 
Cattledog's Avatar
 
Join Date: Oct 2003
Location: Atlanta
Posts: 1,855
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 72 Post(s)
Liked: 44
Quote:
Originally Posted by Pearcebud View Post
Yes. I am sitting about eleven feet back with a hundred inch elite screen. I find when I watch TV I can makeout alot of pixels. 4K Blu-ray movies for really good quality Netflix shows are the ones that I can't see any pixels whatsoever. Not sure what the cause is. Screen or settings? I do find when I turn on Pixel enhancement 4 TV I'm able to pick out the pixels more also..
Has to be settings. I don't see any pixels with a 1080i or 720p TV source.

Reality Based.
Cattledog is online now  
post #17891 of 18068 Old 08-26-2019, 04:03 PM
Member
 
john hunter's Avatar
 
Join Date: Apr 2007
Posts: 198
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 78 Post(s)
Liked: 25
Quote:
Originally Posted by Cattledog View Post
Has to be settings. I don't see any pixels with a 1080i or 720p TV source.
Ditto. Just a great picture.
john hunter is offline  
post #17892 of 18068 Old 08-27-2019, 08:57 AM
Member
 
farmecologist's Avatar
 
Join Date: Sep 2008
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 3
Quote:
Originally Posted by Argyle Shepard View Post
Received my second refurb unit yesterday. This one does not have dust blobs, but the alignment is all messed up. When I go into the alignment mode I noticed that there’s no way to converge the rgb on certain lines. So I may get some on the right side to be tight, but the ones on the left are totally off. In normal viewing, i notice that the left side of the screen is noticeably softer than the center. This is very obvious with text.

It sucks because the previous refurb had perfect alignment, but the giant dust blob. I wish I could blow out that dust blob and be done with the lottery. Have to call today about having a third refurb unit sent out. Meanwhile during all of this back and forth, Epson has a $1500 hold on my card.
The alignment on my unit was slightly off when I received it. When using the PC, there was a noticeable green horizontal line on the bottom of white windows (in WIN10). I went thru the LCD alignment process and after a couple hours of messing with it, I'm pretty happy with it now.

You might want to try going through the LCD alignment process. Multi LCD projectors can be prone to alignment issues. However, the alignment on your unit seems much worse than my unit was.
farmecologist is offline  
post #17893 of 18068 Old 08-27-2019, 09:53 AM
Senior Member
 
Bklynblaze's Avatar
 
Join Date: Aug 2013
Posts: 236
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 280 Post(s)
Liked: 81
Quote:
Originally Posted by Pearcebud View Post
Yes. I am sitting about eleven feet back with a hundred inch elite screen. I find when I watch TV I can makeout alot of pixels. 4K Blu-ray movies for really good quality Netflix shows are the ones that I can't see any pixels whatsoever. Not sure what the cause is. Screen or settings? I do find when I turn on Pixel enhancement 4 TV I'm able to pick out the pixels more also..
Did you go into settings and adjust the frame interpolation if using a 1080P broadcast?
Bklynblaze is offline  
post #17894 of 18068 Old 08-27-2019, 11:58 AM
Member
 
Argyle Shepard's Avatar
 
Join Date: Dec 2013
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 49 Post(s)
Liked: 17
Quote:
Originally Posted by farmecologist View Post
The alignment on my unit was slightly off when I received it. When using the PC, there was a noticeable green horizontal line on the bottom of white windows (in WIN10). I went thru the LCD alignment process and after a couple hours of messing with it, I'm pretty happy with it now.

You might want to try going through the LCD alignment process. Multi LCD projectors can be prone to alignment issues. However, the alignment on your unit seems much worse than my unit was.
Believe it or not, I may just keep this one. I hate playing this refurb game and I'm already on the second one. On text it's obvious, but when watching movies it's not very noticeable. With any other electronic it would be unacceptable at this price, but I don't want to be at Fedex every other day.
Argyle Shepard is offline  
post #17895 of 18068 Old 08-27-2019, 06:20 PM
Advanced Member
 
BradP's Avatar
 
Join Date: Jul 2002
Posts: 529
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Liked: 25
Anyone know if the Panasonic TY-EW3D3MU 3D Glasses work on this unit? I bought some thinking they were compatible and now I can’t tell if I got some bad glasses or if they actually don’t work on this particular model 5040UB.
BradP is offline  
post #17896 of 18068 Old 08-27-2019, 07:43 PM
Senior Member
 
Join Date: Dec 2015
Posts: 365
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 242 Post(s)
Liked: 28
Quote:
Originally Posted by farmecologist View Post
The alignment on my unit was slightly off when I received it. When using the PC, there was a noticeable green horizontal line on the bottom of white windows (in WIN10). I went thru the LCD alignment process and after a couple hours of messing with it, I'm pretty happy with it now.



You might want to try going through the LCD alignment process. Multi LCD projectors can be prone to alignment issues. However, the alignment on your unit seems much worse than my unit was.
I have been to the meny and I have got it sharper, but I don't know if I'm doing it correct. Can you tell me or show me a picture of how the lines should be? Should they be on the same line 'over' each other, on both sides of the middle one or how should it align? Thanks!

Skickat från min SM-G960F via Tapatalk
westbergjoakim is offline  
post #17897 of 18068 Old 08-28-2019, 07:45 AM
Senior Member
 
Morphx2's Avatar
 
Join Date: Dec 2004
Posts: 453
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Liked: 17
I have a weird problem with my refurb 5040UB. It had 0 hours used on the bulb and 0 bulb changes; so I guess it is new? I have around 11 hours on it right now.

The screen image is not square on each side.

If I get the top of the screen to be straight, the bottom of the screen is slightly crooked

If I get the bottom of the screen straight, the top is slightly crooked.

There is no keystone on or anything like that.

Any ideas?
Morphx2 is online now  
post #17898 of 18068 Old 08-28-2019, 07:58 AM
AVS Forum Special Member
 
Join Date: Dec 2014
Location: Mississauga, ON, Canada
Posts: 6,939
Mentioned: 129 Post(s)
Tagged: 0 Thread(s)
Quoted: 4878 Post(s)
Liked: 1842
Quote:
Originally Posted by Morphx2 View Post
I have a weird problem with my refurb 5040UB. It had 0 hours used on the bulb and 0 bulb changes; so I guess it is new? I have around 11 hours on it right now.

The screen image is not square on each side.

If I get the top of the screen to be straight, the bottom of the screen is slightly crooked

If I get the bottom of the screen straight, the top is slightly crooked.

There is no keystone on or anything like that.

Any ideas?
This simply means the projector is not “square” with the screen. Tun the projector slightly towards the shorter side, and then re-centre the image on the screen using the horizontal lens shift.
Dominic Chan is online now  
post #17899 of 18068 Old 08-28-2019, 08:00 AM
Senior Member
 
Morphx2's Avatar
 
Join Date: Dec 2004
Posts: 453
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Liked: 17
Quote:
Originally Posted by Dominic Chan View Post
This simply means the projector is not “square” with the screen. Tun the projector slightly towards the shorter side, and then re-centre the image on the screen using the horizontal lens shift.
Thanks. I tried tilting it left and right, but I guess I chose the wrong solution. I'll try yours tonight and see how it goes

Sent from my SM-G975U using Tapatalk
Morphx2 is online now  
post #17900 of 18068 Old 08-28-2019, 08:25 AM
AVS Forum Special Member
 
Join Date: Dec 2014
Location: Mississauga, ON, Canada
Posts: 6,939
Mentioned: 129 Post(s)
Tagged: 0 Thread(s)
Quoted: 4878 Post(s)
Liked: 1842
Quote:
Originally Posted by Morphx2 View Post
Thanks. I tried tilting it left and right, but I guess I chose the wrong solution. I'll try yours tonight and see how it goes

Sent from my SM-G975U using Tapatalk
Tilting it left and right (roll adjustment) will only shift the problem from top to bottom, to vice versa. You need to adjust the yaw until the left- and right-side edges are of the same height, and then adjust the roll so that the image is level (too and bottom).
Attached Thumbnails
Click image for larger version

Name:	838B3205-4AA2-4EAD-9F60-C4110EEB466E.png
Views:	34
Size:	11.1 KB
ID:	2608264  
Dominic Chan is online now  
post #17901 of 18068 Old 08-28-2019, 08:29 AM
Senior Member
 
tibimakai's Avatar
 
Join Date: Dec 2011
Location: Los Angeles CA
Posts: 338
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 180 Post(s)
Liked: 50
I'm considering this pj, but I have a concern about the FL number. I have a light controlled room(dark garage) and the FL showing in the projector calculator is 70(ProjectorCentral's Estimate/50 Manufacturer's Estimate). That is to high, right? Screen's gain is 1:1.
Can be done something about this, maybe some adjustment on the pj?

Living Room: Samsung UN65JS8500, Onkyo TX-NR656, Klipsch R-28F, Klipsch RC-62II, Klipsch R-14S, Polk Audio 80 FX/RT(Atmos)
Bedroom: Samsung UN55MU6290, Onkyo TX-RZ610, Onkyo & Fluance speakers
Garage: Benq HT2050A, Elite Screens 125" motorized screen, Klipsch RP-160M, Klipsch RP-150M, Klipsch RP-450C , 2 x Klipsch CDT-3800 II for Atmos, Klipsch RW10

Last edited by tibimakai; 08-28-2019 at 09:02 AM.
tibimakai is offline  
post #17902 of 18068 Old 08-29-2019, 09:02 AM
Senior Member
 
Join Date: Feb 2015
Posts: 242
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 163 Post(s)
Liked: 16
So after 8 months of limited use my Epson 5040UB crapped out on me! I received the "refurbished" replacement yesterday and will hook it up to see how it goes. I guess I was a bit naive to think that this power supply issue wouldnt catch me! My question to you guys who have had a similar issue, have you had any success with Epson sending you a brand new unit as opposed to a refurbished, or a 5050UB instead. I find it ridiculous that I now have a refurbished unit which I could have bought at half the price of a new one, and have zero confidence that its going to give me 2 solid years of use before breaking again! Thanks
Gazzer55 is offline  
post #17903 of 18068 Old 08-29-2019, 09:07 AM
Advanced Member
 
DavidinGA's Avatar
 
Join Date: Jan 2010
Location: GA
Posts: 663
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 317 Post(s)
Liked: 110
Quote:
Originally Posted by Gazzer55 View Post
So after 8 months of limited use my Epson 5040UB crapped out on me! I received the "refurbished" replacement yesterday and will hook it up to see how it goes. I guess I was a bit naive to think that this power supply issue wouldnt catch me! My question to you guys who have had a similar issue, have you had any success with Epson sending you a brand new unit as opposed to a refurbished, or a 5050UB instead. I find it ridiculous that I now have a refurbished unit which I could have bought at half the price of a new one, and have zero confidence that its going to give me 2 solid years of use before breaking again! Thanks
I think Epson will *eventually* start sending out refurb 5050 units to replace failed 5040 units, especially now that Epson's excess stock of 5040's has been depleted (Epson USA finally went OOS on it's 5040 clearance). I just picked up a refurb 5040 and it has a 2yr warranty and I would highly doubt they'll have any 5040's on hand to replace mine if it failed almost 2 years from now...

--------------------------------------------------
Source: HTPC w/madVR, Video: Epson 5040, 150" 16:9, Audio: Onkyo RZ 830 avr, 5.1.4 Atmos setup. 5 speaker Energy C Series: L/R C300's, C C-C100, SR/SL C50's, 4 in-ceiling Micca R-8c. Subwoofer: MiniMarty um18 w/NX3000D.
DavidinGA is offline  
post #17904 of 18068 Old 08-29-2019, 11:18 AM
Senior Member
 
tibimakai's Avatar
 
Join Date: Dec 2011
Location: Los Angeles CA
Posts: 338
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 180 Post(s)
Liked: 50
I guess, it is wise than to wait, until they are super low on stock and maybe next time, we will get a 5050.
How are the 5050s? Have any issues?

Living Room: Samsung UN65JS8500, Onkyo TX-NR656, Klipsch R-28F, Klipsch RC-62II, Klipsch R-14S, Polk Audio 80 FX/RT(Atmos)
Bedroom: Samsung UN55MU6290, Onkyo TX-RZ610, Onkyo & Fluance speakers
Garage: Benq HT2050A, Elite Screens 125" motorized screen, Klipsch RP-160M, Klipsch RP-150M, Klipsch RP-450C , 2 x Klipsch CDT-3800 II for Atmos, Klipsch RW10
tibimakai is offline  
post #17905 of 18068 Old 08-29-2019, 01:30 PM
Newbie
 
Join Date: Nov 2018
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 0
Quote:
Originally Posted by luc182 View Post
I'm considering the 5040UB, but I'm confused on the HDMI limitations. I know it can't do 4K HDR at 60 fps, but what limitations does that translate to in terms of content I can't watch? I've heard people mention gaming, but I don't game.
The only effect I notice is my Netflix app plays at 4k 60hz, so no HDR on content streamed from them. I really like 4k discs, which look great, but also stream 4k HDR from Amazon and VUDU.
Darrell Money is offline  
post #17906 of 18068 Old 08-29-2019, 01:36 PM
Newbie
 
Join Date: Nov 2018
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 0
Quote:
Originally Posted by Morphx2 View Post
I have a weird problem with my refurb 5040UB. It had 0 hours used on the bulb and 0 bulb changes; so I guess it is new? I have around 11 hours on it right now.

The screen image is not square on each side.

If I get the top of the screen to be straight, the bottom of the screen is slightly crooked

If I get the bottom of the screen straight, the top is slightly crooked.

There is no keystone on or anything like that.

Any ideas?
There is keystone adjustment, but my suggestion is to get your screen and projector perfectly aligned. This was my first PJ, and I installed myself. It took me a LONG time to get it right (note: not all walls are perfectly plumb).
Darrell Money is offline  
post #17907 of 18068 Old 08-30-2019, 12:38 AM
Newbie
 
Join Date: Aug 2019
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 0
Anyone else notice for watching 1080p content that turning on 4k enhancement makes the picture less sharp? I find turning it on washes out the text and sharpness overall. Is there something im doing wrong? I turn 4k.enhancement off with preset 5 and i find it looks really sharp. The only.time i find 4k enhancement works well is with blue ray or 4k ultras. Any settings.you guys reccomend?
Pearcebud is offline  
post #17908 of 18068 Old 08-30-2019, 12:03 PM
AVS Forum Special Member
 
luismanrara's Avatar
 
Join Date: May 2005
Posts: 1,170
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 194 Post(s)
Liked: 130
Check out this comparison by TV Specialists vs 2 more expensive units, the fact that is being compared to units that cost twice as much or more is in itself incredible.

It's amazing what picture quality this projector has at its price.

Do not steal, The powers that be do not like the competition.
luismanrara is offline  
post #17909 of 18068 Old 08-30-2019, 12:48 PM
Advanced Member
 
DavidinGA's Avatar
 
Join Date: Jan 2010
Location: GA
Posts: 663
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 317 Post(s)
Liked: 110
Quote:
Originally Posted by luismanrara View Post
Check out this comparison by TV Specialists vs 2 more expensive units, the fact that is being compared to units that cost twice as much or more is in itself incredible. https://www.youtube.com/watch?v=yUroCr7AtDo&t=46s

It's amazing what picture quality this projector has at its price.

What I would love to see is a face-off between a 5040 running madVR vs a 5050 (w/o running madVR) running its new HDR algo's. I would wager to guess you couldn't see any difference....

--------------------------------------------------
Source: HTPC w/madVR, Video: Epson 5040, 150" 16:9, Audio: Onkyo RZ 830 avr, 5.1.4 Atmos setup. 5 speaker Energy C Series: L/R C300's, C C-C100, SR/SL C50's, 4 in-ceiling Micca R-8c. Subwoofer: MiniMarty um18 w/NX3000D.
DavidinGA is offline  
post #17910 of 18068 Old 08-30-2019, 05:47 PM
Newbie
 
yiepyiep's Avatar
 
Join Date: Feb 2009
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Hi guys. I have bought the tw9400 for a couple of weeks. It has been a great. However, i have noticed that the movie freezed when i access to the gamma menu for making adjustment. The movie continue to play again, after i have exited the gamma menu. May i ask if this is normal? My worry is that the projector shut down during operation, with both the blue and orange lights continuously blinking. A check on the user manual shows it's a internal error, which freaks me out. I may be wrong, but i remember previously the picture didnot freeze, when im accessing the gamma adjustment menu.
yiepyiep is offline  
Sponsored Links
Advertisement
 
Reply Digital Projectors - Under $3,000 USD MSRP

Tags
5040ub power , atmos

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off