BenQ W2700 / HT3550 Announcement and Owner’s Thread - Page 199 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 3248Likes
Reply
 
Thread Tools
post #5941 of 6192 Old 03-06-2020, 09:57 AM
Member
 
Spaded21's Avatar
 
Join Date: Aug 2011
Location: Tinley Park, IL
Posts: 106
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Liked: 45
Quote:
Originally Posted by Anubus12 View Post
you see the green tint as well though correct? you may be right about letting eyes adjust, but is WGC = ON definitively more accurate color? Proven from people who have equipment to test?
I'm not sure, it sounds like some people were having an actual issue where maybe it was really green. To me it only looks like that right when you switch it, as compared to it being off. After a minute or two it looks fine, just dimmer. However I was watching Blade Runner 2049 last night and that is one movie where WCG=On is definitely better.
Manisfive likes this.

7.2.4 BenQ/Marantz/HTD/Micca/SVS/Dayton
Spaded21 is offline  
Sponsored Links
Advertisement
 
post #5942 of 6192 Old 03-07-2020, 05:01 AM
Member
 
JPHCCFC's Avatar
 
Join Date: Dec 2007
Posts: 137
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 80 Post(s)
Liked: 27
Quote:
Originally Posted by Jeffrey Chiafu Hsieh View Post
What game(s) do you play? There were many HT3550 owners shared their experience of using HT3550 with PS4 Pro or XBox One?


Sent from my iPhone using Tapatalk
I play fifa20, Forza, PUBG, Mario Kart and none of the family notice any lag
JPHCCFC is offline  
post #5943 of 6192 Old 03-07-2020, 08:33 AM
Member
 
Join Date: Nov 2018
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 13
Quote:
Originally Posted by JPHCCFC View Post
I play fifa20, Forza, PUBG, Mario Kart and none of the family notice any lag


PUBG with HT3550? Wow! That is great to hear this feedback! Thanks @JPHCCFC


Sent from my iPhone using Tapatalk
Jeffrey Chiafu Hsieh is offline  
Sponsored Links
Advertisement
 
post #5944 of 6192 Old 03-07-2020, 11:51 AM
Member
 
Manisfive's Avatar
 
Join Date: Mar 2018
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Liked: 9
Lots activity on this thread. I don't know how often longtime ht3550 users check in here but if you're listening what are your go to, preferred settings and tweaks for this badboy. I just received mine from FedEx. It's q refurbished model direct from BenQ. I should be shooting a 120 inch image in a light controlled room with light colored walls and a white ceiling by next week. I know 120 inch is the top side of where this dude is optimized. Any tips or suggestions would be appreciated.

Sent from my SM-N975U using Tapatalk
Manisfive is offline  
post #5945 of 6192 Old 03-08-2020, 04:29 PM
AVS Forum Special Member
 
bori's Avatar
 
Join Date: Sep 2006
Posts: 3,294
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 145
Is everyone experience slow bootup time of this projector? I had the W1070 and it started up alot quicker. Anyway to speed the projector startup?

Sent from my GM1917 using Tapatalk
bori is offline  
post #5946 of 6192 Old 03-08-2020, 04:58 PM
Member
 
Manisfive's Avatar
 
Join Date: Mar 2018
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Liked: 9
Quote:
Originally Posted by bori View Post
Is everyone experience slow bootup time of this projector? I had the W1070 and it started up alot quicker. Anyway to speed the projector startup?

Sent from my GM1917 using Tapatalk
My bootup is slow.

Sent from my SM-N975U using Tapatalk
Manisfive is offline  
post #5947 of 6192 Old 03-08-2020, 06:26 PM
Member
 
jimchao's Avatar
 
Join Date: Oct 2012
Location: LA
Posts: 86
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Liked: 49
Quote:
Originally Posted by oneil50 View Post
I found jimchao's not so good on mine with WCG on.
I'm not a pro but this is my values with displaypro :

For SDR content :

Brightness 49
Contrast 48
Color/Tint 50
Sharpness 8
Gamma 2.2
Color Temp Normal
Red gain 103
Green gain 99
Blue gain 98
Red offset 247
Green offset 260
Blue offset 257
Color Management
Hue Sat Gain
R 200 194 152
G 274 241 176
B 177 196 175
C 215 238 190
M 134 186 165
Y 300 173 166
Brilliant Color : Off
Dynamic Iris : High
Light Mode NORMAL

Measures : contrast 0% : 560:1 (With DI off) and brightness 100% : 17 FTL



For HDR content :

Mode Cinema HDR
Brightness 50
Contrast 48
Color/Tint 50
Sharpness 8
Gamma 2.2
Color Temp Normal
Red gain 97
Green gain 100
Blue gain 98
Red offset 249
Green offset 257
Blue offset 258
Color Management
Hue Sat Gain
R 193 220 200
G 220 200 200
B 200 215 200
C 222 265 200
M 200 200 200
Y 231 200 200
Brilliant Color : ON
Dynamic Iris : OFF
Light Mode : NORMAL
WCG : off

Measures : Contrast 0% : 878:1 and brightness 100% : 28FTL



I try many time HDR with WCG ON. But result are worse I ever seen. Gamut range is really good but color occuracy is bad. For grey scale, 0-60% is okay, but 70-100% is bad cause red gain projector is too weak and can't add more. FTL at 70-80-90-100% is same and result is a lot of loss detail in white brightness movie. I notice this while watchning Midway when plane were in the sky.
By the way, I measure 27 FTL with WCG OFF and ONLY 16 FTL with WCG ON.

These result are apply on my system with tecnic screen so it could be not adequate with a white screen.


HT 3550 is a great value for money, but split screen is insane for this price. It appears on mine after 1h30 movie 4-5 time for 1 sec.
Sorry for bad english.

I guess you should double check your calibration gamut for P3. I would not think the post gamut of your calibration enough accuracy. It is far small than BenQ announced and my post calibration for P3. Not only your post gamut is too small, and also your tracing points are almost out of targets.

By the way, I would like to remind those who like to try my setting ( link as my signature) is limited to HDR D.Cinema mode, not in Cinema(Rec. 709). This is because BenQ only calibrate D.Cinema w/o HDR active.

BDP:Sony UBP-X800 LCR:M&K MPS2510 Surround:M&K MPS1625×4 SUB:Rythmik FV15HP HT Prepro:Lexicon MC12B EQ/Anthem MRX510 Power Amp:Lexicon RX7
Stereo:Music server HTPC i5 Jriver Preamp:Bremester 897+MBL 1511F DAC USB Power Amp:Monarchy Audio SE-100 Pure Class A mono mono PJ: HT3550, Acoustical 135” gain 1.2 ** HDR Setting of HT3550** Measurement of HT5550

Last edited by jimchao; 03-08-2020 at 06:48 PM.
jimchao is offline  
post #5948 of 6192 Old 03-08-2020, 06:44 PM
AVS Forum Special Member
 
bori's Avatar
 
Join Date: Sep 2006
Posts: 3,294
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 145
Quote:
Originally Posted by Manisfive View Post
My bootup is slow.

Sent from my SM-N975U using Tapatalk
So I guess it's normal?

Sent from my GM1917 using Tapatalk
bori is offline  
post #5949 of 6192 Old 03-08-2020, 07:08 PM
Member
 
Manisfive's Avatar
 
Join Date: Mar 2018
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Liked: 9
Quote:
Originally Posted by bori View Post
So I guess it's normal?

Sent from my GM1917 using Tapatalk
It has a slow system shut down aswell.

Sent from my SM-N975U using Tapatalk
Manisfive is offline  
post #5950 of 6192 Old 03-08-2020, 08:20 PM
AVS Forum Special Member
 
subacabra's Avatar
 
Join Date: Mar 2016
Location: Hillsborough, New Jersey
Posts: 2,937
Mentioned: 61 Post(s)
Tagged: 1 Thread(s)
Quoted: 1947 Post(s)
Liked: 5678
Mine takes about 30-45 seconds to fully turn on. Doesn't bother me though. If I know I'm going to watch hdr content I give it around ten minutes of regular sdr content to warm up etc.
Here's a fun video of one of my favorite movies Tron Legacy. Really wish they'd re do this in 4k hdr!
subacabra is offline  
post #5951 of 6192 Old 03-08-2020, 09:34 PM
Member
 
Manisfive's Avatar
 
Join Date: Mar 2018
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Liked: 9
Quote:
Originally Posted by subacabra View Post
Mine takes about 30-45 seconds to fully turn on. Doesn't bother me though. If I know I'm going to watch hdr content I give it around ten minutes of regular sdr content to warm up etc.
Here's a fun video of one of my favorite movies Tron Legacy. Really wish they'd re do this in 4k hdr!
https://youtu.be/DFipmzRBl1c
The projector looks damn good in all your videos. I thumbed through them prior to pulling the trigger on buying my ht3550. I'm really happy with my picture so far. I'm shooting it on a small screen right now. My 120inch screen will hopefully be here this week.

Sent from my SM-N975U using Tapatalk
subacabra and ng4ever like this.
Manisfive is offline  
post #5952 of 6192 Old 03-08-2020, 11:19 PM
Member
 
Join Date: Dec 2019
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 4
Quote:
Originally Posted by jimchao View Post
I guess you should double check your calibration gamut for P3. I would not think the post gamut of your calibration enough accuracy. It is far small than BenQ announced and my post calibration for P3. Not only your post gamut is too small, and also your tracing points are almost out of targets.



By the way, I would like to remind those who like to try my setting ( link as my signature) is limited to HDR D.Cinema mode, not in Cinema(Rec. 709). This is because BenQ only calibrate D.Cinema w/o HDR active.
The p3 calibration isn't done but if was with wcg OFF.
How Can we apply D.cinema or users mode with HDR content ?
oneil50 is offline  
post #5953 of 6192 Old 03-09-2020, 07:10 AM
Member
 
The_Weird's Avatar
 
Join Date: May 2010
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 13
Quote:
Originally Posted by oneil50 View Post
The p3 calibration isn't done but if was with wcg OFF.
How Can we apply D.cinema or users mode with HDR content ?
You can't, there is only one HDR preset - "HDR".

"Cinema", "D.Cinema" and "User" are all for only available for SDR content. If you unlock the ISF mode, you can also access two more additional user presets - ISF Day and ISF Night, but these do not allow WCG to be activated.

The one feature I would really like Benq to add is to provide an additional HDR preset so we can have one with WCG active and one without, so there is a real HDR equivalent to Cinema and D. Cinema.
jimchao and ng4ever like this.
The_Weird is offline  
post #5954 of 6192 Old 03-09-2020, 07:19 AM
AVS Forum Special Member
 
sage11x's Avatar
 
Join Date: Dec 2006
Location: Howell, MI
Posts: 7,064
Mentioned: 224 Post(s)
Tagged: 0 Thread(s)
Quoted: 3053 Post(s)
Liked: 3168
Quote:
Originally Posted by home4sale2 View Post
Interesting, are you saying there's nothing wrong physically with the projector, that a firmware upgrade is preventing a startup? Looks like I am within the replacement of bulb warranty (one year if I bought it brand new, which I did) which expires on 3/11 but BenQ had offered another 2 months extension because they sat on my money for a month and a half before they shipped it due to early debacles. I have that in writing should they give me trouble. Waiting to ship once they process / give me an RMA, out two weeks I am told. I told them I was not interested in a refurbish, prefer to get mine fixed.


Hard to say. But, I doubt it’s the lamp. Glad to hear you’re getting the ball rolling on a fix.
ng4ever likes this.

What to do if you find yourself stuck with no hope of rescue:
Consider yourself lucky that life has been good to you so far. Alternatively, if life hasn't been good to you so far, which given your present circumstances seems to be more likely, consider yourself lucky that it won't be troubling you much longer...

-- Excerpt from the Hitchhiker's Guide to the Galaxy.
sage11x is offline  
post #5955 of 6192 Old 03-09-2020, 07:33 AM
AVS Forum Special Member
 
bori's Avatar
 
Join Date: Sep 2006
Posts: 3,294
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 145
Why does the benq logo flicker in the bootup sequence?

Sent from my GM1917 using Tapatalk
bori is offline  
post #5956 of 6192 Old 03-09-2020, 10:36 AM
Member
 
Join Date: Mar 2015
Posts: 128
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 34
Got the RMA process rolling. But I had to beg them to not send me a refurb unit - which initially they said they would do.
xealo is offline  
post #5957 of 6192 Old 03-09-2020, 11:42 AM
Newbie
 
Join Date: Mar 2020
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 1
Benq W2700 doesnt actually support 120hz?

Just wanted to share my experience with the w2700. I upgraded from a w1070 and Its a notable upgrade. At first playing HDR content on my projector using my PC resulted in a yellow tinted image but that was easily fixed with a firmware update (1.0.5).

I took this projector for both movies and gaming with the hope of lower latency with 120hz as 4K mode has a little input lag.

On to the gaming part.

The 120hz 1080p refresh rate did not show up by default in my projector. I had to add a custom resolution for it to show up.

After I selected 120hz 1080p there is no additional smoothness to my motion. I even ran the UFO test frame rate skipping checker and I notice its actually skipping frames, so that makes me thing it runs 60hz even though it states 120. So kinda like a fake 120hz.

There is a test on blur busters where we can check for frame skipping. FPS Skip check

More curious is that I can actually add a custom resolution of 240hz as well for 1080p.
The Benq display resolution icon even shows this. Using the skip test the effect is even more accentuated with 240hz.

Specs:
The source is GPU, a 1080 TI, it goes directly from the GPU to projector. On the PC 4K 60 and even HDR works fine.

I got a 4K 60 fiber optic hdmi cable. FeizLink HDMI Cable

Anyone else has the same experience as me?
Constantin Georgiu is offline  
post #5958 of 6192 Old 03-09-2020, 12:28 PM
Member
 
Join Date: Mar 2015
Posts: 128
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 34
Quote:
Originally Posted by Constantin Georgiu View Post
Benq W2700 doesnt actually support 120hz?

Just wanted to share my experience with the w2700. I upgraded from a w1070 and Its a notable upgrade. At first playing HDR content on my projector using my PC resulted in a yellow tinted image but that was easily fixed with a firmware update (1.0.5).

I took this projector for both movies and gaming with the hope of lower latency with 120hz as 4K mode has a little input lag.

On to the gaming part.

The 120hz 1080p refresh rate did not show up by default in my projector. I had to add a custom resolution for it to show up.

After I selected 120hz 1080p there is no additional smoothness to my motion. I even ran the UFO test frame rate skipping checker and I notice its actually skipping frames, so that makes me thing it runs 60hz even though it states 120. So kinda like a fake 120hz.

There is a test on blur busters where we can check for frame skipping. FPS Skip check

More curious is that I can actually add a custom resolution of 240hz as well for 1080p.
The Benq display resolution icon even shows this. Using the skip test the effect is even more accentuated with 240hz.

Specs:
The source is GPU, a 1080 TI, it goes directly from the GPU to projector. On the PC 4K 60 and even HDR works fine.

I got a 4K 60 fiber optic hdmi cable. FeizLink HDMI Cable

Anyone else has the same experience as me?
It can't do 4k @ 120hz. Max is 2160p/60. I don't think there even is such a 4K PJ that is capable of that.
ng4ever likes this.

Last edited by xealo; 03-09-2020 at 12:31 PM.
xealo is offline  
post #5959 of 6192 Old 03-09-2020, 01:30 PM
Newbie
 
Join Date: Mar 2020
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 1
Quote:
Originally Posted by xealo View Post
It can't do 4k @ 120hz. Max is 2160p/60. I don't think there even is such a 4K PJ that is capable of that.
I was trying 1080p and 120hz. Yes, 4K 60 is the max it goes on my machine as well.
ng4ever likes this.
Constantin Georgiu is offline  
post #5960 of 6192 Old 03-09-2020, 03:40 PM
Member
 
Join Date: Mar 2015
Posts: 128
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 34
Quote:
Originally Posted by Constantin Georgiu View Post
I was trying 1080p and 120hz. Yes, 4K 60 is the max it goes on my machine as well.
Here is what I found via someone asking on Amazon:

Thank you for your interest in our HT3550 4K Home Theater Projector. We are pleased to inform you that this model does indeed support 1080p content at 120Hz refresh rate. To reach the resolution, you have to connect through the HDMI 2.0 port. In case you would like to know more about the timing chart, please refer to page 41 in the user manual, which can be downloaded here:

https://www.benq.com/en-us/support/d...50/manual.html
ng4ever likes this.

Last edited by xealo; 03-09-2020 at 03:46 PM.
xealo is offline  
post #5961 of 6192 Old 03-09-2020, 03:44 PM
Member
 
JPHCCFC's Avatar
 
Join Date: Dec 2007
Posts: 137
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 80 Post(s)
Liked: 27
Quote:
Originally Posted by bori View Post
Is everyone experience slow bootup time of this projector? I had the W1070 and it started up alot quicker. Anyway to speed the projector startup?

Sent from my GM1917 using Tapatalk
Definitely slower than my w1070
bori and ng4ever like this.

Last edited by JPHCCFC; 03-09-2020 at 03:47 PM.
JPHCCFC is offline  
post #5962 of 6192 Old 03-09-2020, 07:08 PM
Senior Member
 
home4sale2's Avatar
 
Join Date: Jun 2003
Posts: 224
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Liked: 63
Quote:
Originally Posted by sage11x View Post
Yeah, contact BenQ. The issue sounded similar to a known firmware issue on the recently released TK850 which BenQ is prepping a firmware update to fix.
Quote:
Originally Posted by xealo View Post
Got the RMA process rolling. But I had to beg them to not send me a refurb unit - which initially they said they would do.
Good to know. My support agent persisted that I had no choice and it would be a refurbished unit. I have liked my unit for the most part so didn't fight it. With wife and daughter on our living room TV with a crappy season of whatever stuff they watch, I am on a laptop with no projector/TV, boohoo.
home4sale2 is offline  
post #5963 of 6192 Old 03-10-2020, 09:57 AM
AVS Forum Special Member
 
bori's Avatar
 
Join Date: Sep 2006
Posts: 3,294
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 145
Why does it show that HDR is not working on the Xbox one X. Is there a setting on the projector I need to change?

Sent from my GM1917 using Tapatalk
bori is offline  
post #5964 of 6192 Old 03-10-2020, 11:56 AM
Member
 
Join Date: Mar 2015
Posts: 128
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 34
Quote:
Originally Posted by home4sale2 View Post
Good to know. My support agent persisted that I had no choice and it would be a refurbished unit. I have liked my unit for the most part so didn't fight it. With wife and daughter on our living room TV with a crappy season of whatever stuff they watch, I am on a laptop with no projector/TV, boohoo.
Ya mine was being persistent as well. I told him that this is my 4th Benq PJ. And knowing my luck, I would get a bad refurb. I begged for a 1 time courtesy of sending a new one.
Quote:
Originally Posted by bori View Post
Why does it show that HDR is not working on the Xbox one X. Is there a setting on the projector I need to change?

Sent from my GM1917 using Tapatalk
Other than setting HDR to "Auto", no.
xealo is offline  
post #5965 of 6192 Old 03-10-2020, 03:56 PM
AVS Forum Special Member
 
bori's Avatar
 
Join Date: Sep 2006
Posts: 3,294
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 145
Why can't I get Xbox One X to support HDR and Dolby Vision. I have a Onkyo TX-NR838



Sent from my GM1917 using Tapatalk
bori is offline  
post #5966 of 6192 Old 03-10-2020, 04:44 PM
AVS Forum Special Member
 
subacabra's Avatar
 
Join Date: Mar 2016
Location: Hillsborough, New Jersey
Posts: 2,937
Mentioned: 61 Post(s)
Tagged: 1 Thread(s)
Quoted: 1947 Post(s)
Liked: 5678
Quote:
Originally Posted by bori View Post
Why can't I get Xbox One X to support HDR and Dolby Vision. I have a Onkyo TX-NR838



Sent from my GM1917 using Tapatalk
It doesn't have Dolby Vision. Maybe a setting in your avr or your cable?
I get all green checks(except DV of course) with my Xbox One X, Denon x6200w and Ruipro fiber hdmi.
subacabra is offline  
post #5967 of 6192 Old 03-10-2020, 04:55 PM
AVS Forum Special Member
 
bori's Avatar
 
Join Date: Sep 2006
Posts: 3,294
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 277 Post(s)
Liked: 145
Is the NR838 capable of all these features?

Sent from my GM1917 using Tapatalk
bori is offline  
post #5968 of 6192 Old 03-10-2020, 05:43 PM
AVS Forum Special Member
 
subacabra's Avatar
 
Join Date: Mar 2016
Location: Hillsborough, New Jersey
Posts: 2,937
Mentioned: 61 Post(s)
Tagged: 1 Thread(s)
Quoted: 1947 Post(s)
Liked: 5678
Quote:
Originally Posted by bori View Post
Is the NR838 capable of all these features?

Sent from my GM1917 using Tapatalk
Quick search
Time for a newer model
Yellbean and xealo like this.
subacabra is offline  
post #5969 of 6192 Old 03-10-2020, 07:04 PM
Member
 
Join Date: Mar 2015
Posts: 128
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 81 Post(s)
Liked: 34
Ight, Benq just shipped out a new replacement. Fingers crossed its one made recently. We shall see how it compares to my April '19 made one.
xealo is offline  
post #5970 of 6192 Old 03-10-2020, 09:36 PM
Senior Member
 
home4sale2's Avatar
 
Join Date: Jun 2003
Posts: 224
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Liked: 63
Just got a one year happy Anniversary note while my projector sits disassembled somewhere in Benq repair facility, ironic. And, I have no idea what their statement below even means. Grrr


It's been 1 whole year since you've joined the BenQ family and added a BenQ HT3550 True 4K HDR Projector-Item will ship 4/12 to your tech collection.


Sent from my iPhone using Tapatalk
home4sale2 is offline  
Sponsored Links
Advertisement
 
Reply Digital Projectors - Under $3,000 USD MSRP

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off