Weird Green problem with LG UST LED Projector - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 07-22-2019, 10:27 AM - Thread Starter
Newbie
 
Join Date: Feb 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Angry Weird Green problem with LG UST LED Projector

A few months back I bought an LG HF65LSR - which I believe is basically the European version of the HF65LA, which in turn seems to be an update of the PF1000UW. Well, for the most part I was pretty happy with the purchase, until, that is, I turned the Energy Saving Mode down to "Off". Suddenly everything went bright green. I mean, *really* green. With any other level of energy saving, the colours were as you would expect, dimmer/brighter depending on the level, but neutral. But turn it off, and as well as being brighter, it was really, really green.


So I sent it back; they tested it using the internal test screens, sent it back to me saying there was nothing wrong with it; I sent it back again with a message saying "actually read what I wrote to you this time", they tested it through the UI with the mode switch, found the problem, and tried to fix it. This was a 3rd party repair place that is LG's official after-sales service agent in Spain; they tried everything, up to and including replacing the main PCB, and couldn't fix it. So they sent it back to me and told me to return it for a refund/replacement through the original retailer. Fair enough. I sent it back for an exchange, got a new projector, and obviously the first thing I did was to test the energy saving mode: exactly the same.


LG have been reasonably helpful - they've told me to send it back for a refund, and have promised to get their engineers on the problem and come back to me when they have a proper solution - which might be a software update if this is some sort of general fault in (the particular local version of?) WebOS. I'm disappointed, because there really weren't a great deal of other options that met my requirements (tolerably bright UST LED projector) and I spent a lot of research time working out which product to buy... online to find it's systematically broken :-( Has anyone else (ideally in Europe) encountered this problem/heard of it? I'm wondering if I try and buy something from e.g. Germany if I'm likely to get one that actually works....


Cheers,
lucianh is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-10-2019, 07:15 PM
Newbie
 
Join Date: Sep 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Interesting. Just bought similar projector, LG HF85LSR in the Czech Republic and have exactly the same issue. Did you get anywhere with replacements/other sources?
Endeer is offline  
post #3 of 3 Old 09-10-2019, 10:28 PM - Thread Starter
Newbie
 
Join Date: Feb 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Quote:
Originally Posted by Endeer View Post
Interesting. Just bought similar projector, LG HF85LSR in the Czech Republic and have exactly the same issue. Did you get anywhere with replacements/other sources?

Sadly, no. I sent the projector back and bought an OLED TV instead. Since we didn't really want a massive screen anyway it ended up being a better fit for our needs - a much better picture per watt of power usage than we could ever have hoped for from a projector. I haven't heard anything back from LG yet about a resolution to the original issue. They strongly implied that there would have to be an update to the product line to fix this. It still astonishes and horrifies me that a company the size of LG could release a product like this with such a glaring fault, and apparently no one's talking about it. Is no one buying these things?
lucianh is offline  
Sponsored Links
Advertisement
 
Reply Digital Projectors - Under $3,000 USD MSRP

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off