NEC NP-PA550W Issue. - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 05-21-2020, 02:40 AM - Thread Starter
Newbie
 
Join Date: May 2020
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Unhappy NEC NP-PA550W Issue.

Hello all. I have an NEC NP-PA550W 5500 lumen Projector that projects a great BRIGHT picture. The only issue is that it has a blue'ish Verticle line on the left side. It is a 3LCD projector, I have tried to adjust the Red, Green, and Blue filter's but it remains no matter what I do.

Any suggestions?

I purchased this unit on eBay, when it arrived it was clear it had been dropped, as picking it up I could hear parts rattling around. I took it apart fixed the issues but this is the only one I can't figure out. Yes I did contact the seller sell said they would replace it, but then a few days later told me they don't have one to replace it and refunded my full purchase price.

So this unit has cost me nothing (FREE), so I'm trying to fix and use it!
Attached Thumbnails
Click image for larger version

Name:	IMG_2195.jpg
Views:	11
Size:	951.3 KB
ID:	2730136   Click image for larger version

Name:	IMG_2197.jpg
Views:	11
Size:	660.2 KB
ID:	2730138  
Sub Frequency is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-21-2020, 05:57 AM
AVS Forum Special Member
 
rekbones's Avatar
 
Join Date: Jan 2012
Location: Somers, CT
Posts: 3,752
Mentioned: 80 Post(s)
Tagged: 0 Thread(s)
Quoted: 1333 Post(s)
Liked: 677
One of the components in the optical block is out of place or damaged. The manufactures won't even consider repairing it, they just replace the entire optical block. Some have had success in fixing these kind of issues but its not easy and a lot of trial and error.

"Smart enough to know better, to old to care" ------ Dedicated Bat Cave Home Theater, JVC RS49U/Mitsubishi HC7900DW Projector, 110" 16:9 Jamestown screen with variable power masking for CIW 2.50:1 to 16:9, Marantz 7009 with 7.1.4 Atmos with Ohm mains,3 DIY Subs (2 15" (1 ported, 1 sealed and a 12" 4th order bandpass), 1 DIY butt kicker, Custom Built HTPC, 18TB DroboFS NAS
rekbones is offline  
post #3 of 3 Old 05-21-2020, 09:10 AM
AVS Forum Special Member
 
AV_Integrated's Avatar
 
Join Date: Jun 2005
Location: Northern, VA - Washington, DC
Posts: 6,798
Mentioned: 103 Post(s)
Tagged: 2 Thread(s)
Quoted: 1716 Post(s)
Liked: 1255
It doesn't look like things are out of alignment, because your other colors on the color test pattern are in proper alignment.

My best guess is that your ribbon cable that connects the video processing to the LCD chips is bad to the red section. Since yellow and blue make cyan, it looks like red is missing, which would make that section white.

You should reseat those ribbon cables to see if it corrects the issue.

You can also check out and even ask FixItFrank on YouTube for additional information and perhaps replacement parts. He's one of the most tremendous resources on projector repair that I'm aware of at this time.

AV Integrated - Theater, whole house audio, and technology installation in the Washington DC metro area.
AV_Integrated is offline  
Sponsored Links
Advertisement
 
Reply Digital Projectors - Under $3,000 USD MSRP

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off