Problem with LSI speakers - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 05-15-2019, 07:50 PM - Thread Starter
Advanced Member
 
Rockokma's Avatar
 
Join Date: Nov 2005
Location: San Diego
Posts: 646
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 20
Problem with LSI speakers

Hello, I used to use these speakers about 5-10 years ago. They were all working fine from what I remember. I had to take down my home theater, so I let my friend borrow them until I created a new theater one day. The day has come.

I really don't know much about the technical side of speakers.

I set them up just today. When doing a speaker calibration test tone on each speaker, I noticed the center (LSIC) sounded much different form the other speakers. I recorded my what I found out. Anyone know what is going on with this right woofer? With the test tone, the left woofer does not make any sound at all. I pulled out the left woofer, all connections seemed tight. I really don't know much about the technical side of speakers, so feel free to explain to me like I'm five

https://photos.app.*******/Vopah2dCxJerWVJv7

Both rears (LSIFX) also have only one woofer making noise when I run the test tone.

Both Floor standing speakers would make noise from both woofers on the test tone.

I'm thinking of just purchasing an LSIM704C, not sure if it will go well with my front LSI15 floor standing speakers.

Last edited by Rockokma; 05-15-2019 at 08:08 PM.
Rockokma is online now  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-15-2019, 08:10 PM
Advanced Member
 
Join Date: Oct 2018
Posts: 886
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 340 Post(s)
Liked: 276
Should work fine. Some here have mixed the 704C with other Polk lines and were happy.
cocrh is online now  
Sponsored Links
Advertisement
 
Reply Speakers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off