Owner's thread for the Anthem MRX 520 - Page 3 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 2Likes
Reply
 
Thread Tools
post #61 of 89 Old 04-13-2019, 09:58 AM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Im sitting on the fence about pulling the trigger on a 520 , is it worth the extra scratch over less expensive but with more features etc ? I dont see myself needing more than 5.1 even down the road.
My original budget was 1000ish inc tax ,im in Canada so im spending more to begin with. I like the quality and performance of anthem and like to buy Canadian when i can , so if i dont go with the 520 I would probably get a Yamaha as ive heard that there pretty reliable. Right now i have a 4.1 with studio 20 v3 for fronts and titan v3 for rears and will probably be upgrading spakers in the next year or so. Any input would be helpful thanks
kjonesversatech is offline  
Sponsored Links
Advertisement
 
post #62 of 89 Old 04-13-2019, 12:22 PM
Newbie
 
neulee's Avatar
 
Join Date: Apr 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
Quote:
Originally Posted by kjonesversatech View Post
Im sitting on the fence about pulling the trigger on a 520 , is it worth the extra scratch over less expensive but with more features etc ? I dont see myself needing more than 5.1 even down the road.
My original budget was 1000ish inc tax ,im in Canada so im spending more to begin with. I like the quality and performance of anthem and like to buy Canadian when i can , so if i dont go with the 520 I would probably get a Yamaha as ive heard that there pretty reliable. Right now i have a 4.1 with studio 20 v3 for fronts and titan v3 for rears and will probably be upgrading spakers in the next year or so. Any input would be helpful thanks
For me it came down to sound quality and ARC. The "extra" features like music streaming and more than 5 channels didn't matter to me at all. I previously was using an Integra receiver and a 5 channel setup, when I added a Paradigm sub with the Perfect Bass Kit bass EQ software it worked so well that I couldn't wait to replace the Integra with an Anthem and EQ the whole system with ARC!

If sound quality matters to you as much as it does to me, then the Anthem is the way to go.
neulee is offline  
post #63 of 89 Old 04-13-2019, 01:37 PM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Yup sound quality very important as well as reliability and product support, another reason is that i live 20 min from paradigm/anthem factory
kjonesversatech is offline  
Sponsored Links
Advertisement
 
post #64 of 89 Old 04-13-2019, 02:35 PM
Newbie
 
neulee's Avatar
 
Join Date: Apr 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
Quote:
Originally Posted by kjonesversatech View Post
Yup sound quality very important as well as reliability and product support, another reason is that i live 20 min from paradigm/anthem factory
I should have prefaced my post with the following questions.
Have you been able to hear a difference between audio components that you have used in the past and does it matter to you?
Some people either can't hear a difference or don't care enough about any difference that they hear to justify the cost of something like an Anthem product.


My Anthem purchase did make a positive change in what I hear and I like it! Another reason I went with the 520 is the pre-amp outputs which I have used to connect a Parasound amp for the left and right channels as a lot of my listening is 2 channel music.
neulee is offline  
post #65 of 89 Old 04-14-2019, 02:57 AM
AVS Forum Special Member
 
glangford's Avatar
 
Join Date: Dec 2008
Posts: 3,167
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 702 Post(s)
Liked: 617
Quote:
Originally Posted by kjonesversatech View Post
Im sitting on the fence about pulling the trigger on a 520 , is it worth the extra scratch over less expensive but with more features etc ? I dont see myself needing more than 5.1 even down the road.
My original budget was 1000ish inc tax ,im in Canada so im spending more to begin with. I like the quality and performance of anthem and like to buy Canadian when i can , so if i dont go with the 520 I would probably get a Yamaha as ive heard that there pretty reliable. Right now i have a 4.1 with studio 20 v3 for fronts and titan v3 for rears and will probably be upgrading spakers in the next year or so. Any input would be helpful thanks
I had a denon with all the bells and whistles. I bought the 520 and it was a vast improvement in sound quality. I never used the bells and whistles from the Denon. The 520 is a solid 5.1 AVR. No wi-fi, no streaming, not a bunch of extra channels to worry about, just good sound. If I want features and streaming, I use a blu ray player for that, Oppo-203.

Supercharged Song Towers, Oppo BDP-203, Anthem MRX-520, LG B6 OLED
Headphone Rig: Oppo BDP-95, Burson Audio Soloist MKII Headphone amp/ Sennheiser HD800S, Sennheiser HD650
glangford is offline  
post #66 of 89 Old 04-14-2019, 07:18 AM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Quote:
Originally Posted by glangford View Post
Quote:
Originally Posted by kjonesversatech View Post
Im sitting on the fence about pulling the trigger on a 520 , is it worth the extra scratch over less expensive but with more features etc ? I dont see myself needing more than 5.1 even down the road.
My original budget was 1000ish inc tax ,im in Canada so im spending more to begin with. I like the quality and performance of anthem and like to buy Canadian when i can , so if i dont go with the 520 I would probably get a Yamaha as ive heard that there pretty reliable. Right now i have a 4.1 with studio 20 v3 for fronts and titan v3 for rears and will probably be upgrading spakers in the next year or so. Any input would be helpful thanks
I had a denon with all the bells and whistles. I bought the 520 and it was a vast improvement in sound quality. I never used the bells and whistles from the Denon. The 520 is a solid 5.1 AVR. No wi-fi, no streaming, not a bunch of extra channels to worry about, just good sound. If I want features and streaming, I use a blu ray player for that, Oppo-203.
Ya im the same just want solid performance and reliability, my old yamaha rxv 640 has no issues just dated and i feel it never drove my studio 20's to there full potential. And your right there are alot of options for streaming ,its just a fair bit more than i was planning on spending .
kjonesversatech is offline  
post #67 of 89 Old 04-14-2019, 07:21 AM
AVS Forum Special Member
 
Jonas2's Avatar
 
Join Date: May 2015
Location: South Bay Area
Posts: 5,561
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 2788 Post(s)
Liked: 1752
Quote:
Originally Posted by kjonesversatech View Post
Im sitting on the fence about pulling the trigger on a 520 , is it worth the extra scratch over less expensive but with more features etc ? I dont see myself needing more than 5.1 even down the road.
My original budget was 1000ish inc tax ,im in Canada so im spending more to begin with. I like the quality and performance of anthem and like to buy Canadian when i can , so if i dont go with the 520 I would probably get a Yamaha as ive heard that there pretty reliable. Right now i have a 4.1 with studio 20 v3 for fronts and titan v3 for rears and will probably be upgrading spakers in the next year or so. Any input would be helpful thanks

Also, Anthem is getting ready to release ARC Genesis which will take ARC to another level and promises more flexibility than the current version. So, you'll have that to look forward to in the immediate future. Yamaha does a have a reputation for reliability, but if room EQ is important for you, YPAO is not at the level of ARC. I very much like Anthem as a company, they have great support (in Canada....but the MRX is built in Vietnam and not Canada FWIW...). It's definitely a no frills receiver, but it'll deliver for you.

7.2.4 System: Display: Sony XBR-65X930D; Processing: Anthem AVM60
Mains:
Paradigm Prestige 85F and 55C; Side / Rear Surrounds: Totem Acoustic Tribe III / Tribe I; Amplification: D-Sonic M3a-2800-7 (7ch. x 400w)
ATMOS:
Definitive Technology DI8R; Amplification: Class D Audio SDS-470C (4ch. x 300w)
Subwoofers:
2 x SVS-SB13Ultras; Media: Oppo UDP-203, Pioneer CLD-59
Jonas2 is offline  
post #68 of 89 Old 04-14-2019, 05:22 PM
Newbie
 
neulee's Avatar
 
Join Date: Apr 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
I use an OPPO 103 to pull music from my computer.
I have used a PS3 in the past before I got the OPPO.
neulee is offline  
post #69 of 89 Old 04-15-2019, 06:52 AM
AVS Forum Special Member
 
Join Date: Mar 2008
Posts: 2,994
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 94 Post(s)
Liked: 122
Quote:
Originally Posted by kjonesversatech View Post
Im sitting on the fence about pulling the trigger on a 520 , is it worth the extra scratch over less expensive but with more features etc ? I dont see myself needing more than 5.1 even down the road.
My original budget was 1000ish inc tax ,im in Canada so im spending more to begin with. I like the quality and performance of anthem and like to buy Canadian when i can , so if i dont go with the 520 I would probably get a Yamaha as ive heard that there pretty reliable. Right now i have a 4.1 with studio 20 v3 for fronts and titan v3 for rears and will probably be upgrading spakers in the next year or so. Any input would be helpful thanks

I had the 310 for many years and Anthem does make a quality unit and yes, ARC does work very well. However, with deals on the Denon 3400 which uses Audyssey XT32, it's hard to recommend the Anthem for twice the price as ARC and XT32 are comparable IMO.

Projector: LG PF1500W; Receiver: Sony STR-DN1080; Speakers: Monitor Audio Controlled Performance Inwalls and Inceilings; Subwoofer(s): SVS PC-2000; Bluray Player: Sony BDP-S6500; Remote: Roomie Remote; Cables: Monoprice
rnatalli is online now  
post #70 of 89 Old 04-17-2019, 04:17 PM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Quote:
Originally Posted by rnatalli View Post
Quote:
Originally Posted by kjonesversatech View Post
Im sitting on the fence about pulling the trigger on a 520 , is it worth the extra scratch over less expensive but with more features etc ? I dont see myself needing
more than 5.1 even down the road.
My original budget was 1000ish inc tax ,im in Canada so im spending more to begin with. I like the quality and performance of anthem and like to buy Canadian when i can , so if i dont go with the 520 I would probably get a Yamaha as ive heard that there pretty reliable. Right now i have a 4.1 with studio 20 v3 for fronts and titan v3 for rears and will probably be upgrading spakers in the next year or so. Any input would be helpful thanks

I had the 310 for many years and Anthem does make a quality unit and yes, ARC does work very well. However, with deals on the Denon 3400 which uses Audyssey XT32, it's hard to recommend the Anthem for twice the price as ARC and XT32 are comparable IMO.
Yup i know what you mean I've been living without room correction for 15 years so that part is not paramount in my decision for a new receiver, im just looking for a solid reliable unit with no headaches and i would definitively like to stay with my original budget of 1000$ canadian
kjonesversatech is offline  
post #71 of 89 Old 05-03-2019, 11:27 AM
Member
 
klmonline's Avatar
 
Join Date: Dec 2003
Location: Cary, NC USA
Posts: 22
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 14
Quote:
Originally Posted by Jonas2 View Post
Also, Anthem is getting ready to release ARC Genesis which will take ARC to another level and promises more flexibility than the current version. So, you'll have that to look forward to in the immediate future.
FYI to the group. I just tried to run the 1.0.0 beta version of ARC Genesis. It installed and started up and found my USB-connected microphone. But then it couldn't find my mike calibration file on disk and gave an error when attempting to download a new calibration file from the web. So it's a non-starter for me.

I filed a bug report, which is just an anonymous reporting form with no place to enter contact info for them to respond or ask for more information. I called tech support to ask if there was a way to find out about progress on newer beta versions and a bored tech said, "Nope. I guess you can just keep checking the website to see if the engineers release something new. If we knew about the problem, we would have fixed it already."

So you might have better luck than me, but I might suggest waiting a while for a more stable Genesis!

--Ken
klmonline is offline  
post #72 of 89 Old 05-04-2019, 07:40 AM
Member
 
Join Date: Apr 2018
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Liked: 8
I am trying to configure using the ARC genesis (Anthem MRX 520) for Monolith 10 subwoofer. I had set to THX position, 0 phase but i keep getting error "Your subwoofer volme is too high. Please turn its volume down by about -3db and try again". If i set it in THX according to the website, it should be 0db.

Anyone know what should be my setting for Monolith subwoofer to calibrate?
iliasmd is offline  
post #73 of 89 Old 05-26-2019, 05:42 AM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
I finally pulled the trigger and picked up a mrx 520 and ran a quick test run with arc genisis beta version ( reccomended by my dealer) , i was able to upload my first run succesfully to the reciever but was not able to save my measurements the save window popped up but when i clicked save nothing happened ? And even when i tried to close arc i could not save changes to arc when prompted not sure what the issue is.
My laptop is running windows 7 should I uninstall arc and try again? Im not too computer savvy so any help would be appreciated thanks
kjonesversatech is offline  
post #74 of 89 Old 05-26-2019, 07:04 AM
AVS Forum Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 2,216
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 110
Quote:
Originally Posted by iliasmd View Post
I am trying to configure using the ARC genesis (Anthem MRX 520) for Monolith 10 subwoofer. I had set to THX position, 0 phase but i keep getting error "Your subwoofer volme is too high. Please turn its volume down by about -3db and try again". If i set it in THX according to the website, it should be 0db.

Anyone know what should be my setting for Monolith subwoofer to calibrate?
I recommend not using the THX settings and let ARC make the necessary adjustments. This being said, turn down the subwoofer volume. I got the same message with my SVS sub when I ran Genesis for the first time.
audit13 is offline  
post #75 of 89 Old 05-26-2019, 07:05 AM
AVS Forum Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 2,216
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 110
Quote:
Originally Posted by kjonesversatech View Post
I finally pulled the trigger and picked up a mrx 520 and ran a quick test run with arc genisis beta version ( reccomended by my dealer) , i was able to upload my first run succesfully to the reciever but was not able to save my measurements the save window popped up but when i clicked save nothing happened ? And even when i tried to close arc i could not save changes to arc when prompted not sure what the issue is.
My laptop is running windows 7 should I uninstall arc and try again? Im not too computer savvy so any help would be appreciated thanks
Did you provide a name for the ARC file in the dialogue box?
audit13 is offline  
post #76 of 89 Old 05-26-2019, 12:56 PM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Quote:
Originally Posted by audit13 View Post
Quote:
Originally Posted by kjonesversatech View Post
I finally pulled the trigger and picked up a mrx 520 and ran a quick test run with arc genisis beta version ( reccomended by my dealer) , i was able to upload my first run succesfully to the reciever but was not able to save my measurements the save window popped up but when i clicked save nothing happened ? And even when i tried to close arc i could not save changes to arc when prompted not sure what the issue is.
My laptop is running windows 7 should I uninstall arc and try again? Im not too computer savvy so any help would be appreciated thanks
Did you provide a name for the ARC file in the dialogue box?
No i will have to run another test and try that. Another quick question i have is that with arc on i can see the adjusted levels in the level calibratin screen but when i toggle arc off the levels dont change on that screen but i can definatley hear a difference in the sound , im very confused
kjonesversatech is offline  
post #77 of 89 Old 05-26-2019, 01:00 PM
AVS Forum Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 2,216
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 110
Quote:
Originally Posted by kjonesversatech View Post
No i will have to run another test and try that. Another quick question i have is that with arc on i can see the adjusted levels in the level calibratin screen but when i toggle arc off the levels dont change on that screen but i can definatley hear a difference in the sound , im very confused
It makes sense to me that the screen would not change with ARC switched off as all settings world go back to their defaults. This screen is showing you how ARC has set up your system.
audit13 is offline  
post #78 of 89 Old 05-27-2019, 04:02 AM
Newbie
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Have oledc8pua and mrx 520 when setting up tv receiver choice there is no anthem vendor to select ...Denon, yahama etc yes. Can't get tv and receiver sound out from arc HDMI or the optical?

Is there another vendor perhaps similar to anthem I can choose?

Help is truly appreciated!
Michael Saikali is offline  
post #79 of 89 Old 05-27-2019, 06:30 AM
AVS Forum Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 2,216
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 110
Quote:
Originally Posted by Michael Saikali View Post
Have oledc8pua and mrx 520 when setting up tv receiver choice there is no anthem vendor to select ...Denon, yahama etc yes. Can't get tv and receiver sound out from arc HDMI or the optical?

Is there another vendor perhaps similar to anthem I can choose?

Help is truly appreciated!
Something does not seem right because I have ARC working on a LG c7 and 520.
audit13 is offline  
post #80 of 89 Old 05-28-2019, 01:39 PM
Member
 
Join Date: Apr 2018
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Liked: 8
Quote:
Originally Posted by audit13 View Post
I recommend not using the THX settings and let ARC make the necessary adjustments. This being said, turn down the subwoofer volume. I got the same message with my SVS sub when I ran Genesis for the first time.
Let me try and find out. The way i bypassed was that first time i removed the cable for subwoofer, ran with just one subwoofer (martin logan dynamo) and then after first placement, attached it and then it worked. It did not complain for the 2nd placement
iliasmd is offline  
post #81 of 89 Old 05-29-2019, 02:48 PM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
I have a strange one for you all, I have a brand new mrx 520 and it works great the only issue i have is with the hdmi passthrough when watching cable/pvr
As i scroll up throuh the channels and when i reach 23 (the weather channel) the sound drops out on the tv on all the channels it also does the same thing if i go directly to the channel. When i cycle the pvr/tv the sound comes back ,it drops out without fail on that channel any ideas?
kjonesversatech is offline  
post #82 of 89 Old 05-29-2019, 06:27 PM
AVS Forum Special Member
 
audit13's Avatar
 
Join Date: Sep 2007
Location: Toronto
Posts: 2,216
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 110
Quote:
Originally Posted by kjonesversatech View Post
I have a strange one for you all, I have a brand new mrx 520 and it works great the only issue i have is with the hdmi passthrough when watching cable/pvr
As i scroll up throuh the channels and when i reach 23 (the weather channel) the sound drops out on the tv on all the channels it also does the same thing if i go directly to the channel. When i cycle the pvr/tv the sound comes back ,it drops out without fail on that channel any ideas?
That is strange. It happens on all HDMI inputs? Receiver is running the latest firmware?
audit13 is offline  
post #83 of 89 Old 05-30-2019, 07:00 AM
AVS Forum Special Member
 
Legairre's Avatar
 
Join Date: Feb 2001
Posts: 6,643
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1167 Post(s)
Liked: 640
Quote:
Originally Posted by kjonesversatech View Post
I have a strange one for you all, I have a brand new mrx 520 and it works great the only issue i have is with the hdmi passthrough when watching cable/pvr
As i scroll up throuh the channels and when i reach 23 (the weather channel) the sound drops out on the tv on all the channels it also does the same thing if i go directly to the channel. When i cycle the pvr/tv the sound comes back ,it drops out without fail on that channel any ideas?
Is your cable box setup to always display a specific resolution? If it set to switch resolutions based on what the channel is broadcasting you'll have this problem. Some channels like CBS broadcast in 1080i, and some are still in 720p and others are 1080p. If the box has to switch the resolution for different channels then you get an audio drop out and a picture dropout. Make sure the box is set to broadcast everything in one resolution.

"What do you mean it's too loud? My ears aren't even bleeding yet!"
Dedicated ARC Genesis Thread
Legairre is online now  
post #84 of 89 Old 05-30-2019, 05:33 PM
Member
 
Join Date: Mar 2019
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 0
Quote:
Originally Posted by Legairre View Post
Quote:
Originally Posted by kjonesversatech View Post
I have a strange one for you all, I have a brand new mrx 520 and it works great the only issue i have is with the hdmi passthrough when watching cable/pvr
As i scroll up throuh the channels and when i reach 23 (the weather channel) the sound drops out on the tv on all the channels it also does the same thing if i go directly to the channel. When i cycle the pvr/tv the sound comes back ,it drops out without fail on that channel any ideas?
Is your cable box setup to always display a specific resolution? If it set to switch resolutions based on what the channel is broadcasting you'll have this problem. Some channels like CBS broadcast in 1080i, and some are still in 720p and others are 1080p. If the box has to switch the resolution for different channels then you get an audio drop out and a picture dropout. Make sure the box is set to broadcast everything in one resolution.
My pvr is set to one resolution only ,
And i havent tried any of the other inputs yet although i think i spoke to soon as saying it happens without fail because its not doing it anymore (so far anyway)
I did re check all my connections so will keep my fingers crossed
kjonesversatech is offline  
post #85 of 89 Old 06-19-2019, 07:28 AM
Member
 
Join Date: Apr 2018
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Liked: 8
I finally got my MCA 225 which I am trying to use with MRX 520. I used MCA 225 as my front and was trying to use Parasound A23 for my center/surround using the Pre-out. But when I ran the ARC genesis, it is not recognizing the center or surround sound when i hook them to the 2nd amplifier from the Pre-out. Do you know if there is any thing i need to do if i had to add 2nd amplifier?
iliasmd is offline  
post #86 of 89 Old 06-19-2019, 10:10 AM
Newbie
 
neulee's Avatar
 
Join Date: Apr 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 11
Quote:
Originally Posted by iliasmd View Post
I finally got my MCA 225 which I am trying to use with MRX 520. I used MCA 225 as my front and was trying to use Parasound A23 for my center/surround using the Pre-out. But when I ran the ARC genesis, it is not recognizing the center or surround sound when i hook them to the 2nd amplifier from the Pre-out. Do you know if there is any thing i need to do if i had to add 2nd amplifier?

Do you have a trigger wire connected between the 520 and the A23?
How can you run a center channel and 2 surround channels from the 2 channel A23?
neulee is offline  
post #87 of 89 Old 06-19-2019, 02:58 PM
Member
 
Join Date: Apr 2018
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 70 Post(s)
Liked: 8
Quote:
Originally Posted by neulee View Post
Do you have a trigger wire connected between the 520 and the A23?
How can you run a center channel and 2 surround channels from the 2 channel A23?
I did not run both. I tried doing center and then tried surround. Both did not work when i used 2 amplifiers. yes I did use the trigger wire between MRX 520 and A23. this was working before when i used for front.
iliasmd is offline  
post #88 of 89 Old 07-02-2019, 06:18 AM
Member
 
EnKoder's Avatar
 
Join Date: Dec 2006
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
I just brought home an MRX 520 and I need some ventilation tips.

I have a tv stand/media storage cabinet with component bays that are totally open in front and back, but closed on the sides
  1. does the 520 have a fan?
  2. the CAD drawing for the 520 is really for the 710, so don't know if the internal layout/cooling scheme is the same
  3. there are side ventilation cutouts near the front and near the back; if I can only provide ventilation to one of those cutouts on each side, which one should I use?
EnKoder is offline  
post #89 of 89 Old 07-02-2019, 07:24 AM
AVS Forum Special Member
 
Legairre's Avatar
 
Join Date: Feb 2001
Posts: 6,643
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1167 Post(s)
Liked: 640
Quote:
Originally Posted by EnKoder View Post
I just brought home an MRX 520 and I need some ventilation tips.

I have a tv stand/media storage cabinet with component bays that are totally open in front and back, but closed on the sides
  1. does the 520 have a fan?
  2. the CAD drawing for the 520 is really for the 710, so don't know if the internal layout/cooling scheme is the same
  3. there are side ventilation cutouts near the front and near the back; if I can only provide ventilation to one of those cutouts on each side, which one should I use?
The 520 doesn't have a fan, but if your cabinet is open in the front and back you will be fine.

"What do you mean it's too loud? My ears aren't even bleeding yet!"
Dedicated ARC Genesis Thread
Legairre is online now  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off