Onkyo 2016 A/V Receiver Line Owner's Thread: TX-SR353,TX-NR555, TX-NR656, TX-NR757 - Page 2 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 71Likes
Reply
 
Thread Tools
post #31 of 143 Old 12-09-2016, 01:22 PM
Senior Member
 
smdelaney's Avatar
 
Join Date: Apr 2016
Location: Greater Boston, MA
Posts: 443
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 267 Post(s)
Liked: 520
With 2016 all but said and done I'm wondering what folks are thinking about the Onkyo 2016 lineup?
I've been looking around to replace my aging /failing TX-SR803 and I'm on the fence about sticking with Onkyo. I have loved this receiver but reading all the HDMI issues leaves me with questions...especially with the display and surround sound having gone unreliable on my 803. For comparison purposes the Denon AVR-X3300w is at the high end of my budget and that seems to match up against the Onkyo RZ710...Any thoughts here on what people like/dislike/recommend? Any other receivers I should consider in the sub $999 range?
smdelaney is offline  
Sponsored Links
Advertisement
 
post #32 of 143 Old 12-20-2016, 02:49 PM
Member
 
Join Date: Dec 2016
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Onkyo TX-SR353 W/ Xbox One S No HDR Fix

Hi Everyone.

I'd like to present an issue I discovered with not being able to transmit HDR from a Xbox One S, through an Onkyo TX-SR353 and onto my Sony X800D Tv.

First What I did and what was happening: I had the XB1s plugged into the GAME HDMI port on the back of the receiver. Makes sense to me. I then enabled 4:4:4 for the Game port on the receiver. I then enabled Enhanced HDMI on the Sony. At that point, the XB detected the TV as being 4k & HDR compatible. All was good.

Second what was happening: Everything was fine, except I noticed that now I could not run the Netflix App on the XB. Everything else worked fine. All other games and apps just fine. It would start to load - then the TV would lose signal from HDMI 2.

Third what I tried: Uninstall and reinstall the Neflix app did not help. If on the Onkyo I changed the Game HDMI port to 4:2:2 it would load just fine. However then the tv would not be detected as HDR compatible any more. I tried new cables. no good. Running the XB directly to the tv would work just fine. But I love PCM compressed auto - so I really need the HDMI connection to the Onkyo.

I tried input HDMI 3 on the tv, same result.

I went through every Onkyo manual or info sheet I could find on this receiver and never did I find any information saying the HDMI ports are different in any way. In fact, The Onkyo manuals just say all the usual - that if there are any problems with 4:4:4 then it's your source or tv problem. They same plug any game machine into the GAME HDMI.

Finally. I gave up. While the receiver is fairly new - I had destroyed the box and couldn't return it. What a waste. It just wouldn't work. I decided I would have to use Netflix app built into the tv.

Fourth, then this happened: I wanted to try a HDR game so I downloaded Forza 3 demo. Once it was ready I launched it and.... The tv lost signal from the receiver. What? I ran the XB direct to the tv and no problem, the game comes up fine with HDR settings detected. On the Sony I opened the HDMI 2 settings and it now says HDR on the input. I try a test. With the XB direct to tv still i load the Youtube app. It also says it is running in HDR mode! (I hadn't noticed that before) So - it seems the Onkyo will not pass the HDR signal from the XB. This sucks.

Fifth I try one last thing, and it works!: On a whim, I unplugged the XB1 from the Onkyo GAME HDMI, and plugged it into the BD/DVD HDMI - I then set the BD/DVD also to 4:4:4 and Boom! It works! Now Netflix and Forza are going to the tv, through the receiver in HDR. Verified by the Sony HDMI display input info.

I rebooted the XB just to be sure and yep still works now.

So it seems that the GAME HDMI on the Onkyo TX-SR353 will not pass HDR from a XB1s, but the BD/DVD HDMI port will. Odd, since both inputs show up as HDR compatible when in XB display config.

Finally, I hope this helps someone: I couldn't find this information anywhere on the net, in fact, just posts from people saying to not purchase the Onkyo as they are unreliable passing through 4:4:4.

Hope if someone ever encounters this problem this helps!
McGilli is offline  
post #33 of 143 Old 12-20-2016, 08:51 PM
AVS Forum Special Member
 
kikkenit2's Avatar
 
Join Date: Nov 2006
Location: Redondo Beach
Posts: 3,297
Mentioned: 9 Post(s)
Tagged: 1 Thread(s)
Quoted: 823 Post(s)
Liked: 310
The spec sheet claims all 4 hdmi inputs are 2.2 although most low end
receivers only have a few 2.2 ports. What happens on the other 2 ports?
Maybe one is defective. Does that port work with 1080p?
kikkenit2 is offline  
Sponsored Links
Advertisement
 
post #34 of 143 Old 12-24-2016, 06:40 AM
Member
 
Nitrousbird's Avatar
 
Join Date: Feb 2007
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 12
I currently have a Denon 720W. Due to Amazon's liberal Christmas return policy, I still have a few more weeks before it has to go back. I already tried a cheap Sony (returned it quickly) and these two replaced my HK 2650 that bricked on a firmware update. I'm not loving the Denon due to:
- No on-screen overlay for the volume at 4k
- VERY dated GUI
- Hard to decipher what audio format it is processing

Questions:
- How is the Onkyo GUI? I don't care about the apps (will never use them), but does it look like something out of the 80's or something made in the last couple of years. My Denon's looks worse than my 2010 HK, which was a GUI designed a couple years before that.

- Does the on screen volume overlay work at 4K @ 60Hz? I run a lot @ 60Hz, so this is a factor

- Does the on screen overlay show more than just volume? My HK showed whatever audio format was being processed with the volume, which was great. My receiver is hidden away, so I can't just look at the front of it.

- Any HDMI issues that plagued previous models?
Nitrousbird is offline  
post #35 of 143 Old 12-29-2016, 02:34 PM
AVS Forum Special Member
 
lparsons21's Avatar
 
Join Date: May 2007
Posts: 1,455
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 161 Post(s)
Liked: 87
The GUI is a bit dated but works very well. And the volume overlay works just fine with 4K. But the full GUI only runs at 720p and doesn't overlay at all. I don't find that to be an issue worth worrying about as I'm almost never in the full GUI

I've had my 757 for a few months now and it hasn't burped once. I'm VERY pleased with it. I came from a HK AVR3600 to it.

Lloyd
lparsons21 is online now  
post #36 of 143 Old 12-30-2016, 01:57 AM
Member
 
Nitrousbird's Avatar
 
Join Date: Feb 2007
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 12
Quote:
Originally Posted by lparsons21 View Post
The GUI is a bit dated but works very well. And the volume overlay works just fine with 4K. But the full GUI only runs at 720p and doesn't overlay at all. I don't find that to be an issue worth worrying about as I'm almost never in the full GUI

I've had my 757 for a few months now and it hasn't burped once. I'm VERY pleased with it. I came from a HK AVR3600 to it.
Does the volume overlay show just volume or does it also show the source format like the HK's do?
Nitrousbird is offline  
post #37 of 143 Old 12-30-2016, 02:08 AM
AVS Forum Special Member
 
lparsons21's Avatar
 
Join Date: May 2007
Posts: 1,455
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 161 Post(s)
Liked: 87
The volume overlay just shows volume. But there is an 'info' overlay that shows source audio format, output audio format and video format.


Sent from my iPad using Tapatalk

Lloyd
lparsons21 is online now  
post #38 of 143 Old 12-30-2016, 09:26 AM
Member
 
Iggy SLO's Avatar
 
Join Date: Aug 2014
Location: Ljubljana, Slovenia
Posts: 68
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Liked: 26
@lparsons21 : What's the music like with your receiver? Or more precisely, how's the bass?

I know Onkyos usually performs splendidly for movies, but I've heard many complaints that the bass tends to be very weak with music. That's also been my experience with the TX-SR606 and I'd like to know how these newer models perform in this regard.
Iggy SLO is offline  
post #39 of 143 Old 12-30-2016, 09:52 AM
AVS Forum Special Member
 
lparsons21's Avatar
 
Join Date: May 2007
Posts: 1,455
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 161 Post(s)
Liked: 87
My setup is all about the TV and sound for it, and for that it is superb. The music in movies sounds wonderful if that's any help.

Lloyd
lparsons21 is online now  
post #40 of 143 Old 12-31-2016, 06:35 PM
Newbie
 
rmill2001's Avatar
 
Join Date: Jun 2008
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 12
Quote:
Originally Posted by smdelaney View Post
With 2016 all but said and done I'm wondering what folks are thinking about the Onkyo 2016 lineup?
I've been looking around to replace my aging /failing TX-SR803 and I'm on the fence about sticking with Onkyo. I have loved this receiver but reading all the HDMI issues leaves me with questions...especially with the display and surround sound having gone unreliable on my 803. For comparison purposes the Denon AVR-X3300w is at the high end of my budget and that seems to match up against the Onkyo RZ710...Any thoughts here on what people like/dislike/recommend? Any other receivers I should consider in the sub $999 range?


I have a Onkyo TX-SR876 ,about 6 years old, and I recall, even then ,on that owners thread, they were having some HDMI boards go bad, but never had any issues with mine , and love the sound. I just pulled the trigger on an NR757,looks like its supports all the new stuff including HDR.
I would have been an owner of the UN65KS8000 65-Inch this week, but it was delivered with a cracked screen, so have to wait 2 more weeks.
rmill2001 is offline  
post #41 of 143 Old 01-15-2017, 05:52 PM
Senior Member
 
bobkat007's Avatar
 
Join Date: Oct 2010
Posts: 473
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 414 Post(s)
Liked: 74
I have lost my return audio from tv over the ACR HDMI port on my Onkyo tx-sr353. I can get audio from the tv if it is streamed to the tv via wifi. Tried other hdmi cables, but all do the same. Any ideas?
bobkat007 is offline  
post #42 of 143 Old 02-11-2017, 09:24 AM
Member
 
tonyo123's Avatar
 
Join Date: Nov 2001
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Arc

I had some issues with HDNI ARC. It took everything being properly connected and the all the settings being turned on to have it work correctly. Initially, I also went through the cable swaps, etc...a little madening. But, usually not the cable. Now that I have it figured out all the cable work. But, the cabling has to be connected properly: ARC on TV HDMI port connected to ARC HDMI on receiver; HDMI into tv connection in receiver. The TV has to have its version of ARC turned on: I have a Panasonic TV and it works fine; also, I know, it works with Samsung. Lastly, I think the cable/satellite receiver, mine is FIOS, has to be also set to ARC. I am a little sketchy on this but I think the devices have to also have some setting for automatic switching of ARC and devices like Chromecast (there is a standard for this), as well as the auto on/off where all your devices turn on once they see one turn on (usually the tv). Called HDMI CEC. You should turn that on (again all the manufacturers call it something different).

I would disconnect everything but the receiver, cable/sat box, and the tv, and speakers, of course, go through the step by step set up and cabling for each device. Then turn on the tv and everything should turn on and switch to ARC channel. Also, test that you get the sound from the cable/sat AND the sound from the tv's smart apps...that's the key benefit as the sound always is outputted to the receiver by what is on the screen.

Last edited by tonyo123; 02-11-2017 at 09:57 AM. Reason: update
tonyo123 is offline  
post #43 of 143 Old 02-14-2017, 11:50 AM
Member
 
razee's Avatar
 
Join Date: Jan 2007
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 10
Going to receive my NR555 tomorrow. Upgrading from the sr505 after a friend said he was looking to buy a secondhand receiver. I was trying to buy a different brand this time but it came back down to Denon and Onkyo once again. Zone 2 is very important to me so the separate speaker terminals on the Onkyo swung it. I'm looking forward to getting my hands on it not that the decision is made.

I was oblivious to the Onkyo quality issues until I started researching this purchase. I hope my old unit will be ok with my friend. Can I ask, does heat contribute to the problem or do the old units just die when they die?
razee is offline  
post #44 of 143 Old 02-24-2017, 05:47 AM
Newbie
 
Join Date: Feb 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Hi, I just order a tx-nr757. My question is does the volume knob light up like on previous models. Thanks
Ryan Randall is offline  
post #45 of 143 Old 02-24-2017, 06:39 AM
AVS Forum Special Member
 
lparsons21's Avatar
 
Join Date: May 2007
Posts: 1,455
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 161 Post(s)
Liked: 87
Quote:
Originally Posted by Ryan Randall View Post
Hi, I just order a tx-nr757. My question is does the volume knob light up like on previous models. Thanks
No. Just checked.

Lloyd
lparsons21 is online now  
post #46 of 143 Old 02-25-2017, 04:12 AM
Member
 
Iggy SLO's Avatar
 
Join Date: Aug 2014
Location: Ljubljana, Slovenia
Posts: 68
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Liked: 26
Quote:
Originally Posted by razee View Post
I was oblivious to the Onkyo quality issues until I started researching this purchase. I hope my old unit will be ok with my friend. Can I ask, does heat contribute to the problem or do the old units just die when they die?
Heat can always be a problem, so all you can do is give the avr enough breathing space. Installing a fan is a last resort.
Iggy SLO is offline  
post #47 of 143 Old 03-12-2017, 01:26 PM
Newbie
 
Join Date: Nov 2015
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 1
FYI, have been eyeing the NR757 for awhile, and looks like it's on sale for $499 at Best Buy and majority of online retailers. Pretty good deal, think I'm going to pick one up.
aperfectburman is offline  
post #48 of 143 Old 04-04-2017, 08:20 AM
AVS Forum Special Member
 
jbug's Avatar
 
Join Date: Feb 2004
Location: Chicago
Posts: 4,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 136
I'm picking up a 757 from a Fedex holding location today (too many package thieves these days). Got it for $399.00 at Accessories4less and it's a factory refurb with the same warranty and comes in a new box with all accessories. I've had many Onkyo receivers over the years and I swore that I'd try Denon but couldn't pass up the deal. I'm coming from a 2015 646 model. I'll post my findings ASAP.

Edit: It came in a brown box from Onkyo with sticker on it saying "refurbished with 1 year warranty."

Last edited by jbug; 04-16-2017 at 07:44 AM.
jbug is offline  
post #49 of 143 Old 04-04-2017, 08:23 AM
AVS Forum Special Member
 
jbug's Avatar
 
Join Date: Feb 2004
Location: Chicago
Posts: 4,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 136
Time for someone to start a owners thread. Who got theirs first?
jbug is offline  
post #50 of 143 Old 04-07-2017, 09:52 AM
AVS Forum Special Member
 
DrPainMD's Avatar
 
Join Date: Nov 2004
Posts: 2,243
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 29
DrPainMD is offline  
post #51 of 143 Old 04-16-2017, 07:36 AM
AVS Forum Special Member
 
jbug's Avatar
 
Join Date: Feb 2004
Location: Chicago
Posts: 4,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 136
Quote:
Originally Posted by lparsons21 View Post
A little follow up. Had the 757 since 7/2016. Nary a glitch and the performance has been superb!


Sent from my iPad using Tapatalk
Going from a 646 to the 757 has been all good for me. No HDMI issues nor ARC problems (like I had with the 646). As far as features, the larger font on front panel makes it easier to see from a distance and I like the front panel display of which speakers are in play. I missed that from an Onkyo model I had some years back.
jbug is offline  
post #52 of 143 Old 04-19-2017, 08:50 AM
AVS Forum Special Member
 
bargervais's Avatar
 
Join Date: May 2010
Location: Tampa Bay Florida
Posts: 3,759
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 1755 Post(s)
Liked: 1091
Quote:
Originally Posted by jbug View Post
Going from a 646 to the 757 has been all good for me. No HDMI issues nor ARC problems (like I had with the 646). As far as features, the larger font on front panel makes it easier to see from a distance and I like the front panel display of which speakers are in play. I missed that from an Onkyo model I had some years back.
i came from the TX-NR747 to the TX-RZ710 i had zero issues with the 747 but i do like that the 710 has a detachable power plug, and the front panel has the display of which speakers are in play.

Living Room Sam. UN65KS8000 / 2017 Roku Ultra / Onkyo TX-RZ920 7.2.4 / M-5010 Amp. /Sam. UBD-M8500 Blu-Ray Player.
DEN TCL 65R617 65-Inch 4K Ultra / Onkyo TX-RZ730 5.2.4 / Philips 4K UHD Dolby Vision Player (P7502) BEDROOM Sam. 55JS8500 / 2016 Roku Ultra / LG UP870 3D Ultra High Definition Blu-Ray 4K Player
bargervais is offline  
post #53 of 143 Old 04-26-2017, 02:09 AM
Advanced Member
 
Bahn Yuki's Avatar
 
Join Date: Oct 2002
Location: Salem, Oregon
Posts: 585
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 283 Post(s)
Liked: 156
Send a message via AIM to Bahn Yuki Send a message via MSN to Bahn Yuki Send a message via Yahoo to Bahn Yuki
Recently got a 656. Any release notes on the firmware updates?

Sent from my SAMSUNG-SM-G870A using Tapatalk

JVC RS400,Optoma 27HDR, Denon X6300H, Klipsch RP-280F x 2, RP-450C, RB-51 II x 2, RS-42 II x 2, RB-41 II x 2, R-150M in 7.1.4, 150" Silver Ticket
LG 77C9, Denon X4300H, Klipsch RF-26 x 2, RC-52 II, Onkyo speakers in 5.1.4 setup
LG 55CX, Klipsch 2.1 Certified THX speakers
Sony 34XBR960 x 3, Apple Studio Monitor 21", Panasonic 50VT25
Bahn Yuki is offline  
post #54 of 143 Old 05-03-2017, 09:57 AM
Member
 
costersall's Avatar
 
Join Date: Jul 2008
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
I’m having a heck of a time getting my new Onkyo and Samsung KS8000 to work. I can get audio to work via having the ARC+CEC stuff turned on via ARC out on the receiver to HDMI3 on the Samsung One Connect box, but no video. I cant get video to work at all for anything via pass-through. I want to put all me devices into my AVR and then have it output video to the TV. This seems like it should be easy, but the One Connect box doesn’t want to play nice. I also seem to be having the issue described in the Q&A section of the RTING article on the subject with it stating the TV source “is already a speaker”

http://ca.rtings.com/tv/tests/inputs...io-passthrough

Both my items are brand new, didn’t think it would be so hard.

I also cant get the receivers menus to display on the TV, I don't even know if they can be displayed with the One connect box?
costersall is offline  
post #55 of 143 Old 05-03-2017, 10:20 AM
Advanced Member
 
Bahn Yuki's Avatar
 
Join Date: Oct 2002
Location: Salem, Oregon
Posts: 585
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 283 Post(s)
Liked: 156
Send a message via AIM to Bahn Yuki Send a message via MSN to Bahn Yuki Send a message via Yahoo to Bahn Yuki
I had issues with arc on my lg 65c7 and th onkyo 656. After doing a lot of troubleshooting I got rid of the onkyo and moved my DENON x4300. I sold that Onkyo for a loss. Good riddance.
I remember when Onkyo used to be a solid brand.

Sent from my SAMSUNG-SM-G870A using Tapatalk
schicksal likes this.

JVC RS400,Optoma 27HDR, Denon X6300H, Klipsch RP-280F x 2, RP-450C, RB-51 II x 2, RS-42 II x 2, RB-41 II x 2, R-150M in 7.1.4, 150" Silver Ticket
LG 77C9, Denon X4300H, Klipsch RF-26 x 2, RC-52 II, Onkyo speakers in 5.1.4 setup
LG 55CX, Klipsch 2.1 Certified THX speakers
Sony 34XBR960 x 3, Apple Studio Monitor 21", Panasonic 50VT25
Bahn Yuki is offline  
post #56 of 143 Old 05-03-2017, 10:35 AM
Member
 
costersall's Avatar
 
Join Date: Jul 2008
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by Bahn Yuki View Post
I had issues with arc on my lg 65c7 and th onkyo 656. After doing a lot of troubleshooting I got rid of the onkyo and moved my DENON x4300. I sold that Onkyo for a loss. Good riddance.
I remember when Onkyo used to be a solid brand.

Sent from my SAMSUNG-SM-G870A using Tapatalk
Ugh don't say that I just bought the thing the other day! I cant get any video input pushed to my TV. I was thinking it was the Samsung One-Connect box causing all the grief since I cant hook directly into the TV. I don't care about audio from the TV apps, I just want my video/audio to go via the AVR and show on the TV.
costersall is offline  
post #57 of 143 Old 05-03-2017, 10:42 AM
Advanced Member
 
Bahn Yuki's Avatar
 
Join Date: Oct 2002
Location: Salem, Oregon
Posts: 585
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 283 Post(s)
Liked: 156
Send a message via AIM to Bahn Yuki Send a message via MSN to Bahn Yuki Send a message via Yahoo to Bahn Yuki
Quote:
Originally Posted by costersall View Post
Ugh don't say that I just bought the thing the other day! I cant get any video input pushed to my TV. I was thinking it was the Samsung One-Connect box causing all the grief since I cant hook directly into the TV. I don't care about audio from the TV apps, I just want my video/audio to go via the AVR and show on the TV.
Try another receiver, see if you get the same issue. The 656 had video coming out, but audio over hdmi simply didn't work. Had no issues with my denon x4300 on the same set and it was a big upgrade for the living room.

Sent from my SAMSUNG-SM-G870A using Tapatalk

JVC RS400,Optoma 27HDR, Denon X6300H, Klipsch RP-280F x 2, RP-450C, RB-51 II x 2, RS-42 II x 2, RB-41 II x 2, R-150M in 7.1.4, 150" Silver Ticket
LG 77C9, Denon X4300H, Klipsch RF-26 x 2, RC-52 II, Onkyo speakers in 5.1.4 setup
LG 55CX, Klipsch 2.1 Certified THX speakers
Sony 34XBR960 x 3, Apple Studio Monitor 21", Panasonic 50VT25
Bahn Yuki is offline  
post #58 of 143 Old 05-03-2017, 03:15 PM
Newbie
 
hutcha4113's Avatar
 
Join Date: Apr 2013
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
I just updated from TX-NR717 -> to 757. Really like it so far. I think the setup screen is an improvement too, though it took me a while to get used to it.
hutcha4113 is offline  
post #59 of 143 Old 05-07-2017, 07:15 PM
AVS Forum Special Member
 
jbug's Avatar
 
Join Date: Feb 2004
Location: Chicago
Posts: 4,047
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 136
Quote:
Originally Posted by hutcha4113 View Post
I just updated from TX-NR717 -> to 757. Really like it so far. I think the setup screen is an improvement too, though it took me a while to get used to it.
My refurbished 757 just quit passing signals via HDMI. It's under warranty so I'll be calling them on Monday. I get video when I plug HDMI from my components straight into the TV and I get OTA TV signals and sound from the receiver.

Last edited by jbug; 05-07-2017 at 07:37 PM.
jbug is offline  
post #60 of 143 Old 05-08-2017, 12:28 PM
Advanced Member
 
the7mcs's Avatar
 
Join Date: Apr 2010
Posts: 788
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 550 Post(s)
Liked: 254
What is the most channels you can do with a txnr 757?
Is it just 5.1.2 or can it do a 5.1.4 or 7.1.4 configuration as well?
the7mcs is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Tags
TX-SR353 , TX-NR555

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off