Turntable phasing problems - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 8 Old 12-14-2018, 05:57 AM - Thread Starter
Senior Member
 
Join Date: Jun 2015
Posts: 442
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 332 Post(s)
Liked: 158
Turntable phasing problems

I believe I’m having major phasing issues somewhere in my turntable signal path. I have a Gemini PT-2000 MkII with Ortofon Red cart going into the phono preamp of a Denon X4400H.

I compared a few records with their Spotify counterparts and Spotify sounds normal and the vinyl is almost unlistenable. It’s like the midrange is being EQ’d our with phase cancellation. My turntable never sounded like this before but nothing has changed.

I checked wiring and tracking and anti-skate and all that and that didn’t fix it.

Could my preamp be the issue?

Legacy Audio Silhouette Pro L/C/R
DefTech ProCinema 1000 SL/SR
DefTech Supercube III
Denon AVR790
Oppo PM-3
GIK bass traps and absorption
sunPin is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 12-14-2018, 08:29 AM
AVS Forum Addicted Member
 
DonH50's Avatar
 
Join Date: Feb 2010
Location: Monument CO
Posts: 12,403
Mentioned: 69 Post(s)
Tagged: 0 Thread(s)
Quoted: 3303 Post(s)
Liked: 3403
it was working fine then quit? Maybe the cartridge went bad (internally, although is the tip of the stylus still OK?) The preamp could be the issue but it's a little unusual that only midrange is affected.

"After silence, that which best expresses the inexpressible, is music" - Aldous Huxley
DonH50 is offline  
post #3 of 8 Old 12-14-2018, 09:57 AM
AVS Forum Addicted Member
 
M Code's Avatar
 
Join Date: Mar 2003
Location: Cotati, CA
Posts: 11,930
Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 1127 Post(s)
Liked: 733
Over the last several years we have found some sources out-of phase..
Often this is difficult troubleshoot but since we have an oscilloscope in 1 of our vintage Marantz receivers it very obvious as the stereo scope pattern is flipped. The (2) instances were:
a. We were auditioning some NEW phono magnetic cartridge pre-production units 1 was out-of-phase
b. Listening to an FM station, noting it was out-of-phase. Called the station, talked to the engineer & he confirmed a processor was wired incorrectly

Also we have found with certain older vinyl recordings, an instrument or vocal track can be out of phase..
In the early days of analog recording doing multi-tracks and overdubbing using different magnetic tape recorders and mixers an added track could be out-of-phase.... Rare but very possible..

Just my $0.02...
M Code is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 12-14-2018, 03:53 PM - Thread Starter
Senior Member
 
Join Date: Jun 2015
Posts: 442
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 332 Post(s)
Liked: 158
Quote:
Originally Posted by DonH50 View Post
it was working fine then quit? Maybe the cartridge went bad (internally, although is the tip of the stylus still OK?) The preamp could be the issue but it's a little unusual that only midrange is affected.


Thanks for your response. Yes. The Ortofon is a brand new cartridge I got to see if the cartridge was the issues, but it has the same phasing issue as the previously installed Shure SC35c.

The issue probably effects all ranges, but I notice it most on vocals and piano and other instruments that I have a good auditory memory for how they’re supposed to sound.

Legacy Audio Silhouette Pro L/C/R
DefTech ProCinema 1000 SL/SR
DefTech Supercube III
Denon AVR790
Oppo PM-3
GIK bass traps and absorption
sunPin is offline  
post #5 of 8 Old 12-14-2018, 03:58 PM
AVS Forum Special Member
 
holl_ands's Avatar
 
Join Date: Jun 2004
Location: San Diego, CA
Posts: 6,197
Mentioned: 37 Post(s)
Tagged: 1 Thread(s)
Quoted: 958 Post(s)
Liked: 528
I would TRIPLE check the Cartridge and esp. Internal Turntable WIRING....
holl_ands is offline  
post #6 of 8 Old 12-14-2018, 05:22 PM
AVS Forum Addicted Member
 
M Code's Avatar
 
Join Date: Mar 2003
Location: Cotati, CA
Posts: 11,930
Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 1127 Post(s)
Liked: 733
The proper cartridge wire color codes are:
Left Signal + White
Left Signal - Blue
Right Signal + Red
Right Signal - Green

Double check your connections, if something doesn't sound right, reverse the + & - for 1 channel. Then do your comparison.

Just my $0.02...
M Code is offline  
post #7 of 8 Old 12-15-2018, 08:42 AM - Thread Starter
Senior Member
 
Join Date: Jun 2015
Posts: 442
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 332 Post(s)
Liked: 158
Thanks will check this today!

Legacy Audio Silhouette Pro L/C/R
DefTech ProCinema 1000 SL/SR
DefTech Supercube III
Denon AVR790
Oppo PM-3
GIK bass traps and absorption
sunPin is offline  
post #8 of 8 Old 12-31-2018, 06:14 PM - Thread Starter
Senior Member
 
Join Date: Jun 2015
Posts: 442
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 332 Post(s)
Liked: 158
Reporting back: the issue was caused entirely by cartridge misalignment. I downloaded a protractor from https://www.vinylengine.com/cartridg...tractors.shtml, aligned the cartridge, and now it sounds great once again! Thanks for the responses, all.

Legacy Audio Silhouette Pro L/C/R
DefTech ProCinema 1000 SL/SR
DefTech Supercube III
Denon AVR790
Oppo PM-3
GIK bass traps and absorption
sunPin is offline  
Sponsored Links
Advertisement
 
Reply Receivers, Amps, and Processors

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off