New Audio formats not supported by BluRay player? - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 01-28-2014, 01:23 PM - Thread Starter
Member
 
hansmatt's Avatar
 
Join Date: Jan 2006
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 10
I have a 4 year old lg390 BR player that has recently been unable to play some rentals...in particular the center channel audio is totally cut out and my Yamaha 667 receiver shows only LR channels (rather than the 5.1 it is setup for). All connections are hdmi, and the center works under different audio settings (descriptive audio, foreign languages etc) and using different inputs. I did both wifi and disc versions of firmware update for the BR player with no luck. Am I out of luck with the player not supporting new formats? Thoughts?
Matt

Samsung 55" LED 8000 Display; Tivo 2 HD;Yamaha 463 receiver;Emotiva XA-3 Amp;Triad Silver Monitors as LCR (inwall); Samsung BD390 player;Definitive Technologies inwall Surounds;Logitech 900 RT remote
hansmatt is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-28-2014, 01:48 PM
AVS Forum Special Member
 
Jack D Ripper's Avatar
 
Join Date: Jan 2014
Location: Burpelson Air Force Base
Posts: 1,445
Mentioned: 2 Post(s)
Tagged: 1 Thread(s)
Quoted: 168 Post(s)
Liked: 543

You should give more details, like what discs you have used and what audio format you selected on them, as well as about your settings in your BD player.

 

My first bit of advice is to make sure you have not selected something wrong in your BD player for the types of audio it will output.


God willing, we will prevail in peace and freedom from fear and in true health through the purity and essence of our natural fluids. God bless you all.
Jack D Ripper is offline  
post #3 of 5 Old 01-28-2014, 03:08 PM - Thread Starter
Member
 
hansmatt's Avatar
 
Join Date: Jan 2006
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 10
The discs I can note are recently the latest percy jackson, along with turbo...fortunately the kids were less bothered than me this time around.
My player is set to pcm-multi channel output, 5.1 audio.via hdmi..nothing has changed in my time of ownership for the receiver or BR player. The fact that other audio versions output to the center channel, but not the primary english track, and the setup works fine for other purchased (not burned) discs leads me to believe that either there is a new formatting that is being used that my player is not supporting, or bad disc copies...but two unrelated discs in a few weeks suggests to me the first.

Samsung 55" LED 8000 Display; Tivo 2 HD;Yamaha 463 receiver;Emotiva XA-3 Amp;Triad Silver Monitors as LCR (inwall); Samsung BD390 player;Definitive Technologies inwall Surounds;Logitech 900 RT remote
hansmatt is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 01-28-2014, 07:06 PM
AVS Forum Special Member
 
MarkHotchkiss's Avatar
 
Join Date: Mar 2007
Location: Long Beach, California
Posts: 1,471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 86
Hi Hansmatt,

I can't be of too much help, except to say that there hasn't been any new audio formats added to Blu-Ray discs.

It sounds to me like those two discs may be mastered with some stereo tracks. Many studios release rental-only versions of their movies, which are often dumbed-down.
MarkHotchkiss is offline  
post #5 of 5 Old 01-28-2014, 07:44 PM
AVS Forum Special Member
 
BIslander's Avatar
 
Join Date: Jul 2005
Posts: 8,929
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 247 Post(s)
Liked: 191
Try setting the player to bitstream so that the receiver does the decoding. See if there's any difference in the output.
BIslander is offline  
Sponsored Links
Advertisement
 
Reply Audio Theory, Setup, and Chat

Tags
Yamaha Rx V667 Receiver

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off