Nevo C2 stuck in Upgrade Mode - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 6 Old 09-09-2015, 01:24 PM - Thread Starter
 
htpcforever's Avatar
 
Join Date: Jul 2014
Posts: 919
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 493 Post(s)
Liked: 193
Nevo C2 stuck in Upgrade Mode

I followed the procedures listed here:


http://www.hifi-remote.com/forums/vi...?p=27215#27215


Quote:
10) For the Xsight Color and Xsight Touch:
Quote:

- Home, Settings, Reset. Press Reset again or enter 981 then Reset for a full reset
- If the remote is unresponsive, it may be stuck in firmware upgrade mode. To recover from that on the Xsight Color, press the Power, 1 and 3 buttons while putting the battery back in. On the Xsight Touch, press Power and OK while putting the battery back in. Then re-connected to PC and continue with the firmware upgrade





But neither of the two methods work.


When I try to connect via the EXRC website to do the update, I get a Call Failed error. I initially had the USB Drop Out issue, so I added the reg key (it is in a different location than what the .reg file shows, but not too much off), but in the meantime the website had placed it in Upgrade Mode and now I am stuck...
htpcforever is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 11-18-2015, 10:07 PM
Member
 
ianeicher's Avatar
 
Join Date: May 2002
Posts: 153
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Did you ever get this to work? I just got a C2 and the same thing happened to me (windows 10).
ianeicher is offline  
post #3 of 6 Old 11-19-2015, 06:41 AM
AVS Forum Addicted Member
 
mdavej's Avatar
 
Join Date: Sep 2006
Posts: 15,047
Mentioned: 62 Post(s)
Tagged: 0 Thread(s)
Quoted: 3306 Post(s)
Liked: 1530
In Windows 8/8.1/10, you have to do the reg fix twice when you first connect a new remote running an older firmware. The first firmware upgrade phase in EZ-RC changes the remote name, creating a new registry entry. Because of that, the remote will no longer stay connected, hence gets stuck in upgrade mode. To fix this, go to that new registry entry and do the fix again. Disconnect/reconnect, then go back to ez-rc and click through to connect and upgrade again. This time the upgrade should finish and the remote goes back to normal.

Here's the registry fix:

Go to the key, [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\U SB\VID_06E7&PID_80xx\XSIGHT.\Device Parameters] and change EnhancedPowerManagementEnabled to 0. Change takes effect next time remote is plugged in.

Different Xsight models have different PID's (xx is different). So this key should get you close no matter what model since the VID is the same for all Xsight and Nevo models.

When you first plug in a remote with an older firmware, the key is "XSIGHT.". After the first upgrade attempt, a new key "Xsight" is created. You must make the above change to the new key and retry the upgrade (disconnect/reconnect, click Connect in EZ-RC and click Upgrade again).

Additionally, in Win 10, the Edge browser is not compatible with the EZ-RC website (account creation and connection will fail). So right click and open in IE mode. Other browsers (Chrome, Firefox, Safari, etc.) wont' work either.

Last edited by mdavej; 11-19-2015 at 06:50 AM.
mdavej is online now  
Sponsored Links
Advertisement
 
post #4 of 6 Old 11-19-2015, 08:33 AM
Member
 
ianeicher's Avatar
 
Join Date: May 2002
Posts: 153
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Thanks. The link in your signature actual does a good job explaining with the exception of the 2nd loop of changing reg keys. That should probably be updated. Anyway, I'm still stuck in upgrade loop. I've tried the reset tricks and neither work. Any other ideas?
ianeicher is offline  
post #5 of 6 Old 11-20-2015, 07:50 AM
Member
 
ianeicher's Avatar
 
Join Date: May 2002
Posts: 153
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by ianeicher View Post
Thanks. The link in your signature actual does a good job explaining with the exception of the 2nd loop of changing reg keys. That should probably be updated. Anyway, I'm still stuck in upgrade loop. I've tried the reset tricks and neither work. Any other ideas?
Ok, per @mdavej 's suggestion, I tried plugging in to a Windows 7 computer and the the EZRC software was able to get the remote off of upgrade mode. I seem to be back in business now. I guess the moral is to stay away from Win8/10 wit this remote.
ianeicher is offline  
post #6 of 6 Old 11-20-2015, 07:58 AM
AVS Forum Addicted Member
 
mdavej's Avatar
 
Join Date: Sep 2006
Posts: 15,047
Mentioned: 62 Post(s)
Tagged: 0 Thread(s)
Quoted: 3306 Post(s)
Liked: 1530
Glad you got it going.

Firmware upgrade in Win 10 is indeed fraught with danger and does not ever go smoothly. So doing that part in Win 7 if you can is definitely the safest approach. But once you get past the upgrade, Win 8/10 should work fine if all the registry changes are correct.

Xsight support says you can't use Win 8/10 at all, so we're lucky to have any workaround at all.
mdavej is online now  
Sponsored Links
Advertisement
 
Reply Remote Control Area

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off