AVS Forum | Home Theater Discussions And Reviews - View Profile: lbrande

lbrande lbrande is offline

Member

  Statistics

Total Posts
General Information
  • Last Activity: 06-26-2020 11:17 AM
  • Join Date: 08-25-2011
  • Referrals: 0

  Reviews

lbrande's Recent Reviews
This does not have any entries.

  Mentions

03-01-2020
11:03 AM - eriksells916 mentioned lbrande in post New Processor
lbrande I own nothing high e...

  Thread Tags

No results to display...

  Quotes

06-17-2020
11:46 AM - lbrande quoted Alan P in post 2011 Mitsubishi 3D DLP Owners Thread (740/840 series)
https://youtu.be/Gz1SatVZ-z...
10:22 AM - Alan P quoted lbrande in post 2011 Mitsubishi 3D DLP Owners Thread (740/840 series)
Well, as I posted earlier, m...
03-10-2020
11:03 AM - mmiles quoted lbrande in post New Processor
Where can you get the MC10 f...
05:02 AM - MUDCAT45 quoted lbrande in post New Processor
Thank you all for your input...
03-04-2020
05:04 AM - lbrande quoted MUDCAT45 in post New Processor
Lexicon MC10. Can probably ge...
03-01-2020
08:54 AM - lbrande quoted mlknez in post New Processor
What are your source device...
12-03-2019
01:49 AM - glangford quoted lbrande in post Official OPPO BDP-95 Owner's Thread
This is an FYI. My BDP-95 st...
10-09-2018
11:55 PM - Augerhandle quoted lbrande in post 2011 Mitsubishi 3D DLP Owners Thread (740/840 series)
... I just replaced the lamp...
12-01-2017
11:05 AM - lbrande quoted AVGeek_00 in post Official Classe SSP-800 thread.
Classe came under new ownershi...
10:11 AM - lbrande quoted AVGeek_00 in post Official Classe SSP-800 thread.
Ooops! I meant Sigma gear, not...