AVS Forum banner
sony str de697 audio video receiver
1-5 of 5 Results
  1. Receivers, Amps, and Processors
    I'm trying to find out if the sub input is faulty on a Sony STR-DE697. Hooked the sub up (PSW10), but it doesn't play. Followed the guidelines here: https://us.en.kb.sony.com/app/answers/detail/a_id/39055/c/65,66/p/41901,43145,43976/ Any ideas?
  2. Receivers, Amps, and Processors
    Gday! I own a Onkyo TX-904. I have hooked-up 2 Jamo D265 (265w, long term 150w impedance 4-8 Ohms) to this Onkyo. I have also 2 Wharfedale Programme 2180 (100 watts, long term 60w impendance 8 Ohms), but i have them unconnected. Ive attached a jpg howto connect them alternatively. It gets...
  3. Receivers, Amps, and Processors
    On the receiver sometimes I get sound from the front left and center channels and sometimes I don't.. Usually when I turn it on I get no sound from those 2 speakers then the left eventually turns on and most the time the center will too but sometimes it won't. I've read it may be a broken...
  4. Home Theater In A Box
    Basically, I'm doing my basement, and I've reserved about $2100 for the home theater section. First, I need a projector. I'm probably going to get the Epson PowerLite Home Cinema 8350. Maybe the Optoma HD33 if I really want 3D. Next, I'm getting a cheap fixed frame screen. Probably a 100 inch...
  5. Receivers, Amps, and Processors
    Hi there, I just picked up an old Sony str-de697 and I'm having an odd problem. The right channel, left surround channel, and left back surround channel are all noticeably softer than all the other channels. All I really care about are the main left and right channels, though. I've set the...
1-5 of 5 Results
Top