AVS Forum banner

6021 - 6040 of 7415 Posts

·
Registered
Joined
·
8 Posts
Manage to fix it by side loading the app. Everything is back to the way I had it 🙂
I will be also installing the Asia Pacific version, for the Australian one it showing as version V6.4762... is that the one you installed? lastly, did you notice any improvements in the picture quality and blooming?

Thank you.
 

·
Registered
Joined
·
172 Posts
So it sounds like it’s worth pursuing then, but it does appear to be troublesome for those that successfully got ARC to work. Has anybody been successful utilizing ARC and keeping Bluetooth turned on? If so what steps were taken?
I have had very few problems with audio. I have an AppleTV 4K, and an Xbox One X plugged into the tv, then the tv plugged into an Onkyo 646. There have been a few occasions where the sound has randomly cut off, but so far simply turning off the tv and receiver and back on again has fixed it each time. I also have my remote paired via Bluetooth, but no other devices paired by Bluetooth. Not for any reason other than I just haven’t tried it.

I’m also on the H firmware, and did a factory reset after updating.
 

·
Registered
Joined
·
9 Posts
I will be also installing the Asia Pacific version, for the Australian one it showing as version V6.4762... is that the one you installed? lastly, did you notice any improvements in the picture quality and blooming?

Thank you.
Yep, that's the version I installed.

Picture Quality is like what everyone else has mentioned that has done the switch. Motion Handling is much better. I used to not use 'Smoothness' because the SOE was too strong. But now I can have it on 2 without the turning on Clearness and it looks great. Also, light blooming has improved, it's still there but no where near as bad as it was, less obvious in the letter boxing.
 

·
Registered
Joined
·
20 Posts
Our first 950G had a nasty yellow color shift in the green along with continuous lock ups with the Youtube apps. That set was replaced. The replacement arrived and seemed to work BUT believe it had Android 8. When an update finished, the Youtube app problems returned. Sony was of no help as they fixated on the internet even when it was obvious the internet was fine. The local dealer we purchased the TV from at that point walked away and said it was a Sony warranty item. I did manage to find a Best Buy forum post from people who had the same problem. That forum was quickly locked by the moderators.

Is difficult to determine how common this problem is since many do not use the internal apps. That said, it may have been limited to a certain batch of TVs, etc. and is not widespread. Sometimes I do draw bad lottery tickets! The latest firmware does appear to be helping, or something I did in the settings has helped. I have not had a lockup in several days now.

I would assume if the problems I had were widespread they would be posted all over the boards. They certainly were annoying and Sony really was of no help other than to blame the internet. Our 900F and A8G TVs have never had this issue. All bought at same time.

I have had the same issue with the YouTube app on the x950G. I have to restart the TV. One reason my next TV won't be a Sony.
 

·
Vendor
Joined
·
27,516 Posts
And for this reason I do not install the software from the USA on the European version. Because it may turn out that, for example, the myCanal + application for Europe will not work.
There could be issues down the road, you are right. You never know....
 

·
Registered
Joined
·
397 Posts
For anyone interested Encompass (Sonys part site) just contacted me to tell me the Rmf-tx611u Backlit metal remote is available to order. Its a bit expensive at $107.53 but if you register a new account after registering there should be a 15% discount code. So I got it for $91.76 plus shipping. It says Ill get it by 6-8-20. This is the same one that comes with the Sony Z8H 8K set. From what I can tell it also has all the same buttons but a couple might be in a different location. Like the apps button is now above the settings button, and where the apps button is on the TX600 is an exit button based on the pics from the Z8H site.

Heres a link to the remote. https://encompass.com/item/12571036/Sony/1-005-041-11/
 

Attachments

  • Like
Reactions: jlo8720 and galonzo

·
Registered
Joined
·
196 Posts
For those still having issues with the internal apps I have zero issues. More than likely that’s a issue with your area or tv. All my on board apps work perfectly after the H update.
Our 950G would not work this morning with YouTube TV. Same as before. Acts like there is no network connection, youtube TV circle just swirls until it times out. Other apps work fine when this happens. Network is fine. Just the Internal Google apps. Switch over to Roku and the Youtube apps are working fine.

Power restart and then all is again working with the internal youtube apps.

I may see if Sony's phone help is back online again but not sure I have the ability to withstand their "attack of the internet" again. Given we spent $3800 on this TV in January 2020 it most likely will be something we have to live with for quite some time. Sony thus far has not been of any help other than having me continuously check the internet connections and then blaming the internet regardless.

Had I bought this TV from either bestBuy or Costco, etc. it would have been returned. We bought from a smaller local retailer because we try hard to support small local businesses where possible. In this case that cost us since the small business walked away and said it was a Sony warranty issue.

I am old enough to know every brand turns out lemons and you often only know what is bad about your item versus the competition. But based on this experience the odds of me buying another Sony TV in the future are slimmer. And the odds of me revisiting our smaller local store is not going to happen.

There does not appear to be a fix for this problem. Our 900F and A8G TVs.. 0 issues. Just something about the 950G.
 

·
Registered
Joined
·
96 Posts
Our 950G would not work this morning with YouTube TV. Same as before. Acts like there is no network connection, youtube TV circle just swirls until it times out. Other apps work fine when this happens. Network is fine. Just the Internal Google apps. Switch over to Roku and the Youtube apps are working fine.

Power restart and then all is again working with the internal youtube apps.

I may see if Sony's phone help is back online again but not sure I have the ability to withstand their "attack of the internet" again. Given we spent $3800 on this TV in January 2020 it most likely will be something we have to live with for quite some time. Sony thus far has not been of any help other than having me continuously check the internet connections and then blaming the internet regardless.

Had I bought this TV from either bestBuy or Costco, etc. it would have been returned. We bought from a smaller local retailer because we try hard to support small local businesses where possible. In this case that cost us since the small business walked away and said it was a Sony warranty issue.

I am old enough to know every brand turns out lemons and you often only know what is bad about your item versus the competition. But based on this experience the odds of me buying another Sony TV in the future are slimmer. And the odds of me revisiting our smaller local store is not going to happen.

There does not appear to be a fix for this problem. Our 900F and A8G TVs.. 0 issues. Just something about the 950G.
To clarify - you are still using the v6.3626 X950G firmware, correct?
 

·
Registered
Joined
·
196 Posts
To clarify - you are still using the v6.3626 X950G firmware, correct?
That is correct. Not sure I want to go with the H firmware in event I start the "call Sony for internet check help". If I go with the H firmware and the problem persists I am certain Sony will fixate on that as the cause.
 

·
Registered
Joined
·
4 Posts
That is correct. Not sure I want to go with the H firmware in event I start the "call Sony for internet check help". If I go with the H firmware and the problem persists I am certain Sony will fixate on that as the cause.

I'm on the H firmware and Youtube freezes up a couple times a week. Personally, I wouldn't return the TV because of it. Restarting the TV is pretty simple thru the settings menu. It's not like it completely freezes up and you have to get up and unplug it. Just my 2 cents
 

·
Registered
Joined
·
196 Posts
I'm on the H firmware and Youtube freezes up a couple times a week. Personally, I wouldn't return the TV because of it. Restarting the TV is pretty simple thru the settings menu. It's not like it completely freezes up and you have to get up and unplug it. Just my 2 cents
Thanks for sharing the H firmware information. Will most definitely not update the firmware just yet.

I cannot return the TV so am stuck with it and from what I have been through thus far Sony will do nothing to help. Sony's response has made things worse.

I do understand power restarts (just hold the green button down for a few seconds on remote.. faster than using the menu) are a fairly simple workaround. Or using a Roku stick, etc.

But we paid nearly $4000 for a "Smart TV" that is not always so smart. If Sony would have taken an interest, or sent a technician to troubleshoot, or just sent a sympathy card I might feel differently. But after hours on the phone with Sony getting stuck on checking the internet as their only non solution and realizing we'll need to accept an expensive but defective television, I am not aligned with just accepting it, though it appears I have little choice actually.

Thanks for letting me know your 950G is freezing with the H firmware.
 

·
Registered
Joined
·
337 Posts
Our 950G would not work this morning with YouTube TV. Same as before. Acts like there is no network connection, youtube TV circle just swirls until it times out. Other apps work fine when this happens. Network is fine. Just the Internal Google apps. Switch over to Roku and the Youtube apps are working fine.



Power restart and then all is again working with the internal youtube apps.



I may see if Sony's phone help is back online again but not sure I have the ability to withstand their "attack of the internet" again. Given we spent $3800 on this TV in January 2020 it most likely will be something we have to live with for quite some time. Sony thus far has not been of any help other than having me continuously check the internet connections and then blaming the internet regardless.



Had I bought this TV from either bestBuy or Costco, etc. it would have been returned. We bought from a smaller local retailer because we try hard to support small local businesses where possible. In this case that cost us since the small business walked away and said it was a Sony warranty issue.



I am old enough to know every brand turns out lemons and you often only know what is bad about your item versus the competition. But based on this experience the odds of me buying another Sony TV in the future are slimmer. And the odds of me revisiting our smaller local store is not going to happen.



There does not appear to be a fix for this problem. Our 900F and A8G TVs.. 0 issues. Just something about the 950G.
Strange. My YouTube will occasional be disconnected after the tv has sat for a while but once I exit out to home screen and go back in it usually loads up.

Sent from my Pixel 2 XL using Tapatalk
 

·
Registered
Joined
·
96 Posts

·
Registered
Joined
·
106 Posts
That's really weird, I haven't seen a single issue with in-built youtube on my x950g from android 8 to the latest android 9 update and i'm using it daily...But I did a factory reset after updating to Android 9 that's true...Also I'm using a wired connection and a static ip for the set, no dhcp.
 

·
Registered
Joined
·
196 Posts
That's really weird, I haven't seen a single issue with in-built youtube on my x950g from android 8 to the latest android 9 update and i'm using it daily...But I did a factory reset after updating to Android 9 that's true...Also I'm using a wired connection and a static ip for the set, no dhcp.
Static IP is the only thing I haven't tried. After 3 factory resets I told Sony no more. I have run via Ethernet connection rather than wireless, no help. App cache has been cleared more times than I can count. Every time I contacted Sony they started at ground zero, even though they had the case number and the information from previous calls. Apps have been uninstalled and reinstalled.

Our A8G and 900F have had zero issues and both are running wireless, and both are further away from the main router.

I *may* try Sony 1 more time and will try to steer them away from repeating what has been repeated multiple times before. The lockups do seem less frequent now so not sure what can be done to troubleshoot unless the TV is in a locked state. I have called Sony with the TV in such a state but their Level 2 support seemed just as programmed as their Level 1 support.

The Best Buy forum did have others experiencing the same thing I am. If I knew why some have zero issues with their 950G while we are the opposite then we'd probably know the cause. It does seem isolated to the youtube apps. When youtube TV is stuck I can go to Netflix and not a problem. We are averaging about 145 mbps at the Tv when connected wireless.

It may just be time to use the Roku stick and walk away from this though. The Roku apps have never had an issue. But it does defeat what I originally wanted. a Smart Tv and not having to use a Roku, etc.
 

·
Registered
Joined
·
239 Posts
Quite frankly, I don't think that bad customer service is specifically Sony's problem. I use appliances made by different brands and use multiple services where from time to time I need to contact customer service. At the lowest level of support they are all bad, but this is on purpose - they are designed to help people with trivial mundane issues that can be solved much faster by reading the user manual, which apparently is the dominant percentage of calls. Some companies even use software to reply to emails in which case they are just providing standard advice based on keywords and not on the specific case. Sometimes I begin by saying that I have called before, standard solutions do not work, I need to elevate that to someone who can figure it out. And they still go through the standard hoops because otherwise they are not allowed to elevate. This is not to justify Sony's bad customer service, but just don't expect other companies to be better in this respect. The only company that has great customer service is Amazon, but that's because they have a simple solution for all troubles - replace the item. TV manufacturers don't do that just because you complain about something.
 

·
Registered
Joined
·
3,731 Posts
I'm on the H firmware and Youtube freezes up a couple times a week. Personally, I wouldn't return the TV because of it. Restarting the TV is pretty simple thru the settings menu. It's not like it completely freezes up and you have to get up and unplug it. Just my 2 cents
Just an FYI, if you press and hold the power button the TV will reboot. No need to go through the menu system...save yourself a bunch of button presses. ;)

Edit: I see jdavis already mentioned this. :)
 

·
Registered
Joined
·
196 Posts
Quite frankly, I don't think that bad customer service is specifically Sony's problem. I use appliances made by different brands and use multiple services where from time to time I need to contact customer service. At the lowest level of support they are all bad, but this is on purpose - they are designed to help people with trivial mundane issues that can be solved much faster by reading the user manual, which apparently is the dominant percentage of calls. Some companies even use software to reply to emails in which case they are just providing standard advice based on keywords and not on the specific case. Sometimes I begin by saying that I have called before, standard solutions do not work, I need to elevate that to someone who can figure it out. And they still go through the standard hoops because otherwise they are not allowed to elevate. This is not to justify Sony's bad customer service, but just don't expect other companies to be better in this respect. The only company that has great customer service is Amazon, but that's because they have a simple solution for all troubles - replace the item. TV manufacturers don't do that just because you complain about something.
There's plenty of "poor" service out there, sometimes the price we pay for cheaper prices. On flip side I own equipment for which I have gotten truly wonderful customer support with. I don't often call for help so am not a frequent user of phone/email support.

Once you have established a case number within Sony they should make use of it. My experience was they didn't even though when asked about it the information was there for them. It appeared to be a system designed to frustrate and discourage, which it succeeded in doing. Now, I am reticent to call again, believing they will put me through the same hoop jumping. But as a result they most likely have lost me as a future customer. But then given we just purchased 3 TVs in January I most likely won't be a customer again for 10 years anyway.

Anyhow, I have experienced different levels of help. The companies who have given us excellent support have earned repeat business when that time comes. The local small business who sold us the TVs and then walked away when the Tv *could* have been returned won't get any future business from us or word of mouth referrals. And Sony? Unless something changes most likely in 10 or so years when this big semi Smart TV needs to be replaced it won't be Sony. Of course whatever we go with at that time could always be worse. I'm not overly perturbed. The TV works with exception of reliability for the YouTube apps. But I do think for $3800 the apps should work and Sony could have done more to help.
 

·
Registered
Joined
·
196 Posts
Just an FYI, if you press and hold the power button the TV will reboot. No need to go through the menu system...save yourself a bunch of button presses. ;)

Edit: I see jdavis already mentioned this. :)
Your info wasn't buried :) Is good to share it especially for those who do need to power restart frequently!
 
6021 - 6040 of 7415 Posts
Top