AVS Forum banner

3561 - 3580 of 4964 Posts

·
Registered
Joined
·
158 Posts
In the past couple weeks the costco near me went from having 20 in stock to 65. Hopefully some of those were manufactured without the issue. I'll see tonight if I was lucky enough to receive a fully functioning set.
 

·
Registered
Joined
·
674 Posts
Just received my 55" H9G from Bestbuy. It exhibits the red ghosting on the Crown scene. The manufacturer date on my set is September 12 Mexico. Not a good sign.
Actually, that's no sign at all...check some of the other examples, Alita for one. If the Crown is the only time you have it...don't worry. If you have it on the other examples we know newer sets have the same problem. It's looking like what should have been the set of the year might turn into the lemon of the year.
 

·
Registered
Joined
·
582 Posts
Actually, that's no sign at all...check some of the other examples, Alita for one. If the Crown is the only time you have it...don't worry. If you have it on the other examples we know newer sets have the same problem. It's looking like what should have been the set of the year might turn into the lemon of the year.
No offense but thats not really good advice to a new owner. Why would you say its "no sign at all" if it exhibits red ghosting on the Crown ? Of course its a sign the TV has red ghosting. If it's on the Crown, it will be on other scenes too.
How severe though is the question. Still sounds to me like every H9G has the red ghosting issue to some degree.
 

·
Registered
Joined
·
136 Posts
Well this set unfortunately has it as well, I've spoken with costco support, they'll be doing one more exchange for me. They said if this coming set has the issue as well, they will most likely delist the item while they contact the manufacturer regarding the issue.
Sorry to hear you got the issue that seems like it's present on every panel. Good to hear that Costco will be contacting Hisense. Maybe now they will fix the panels. Amazon and BB should do the same... now that would be 'pressure' to something to get it right!

Just received my 55" H9G from Bestbuy. It exhibits the red ghosting on the Crown scene. The manufacturer date on my set is September 12 Mexico. Not a good sign.
Damn, that's only about a month ago.

...It's looking like what should have been the set of the year might turn into the lemon of the year.
Yep!

Robert
 

·
Registered
Joined
·
674 Posts
No offense but thats not really good advice to a new owner. Why would you say its "no sign at all" if it exhibits red ghosting on the Crown ? Of course its a sign the TV has red ghosting. If it's on the Crown, it will be on other scenes too.
How severe though is the question. Still sounds to me like every H9G has the red ghosting issue to some degree.
Here we go again....ask Merubin that question, not me
His set had the blur on the Crown...and nothing else.
I've never had the blur and have tested every example except the Crown.
So...not all panels are bad. And before we get the usual cries for proof...Ohwell posted a few pages ago some pictures proving that Jumanji didn't have a problem for him as it did for others...and no one said a single word.
Also, FOMO tested Alita with no issue...so no, the Crown is not valid for determining that the other examples will be bad too....
 

·
Registered
Joined
·
158 Posts
My plan is to compile a bunch of small clips and information to send to costco so that at the very least when they contact Hisense they'll be able to be more specific rather than just asking about "defective" tv's.
 

·
Registered
Joined
·
674 Posts
My plan is to compile a bunch of small clips and information to send to costco so that at the very least when they contact Hisense they'll be able to be more specific rather than just asking about "defective" tv's.
The sad part is no one should have to do any of that...Hisense has just left everyone hang at this point, 4 months later.
We've got a whole board of very unhappy customers whose time and effort have raised the price of this set to Sony and Samsung levels. And no word...of anything viable about a fix.
 

·
Registered
Joined
·
158 Posts
The sad part is no one should have to do any of that...Hisense has just left everyone hang at this point, 4 months later.
We've got a whole board of very unhappy customers whose time and effort have raised the price of this set to Sony and Samsung levels. And no word...of anything viable about
I know some people think I'm being a bit crazy and should just go with a different brand if I don't like the tv.
The sad part is no one should have to do any of that...Hisense has just left everyone hang at this point, 4 months later.
We've got a whole board of very unhappy customers whose time and effort have raised the price of this set to Sony and Samsung levels. And no word...of anything viable about a fix.
I know some people may think I'm crazy for getting this tv 6 times and not just switching brands. I absolutely love this tv when it works but it is so frustrating that it seems nothing is really being done about this issue. I'm hoping my persistence is enough to get the ball rolling a little faster.
 

·
Registered
Joined
·
172 Posts
No offense but thats not really good advice to a new owner. Why would you say its "no sign at all" if it exhibits red ghosting on the Crown ? Of course its a sign the TV has red ghosting. If it's on the Crown, it will be on other scenes too.
How severe though is the question. Still sounds to me like every H9G has the red ghosting issue to some degree.
You never get tired of repeating that, do you . . . even though you are, and have always been, completely wrong. It is quite possible for the red ghosting to appear ONLY on the Crown scene, because that's the only scene I have EVER seen it on. Period. Whether you believe that or not does not change that reality. The only valid "advice" to a newcomer is to see if it exists on the other known problematic scenes, because that's the only way an accurate assessment can be determined. Some people actually care about such things.
 

·
Registered
Joined
·
674 Posts
I know some people may think I'm crazy for getting this tv 6 times and not just switching brands. I absolutely love this tv when it works but it is so frustrating that it seems nothing is really being done about this issue. I'm hoping my persistence is enough to get the ball rolling a little faster.
You are dedicated....and after your ordeal you may need to be medicated !
 

·
Registered
Joined
·
158 Posts
I can upload another clip to show it, there is 0 ghosting with the K304 firmware on the crown but with each update it becomes apparent and worse. It seems so obvious that it's firmware especially considering samsungs similar issue.
 

·
Registered
Joined
·
172 Posts
On an unrelated firmware issue - has anyone else had the 1018 update cause the "TV" button on the remote to stop working? I haven't done the unplug cycle to see if that restores the function yet, just curious to see if it's just another unicorn manifestation on my set or if it's happened to others, too . . .
 

·
Registered
Joined
·
674 Posts
On an unrelated firmware issue - has anyone else had the 1018 update cause the "TV" button on the remote to stop working? I haven't done the unplug cycle to see if that restores the function yet, just curious to see if it's just another unicorn manifestation on my set or if it's happened to others, too . . .
Someone on Reddit was having that issue and it might have to do with the button having new functions....I don't know all the details. So..you got the update, obviously.
 

·
Registered
Joined
·
8 Posts
On an unrelated firmware issue - has anyone else had the 1018 update cause the "TV" button on the remote to stop working? I haven't done the unplug cycle to see if that restores the function yet, just curious to see if it's just another unicorn manifestation on my set or if it's happened to others, too . . .
Mine also has the same problem.
 
3561 - 3580 of 4964 Posts
Top