AVS Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
I've had my RTV 5040 for 47 days and it just started the rebooting cha-cha. RTV's help people said it was dead and to try to exchange it at Best Buy. I called BestBuy and they said after 30 days I had to go to the manufacturer. RTV gave me an RMA and have indicated 15-20 days turnaround. Oh, and by the way, they're going to send me a refurbished unit as they don't have any new ones. Real nice... so I've paid $500 for lifetime service and a used box!!!


...and I haven't even received my rebate check yet!!!


I'm bummed. I've gotten so used to the RTV, I'm in shock having to watch what's on... and with commercials no less!!!


I just hope the box they send lasts!


01000111
 

·
Registered
Joined
·
398 Posts
It sounds like you don't have much choice but to send the thing back and wait for the turnaround. Sucks, but at least it's under warranty. And a used (refurbished), working unit is better than a new one that doesn't work.


If you really don't feel like you can live 3 weeks without your machine, you could always go buy another one from a store with a good return policy, put lifetime activation on it, and then cancel the activation and return the new one to the store within your 30 day window when you get your original one back.


Kind of a sucky way to have to do things, but probably justifiable under the circumstances. If ReplayTV offered a good cross-ship policy or fast turnaround, it wouldn't have to come to that.
 

·
Registered
Joined
·
45 Posts
When I called SB support they gave me an RMA #. My wife shipped the unit on a Thursday and we had a refurb back that next Tuesday - that's 4 business days including shipping. I can't complain about having to ship it back other than I didn't get my shows off of it. This was at the end of this March.
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #6 ·
Quote:
Originally posted by Carnivore
It sounds like you don't have much choice but to send the thing back and wait for the turnaround. Sucks, but at least it's under warranty. And a used (refurbished), working unit is better than a new one that doesn't work.
Agreed. It is under warranty, and AmEx extends that to 2 years, so as long as someone is still in business and repairing/replacing 'em, I should be ok.

Quote:
Originally posted by replay_boy
When I called SB support they gave me an RMA #. My wife shipped the unit on a Thursday and we had a refurb back that next Tuesday - that's 4 business days including shipping. I can't complain about having to ship it back other than I didn't get my shows off of it. This was at the end of this March.
GOOD NEWS! They quoted me 15-20 days, but I'm hopeful that this is the standard time they are required to quote, and not actual time. I also hope it's calendar days, not working days.


Anyway it's been sent via USPS with insurance... just in case.


01000111
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top