AVS Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
Got a new 5040 today, and although it boots fine, the entire front panel (status lights, and more importantly, the IR sensor) is dead.


Obviously, I want to get a new unit in my hands ASAP. I've read a lot of the posts regarding RMA's to SB, and the amount of time it has taken people to get a new unit seems to vary greatly, from stories of 2 day advance replacement, to 2-3 week+ runarounds.


I'm hoping to hear from those who have had a recent RMA experience to help me decide whether I will have a quicker turnaround going to the retailer (Goodguys.com), or dealing directly with SonicBlue.


Thanks..
 

·
Registered
Joined
·
130 Posts
if you just bought it, use the store 30-day return policy to get a new one. As long as they have one in stock, you'll have the replacement immediately. I just returned my 5040 because of the reboot cha-cha and received the replacement in 10 days.


01000111
 

·
Registered
Joined
·
40 Posts
That's interesting that you had a dead front panel. My second 5040 was just like that. I figured that someone just forgot to connect a wire! Sounds like there may be an issue with the front panel? Unfortunately, my first 5040 was experiencing the reboot of death. I had purchased the first from Best Buy and it was just over the 30 day period (43 days) when it started the continuous reboot. After reading some coments from this forum, I tried returning it to Best Buy, describing the problem and the phenomena behind the reboot. They returned it without much problem (and the second one as well, a few days after). I'm now on my third 5040, so far so good.


As far as your unit, I would definitely just try to take it back to the store, even if it is outside of the 30 day return period. Let them know about the known issues.


Good Luck!
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top