AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have to say, I feel like I should have to post here, but I can't figure this out for the life of me. Thanks for any help you can give.


Summary: PS3 can connect to modem 1000-10/Full, but PS3 can not connect to router at 10-100/Full, only 10-100/Half. PC can connect to router and modem at 10-1000/Full. Using same ethernet ports/wires/etc.


Exquipment:


Motorola SBG6120 (DOCSIS 3.0 Modem)

D-Link DIR-628 (100/Full Wireless N router)

PS3 Slim (120GB)

RJ45 Cat5-e.

EG1032 Linksys NIC (In PC)


Steps tried:


First I turned everything off, and connected direct from the PS3 to the modem. I turned on modem, waited for lights, then turned on PS3. Went through and did everything auto except duplex, which I set at 100/Full. Connects, good through-put, no error. Keeping the PS3 settings the same, I turn everything off again. I set the PC's NIC to 100/Full forced. I connect the modem to the router (WAN port), then the PC to the router(LAN1) and the PS3 to the router(LAN2). I power up the modem, wait for lights, then turn on router, wait for lights. PC can connect, good repair and good through-put. Power up the PS3 and did the test again(keeping the exact same settings) and it fails with "80029020" error. I go back and change it to 100/Half, works like a charm. End of story right? Not quite.


I start having some problem with my PS3 (USB Certified) wired headset. Works on my PC Plug&Play, and works in XMB. Shown up as Logitech USB headset, get good levels on mic check. But no one can hear me in game. I spend weeks opening ports, and forwarding ports, and enabling/disabling UPnP. As a last resort, I boot the PS3 into safe mode and reload the folder system. It finds corrupted files and repairs them. Reboot, now Mic Input has new options in XMB, including a "Echo Canceler". Now the Mic works, but no, still not end of the story. I am sorry.


So I start playing a Online multiplayer PS3 game (Fat Princess) and notice I can only host up to 6 people. When I bypass the router and go direct to the modem I can host up to 36. So I start doing some more troubleshooting. I basically repeat previous mentioned steps. Now I start taking things more serious. I disconnect all other devices and disable the wireless radio in the router. I shut down any port forwarding or such, and try again. This time the test still fails when I set the PS3 to 100/Full, but after it fails, it gives me a result. 492.7Kbps down and 4.47Mbps up. If I set to 100/Half and run the same test, I get no error and 16Mbps down and ~4.5Mbps up. So at this point, I have isolated it down to either a configuration problem in the router or the PS3. I have ruled out hardware. I reset my router back to factory(Ugg, I had alot of custom settings). Didn't restore from file, fresh start. Power cycle, get everything back up and going, with same result. PC can connect to router at 100/Full, but PS3 can not. Interestingly, If I set it at 1000/Full (which my router doesn't support) it fails as step 1. When it is set to 100/Full, it fails at final speed test.


I call up PS3, and they are friendly, but just suggested send it into be repaired. Since I have eliminated hardware, I am not ready to loose my PS3 for 3-4weeks. (Turn around time for repair.) Does anyone else have any other ideas? I have had a problem with this router where I had to reset it to factory because it wasn't saving settings at change. Wouldn't let me re-enable wireless radio about 6 months ago.


Questions:


Could it be bad firmware? But how would it effect duplex?

Could it be a bad driver in the PS3?

Could it be a bad pin? But then why can it duplex to 1000/Full to the modem?


Any help you could give would be great. It may all be a wild goose chase, but I just don't see why it can't connect at 100/Full to the router.
 

·
Registered
Joined
·
28 Posts
I am having the same problem. My Sony EX700 TV, Mac Mini, Wii, two Xbox 360 and two PS 3 (fat and slim) are all on the same Airport network, Mac, Wii and Xbox connection speeds are fine. Only the Sony TV and PS3 are getting crappy 1/5th of my normal download speed and get dropped constantly.


I am convinced that it's the Sony products setup problem.
 
1 - 2 of 2 Posts
Top