AVS Forum banner

241 - 260 of 453 Posts

·
Registered
Joined
·
582 Posts
The ProntoEdit program doesn't do a very good job of recognizing the codes. It will accept partial codes for learning. I have found that Tonto, a freeware project for multiple OS platforms, will continue to prompt you for the codes until it gets more than one with the same data. You can download the most recent version HERE
 

·
Registered
Joined
·
12 Posts
This thread has really gotten me excited. After finding it, I went ahead and ordered a 2nd Replay 5500 (thanks ebay). However, I've hit a problem (jump to the bottom to skip the set-up and get right to the problem).


Situation:

I've got a RG2200 (Next Level Communications / Motorola ) gateway which converts magical DSL-like bitses into 3 TV streams (+DSL). I've been running with remote code of 0764, customized to extend inter* delays to 400 (otherwise channel 144 becomes channel 14).


Now this weird beasty uses RF remotes to tune all three channels (since the box is in one room, but TVs are whereever). Sometimes TV1's remote is programmed to use RF, according to my google research. It is indeed possible to set up all 3 remotes to use IR -- this is why this thread gave me hope.


Good News:

As it turns out, the ReplayTV already knows the IR codes for TV2 and TV3! So I'm home free, except...


Problem:

TV1 is output on ch4. I run CH4 out of the RG2200 into the current Replay and everything works fine.

TV2 is output on ch 7

TV3 is output on ch 13


I've successfully gotten the Replay to tune TV2 and TV3 (verified by using the Replay remote to change channels, while watching the TV connected to the RG2200's regular output tuned to ch 7 and ch 13 respectively.


But I can't set up the Replay to record from 7 or 13. The only choices are 2,3,4.


1) Is there any possibility of hacking a ReplayTV file (similar to how the IR files are hacked) to add a selection of 7 or 13?

2) Is there any semi-inexpensive hardware I could buy to have the RG2200's ch 7 or 13 remapped to ch2/3/4 or simply A/V I could set up on the Replay's Input 1?


I'm hoping one of you Replay hackers might have noticed a file where this is controlled, since obviously the Replay CAN tune channels 7 and 13. Any help would be greatly appreciated.
 

·
Registered
Joined
·
12 Posts
Well, I answered my own question after a few days of digging around, and adapting all these IR blaster techinques.


Each channel source gets its own key tree in the registry. So you have to configure the Replay for the Next Level Communications RG2200 once, using the menus to set up the right registry entries. To discover what those are, you need to may need to export the registry to somewhere you can see it -- easiest is to use WiRNS and the shellcommands extension to export the registry to the photo partition, where you can grab it using Replay's own photo transfer software (a bit of a reverse of the same technique used to add new IR Blaster files).


Add to WiRNS shellcmds file:


cp -f /name/system/user/Registry/sysconfig.reg /name/storage/Photo/sysconfig-orig.reg


(To view the contents, copy the file from the replay partition to the PC, then edit with wordpad or other editor)


Since its now using WiRNS, the keyname is unsurprisingly WIRNS01


Then add the following to the shellcmds:


regedit setval SysConfig/Sources/RF1/WIRNS01 Codeset 1316

regedit setval SysConfig/Sources/RF1/WIRNS01 Channel 13


(or 1315 and 7)


I know this will only help a few people at most, but I got a lot of help from google hits to here and elsewhere, and maybe this entry will help someone else someday in the same way.


Note: I also tried altering the SysConfig/Output/TuningManager ModulationChannel to 13, but it didn't work. I'm guessing the hardware is limited to just channels 3 and 4 for RF output. Time to buy a hardware modulator for housewide distribution
.
 

·
Registered
Joined
·
544 Posts
I can boot flipflop's iso, but it fails to find my RTV. The RTV is set to auto. Any suggestions?

My router has DHCP on.

Update:

I rebooted the RTV and ran the .iso.... it found my rtv and loaded a file to it. The RTV rebooted itself. At no time did I get a prompt (on the PC) to change the DNS and force a connection.
 

·
Registered
Joined
·
20 Posts
I am so close, I need just a little more help. I was able to use WiRNS to load the new code into my 4504 for an H20 Directv receiver and everything is working fine but I cannot get my guide data back. The satellite box is showing up as WiRNS Directv- Denver and has no data, only the channels. I uninstalled WiRNS but I still cannot get the standard Directv guide back. Is there a way to force the DVR to uninstall the WiRNS guide data? Any help would be greatly appreciated.


Edit: Nevermind, I just figured out that all I needed to do was change the zip code and all is well. By the way, this forum rules!!! I love my ReplayTv.
 

·
Registered
Joined
·
6 Posts

Quote:
Originally Posted by FlipFlop /forum/post/0


Once things are working, restore the ReplayTV network configuration to your

previous settings. You can also safely remove the "install" photo directory

from your ReplayTV(s). This folder was automatically created during the

install process.

FlipFlop, I have 4 ReplayTVs and one has no photo partition. The CD boots and hangs at "Installing......" with the IP address of the Replay w/out a Photo Partition. Am I SOL with this configuration? I'd hate to rebuild the Replay but I need these stupid D11s to work.



Sigh... Any help is appreciated...
 

·
Registered
Joined
·
20 Posts

Quote:
Originally Posted by MukPuppi /forum/post/0


FlipFlop, I have 4 ReplayTVs and one has no photo partition. The CD boots and hangs at "Installing......" with the IP address of the Replay w/out a Photo Partition. Am I SOL with this configuration? I'd hate to rebuild the Replay but I need these stupid D11s to work.



Sigh... Any help is appreciated...

What model numbers are you Replays?
 

·
Registered
Joined
·
6 Posts

Quote:
Originally Posted by DSSdevl /forum/post/0


What model numbers are you Replays?

Three 5040s and a 5080. The 5040 w/out the photo partition is the oldest, where I said 'I'll never need that. I'll take the extra 10 minutes of video.'



But the other three have updated so nicely (BTW, the boot disc is TOTALLY 1337 FlipFlop) that I've spent the afternoon moving off everything I'd like to save w/DVArchive and I'll just reformat it and be done with it.


While I dearly love AVS Forum and could never have kept my Replay network running without it, I'm a bit non-plussed at the level of effort and technical ability required to do so. It's just TV. Well, TV MY way, but still...
 

·
Registered
Joined
·
1 Posts
FlipFlop--


I'm having the same problem with a D11 receiver. I created the Linux boot CD from your ISO file and it created the files in the MyPhoto folder, etc. However, during setup, the 2007 code for the D10 receiver will only power on a D11 receiver. I understand you didn't write it for a D11, but was hopeful it might work. If you could create an ISO with the D11 codes, that'd be fantastic! I haven't found anything else out there and it looks like several others are running into the same problem.


Thanks,

Steve
 

·
Registered
Joined
·
544 Posts
Thanks flipflop....got it to work


I got held up initially because my photo partition was set to zero. My replay would reset itself when the .iso tried to load its files into the empty space.
 

·
Registered
Joined
·
22 Posts

Quote:
Originally Posted by FlipFlop /forum/post/0


I rebuilt the bootable CD image with a function to automatically detect all ReplayTV units,...b;ah, blah blah


Once things are working, restore the ReplayTV network configuration to your

previous settings. You can also safely remove the "install" photo directory

from your ReplayTV(s). This folder was automatically created during the

install process.

I was succesfull in perforing procedure with linux bootable cd;,except;


1.How do I "clean up" the new fact that the clock is left toggled on after each guide update? Deleting the install folder inside the photo folder didn't do that..


2. Why is it that even with correct postioning. the 4 digit IR codes being sent to my Pansat 3500S result in the reciever's on screen menu being left on?


Thanks in advance for anyone that knows!!
 

·
Registered
Joined
·
1,172 Posts
1. 243 RZ 3 & 4
 

·
Registered
Joined
·
37 Posts
Many thanks to FlipFlop and all who helped understand and create the bootable dvd to fix the IR problems. It brought to life my DirectV D11 receiver. It was the simplest patch I've ever had to install.

Scott
 

·
Registered
Joined
·
1 Posts
Hello Y'all:

I was wondering if there was a guide on how to get a ReplayTV to work with a coolsat 5k? I tried creating a boot disk described by flip flop but my laptop did not recognize it as a boot disk? Is there some setup or adjustment i must do to get it to work? I pressed f12 and chose cd drive but nothing, windows starts normally. I also downloaded winimage but no results. I was hoping there was a guide for newbies (or a guide for dummies) to get me started on the right path? I have searched but have not found any. Kind of a manual with step by step instructions. Sorry for sounding ignorant but I'm new to this field. Thanks.
 

·
Registered
Joined
·
1 Posts
Hi FlipFlop, Thanks for you quick and easy instructions to upgrade the IR Codes. I do have one some problem, I followed your messge and was able to copy the code to my replaytv but I don't see the codes when I try to added them. I do see the install folder with the files under the Photo folder but when I try to add the ir codes I don't see them. Help! Thanks in advance.
 

·
Registered
Joined
·
333 Posts
After browsing other threads and trying without success their various recommendations, I did used flipflops utility from THIS POST .


this may work for other samsung tuners.


BTW, someone should post flipflops posts 106 and 107 in this thread to the FIRST POST in this thread, so they are easily found. The Robman, I'm talking to you!



thanks for youre great utils, flipflop.


Oh, and I wasn't able to add the code to the list, even when modifying 'ircodes' to add it. Possibly ircodesRaw and irfilelist are important? I ended up just replacing the 0001 codes using DVArchive to upload the file (create the folder 'install' in photos and put it in there) and the shell commands (using WiRNS (getshellcommand plugin) or the serial shell (115200 bps for 5xxx replays)):

Code:
Code:
cdsys
cd Platform/Plymouth/IRBlaster
rm C0001fi.rid
cp /name/storage/Photo/install/C0001fi.rid C0001fi.rid
that code will work whether you're running in sys1 or sys2.

 

SIR-T151.zip 0.314453125k . file
 

Attachments

·
Registered
Joined
·
22 Posts
Quote:

Originally Posted by FlipFlop

I rebuilt the bootable CD image with a function to automatically detect all ReplayTV units,...b;ah, blah blah


Once things are working, restore the ReplayTV network configuration to your

previous settings. You can also safely remove the "install" photo directory

from your ReplayTV(s). This folder was automatically created during the

install process.




I was succesfull in perforing procedure with linux bootable cd;,except;


1.How do I "clean up" the new fact that the clock is left toggled on after each guide update? Deleting the install folder inside the photo folder didn't do that..


2. Why is it that even with correct postioning. the 4 digit IR codes being sent to my Pansat 3500S result in the reciever's on screen menu being left on?


Thanks in advance for anyone that knows!!
 

·
Registered
Joined
·
912 Posts

Quote:
Originally Posted by sxWolf /forum/post/0


1.How do I "clean up" the new fact that the clock is left toggled on after each guide update? Deleting the install folder inside the photo folder didn't do that..

Change your ReplayTV network configuration back to automatic, so that it goes back to getting the updates directly from the ReplayTV servers.
 

·
Registered
Joined
·
20 Posts

Hello to all -

I am trying to get my new D11 Directv receiver and 5040 ReplayTV to talk so the Replay will change channels. I've read through the thread (what I understood, anyway), d/l'ed FlipFlop's ISO (post 207), and tried it. I got the computer to boot fine, but the computer never saw the Replay. I am connected to the Replay with an Ethernet cable, just like I would for DVarchive.

Let's start with the fact that I am a total Noob at all this.


First off, am I trying to solve the problem the right way? It sounds like it.

I'm confused about a few of the instructions with the bootable CD. Switch the network Connection to static. How? At the moment, the Replay is set to Modem with no IP addresses listed. I remember messing with them, but never got that to work.

I think my computer IP address was 0.0.0.0 in the readout from the bootable CD. Can this be right??

Next, select Menu Setup. Connect to ReplayTv service. I don't see this anywhere.

Would it be easier to try the Wirns setup? If so, can someone direct to a step-by step for it? The CD sounds like the way to go, but I'm stumbling.

And lastly, what is the best way to get OUT of the bootable CD? I typed in reboot. Is there a key that will take me out?

Apologies for dragging the thread down to the most basic levels, but this is the best info I've found so far and my only hope of not having to trash the Replay.

Many thanks.

Makoti
 

·
Registered
Joined
·
912 Posts

Quote:
Originally Posted by makoti /forum/post/0


I'm confused about a few of the instructions with the bootable CD. Switch the network Connection to static. How? At the moment, the Replay is set to Modem with no IP addresses listed. I remember messing with them, but never got that to work.

I think my computer IP address was 0.0.0.0 in the readout from the bootable CD. Can this be right??

The bootable CD requires that you have a router on your network, with a DHCP server running. If your ReplayTV is using the modem, then I would guess that you don't have a broadband connection, and therefore don't have a router?


If you do have a router, then the PC should get an IP address from it, and report what it is. On the replayTV you go to the setup menu, select "network and input connections" to switch from modem to ethernet with a static IP.
 
241 - 260 of 453 Posts
Top