AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi , i own a china made DLP projector called PD-X770. It has the following problem.

1)Pressing the power button lights the lamp for 1 second , you can hear an instant buzz sound and then it goes of with a red light.

The spinning wheel starts while the lamp is lit for 1 sec then spins off.

1 every 50-60 trys the projector lights up normally, then a NOT very loud buzzing sound is coming from the ballastt.It is ok for 10-15 minutes then either it goes off or it freezes in black n white picture of the last frame of what i was watching

Anyone has any ideas ? Colour wheel ? ballast ? a capacitor ?

the lamp seems ok as inspected it and had about 1300 hours. picture is ok also when once in 50 shows up

Please help , i dont have any manual or smth similar for that , its an oem projector from china

Thank YOu in Advance
 

·
Registered
Joined
·
1,901 Posts
Sorry, but this is why we warn against buying projectors from China. If and when anything goes wrong, it has to go back to China, there is NO state-side support for it.


The buzzing sound is most likely the color wheel bearings failing. The fact that you have a B&W image, even intermittently, suggests other problems, probably in the image processor. If it were the color wheel freezing, the projector would shut down and the chances of it freezing on the clear segment every time, well, if that were happening, I'd say go buy a lottery ticket with your odds.


No, it was a bad buy and has to go back for repair/replacement, or better yet, get your money back and get something here.
 
1 - 2 of 2 Posts
Top