AVS Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
After thirty hours of use I got two dust blobs, I clean the filter every ten hours.


I got the top off and I got my can of air, but I don't know what to spray.


There is a glass lens inside that I sprayed and I thought that was it, but when I tried the picture out the blobs were still there. They are very large and become focused when I defocus. One is in the middle, the other at the top right-hand corner. One is green, the other, blue. The projector does not have any dead pixels. They are about the size of the circle you can make with both your hands by joining your thumb and index fingers together.


So if someone can detailed specifics for me then maybe I can fix this problem. I searched and searched, but I couldn't find anything that

told where to spray. I am a complete newbie so I don't know what an lcd panel looks like for example.


Thanks alot!
 

·
Registered
Joined
·
111 Posts
hi there i had dust on my panny a100 and cleaned the dust out very easily.


look at here


this is inside a a100 your should look similar now to clean the pannels remove the lid and hold the unit on its side then take your can of air making sure its upright so as not to discharge any liquid give the can a spray away from the pj to ensure no liquid comes out and you want to spray all around the holes where the gold cables attach as these are the pannels try and spray into the holes for abou 2 -3 secs thats what i did and the dust was gone. You can clearly see the 3 panels on the first picture this is where you want to spray
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top