AVS Forum banner
Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
I have a Hauppauge WinTV-card. I experience huge interlacing problems with the WDM-driver. It prevents me from using it. So I asked myself the question: "What is the cause of the interlace problem?". Is it the WDM-diver? Or the capture-program? Or the graphics card driver?

I have done thorough testing with the VFW-driver, WDM-driver and all kind of capture-programs, settings etc.


The results are quite clear (and undeniable, in my opinion):

- The interlacing problems are definately due to the WDM-driver!

- The VFW-driver has no interlacing problems.

- The PQ of the VFW-driver is less than of the WDM-driver.

- The WDM-driver is faster when used for recording tv-programs.

- The WDM-driver does not support the highest PAL-resolution (768 x 576), the VFW-driver DOES support this resolution.

- With ShowShifter in combination with the VFW-driver there's a tv-channel tuning problem, resulting in not-fine-tuned channels and hence even worse PQ (and SQ).


Summarizing: the WDM-driver is faster and has a better PQ than the VFW-driver, but it has terrible interlacing problems and it doesn't support 768 x 576 resolution. The VFW-driver has no interlacing problems and supports 768 x 576 resolution, but has a lower PQ than the WDM-driver and is slower. And it has a tuning problem with ShowShifter.


So at the moment there is NO way to capture at the highest resolution with the highest PQ without interlacing artifacts.


This frustrates me A LOT. I'm waiting and testing for a year now, constantly hoping for better drivers which solve all the problems, but so far IN VAIN.:mad:

It's such a pity, the card is perfect. The PQ CAN be excellent (proved by the WDM-driver), interlacing CAN be solved (proved by the VFW-driver) etc... but STILL there is NO perfect solution!

I've read that ATI is also famous for their flaky drivers. What is it with those hardware vendors? They produce great hardware, but their drivers are sh.. Don't they realize that this pisses customers off (excuse moi) and that it is very bad publicity for their products?


Mkanet, if you read this, can you PLEASE contact the Hauppauge engineers again and explain them the problems. I've tried several times to contact them, but got no response at all. I'm getting desperate...

I know that the previous thread about the WDM-driver raised a lot of confusion, but I'm convinced my testresults are correct.


Some hardware info:

1 GHZ Athlon cpu

128 MB memory

Abit KT7A mobo

Maxtor 40 GB 7200 rpm hd

Matrox G450 DualHead graphics card.


(BTW, I've tested the capturing with the MJPEG and Divx4 codecs).


Regards,

Johan
 

·
Registered
Joined
·
1,631 Posts
Johan,

I hope you are not using ShowShifter only and then judging these drivers because ShowShifter and WinTV both have an interlacing problem that has to do with not sizing the windows correctly for the BT-8x8/9 cards.


You should look at the picture in Amcap. And you should follow the link posted by SHS because there is a new driver there (as well as a new WinTV you might try.
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #4 ·
Whoopie! Something really incredible has happened. THANKS SHS, for giving me the link to the new WDM-driver. I had a URL to this FTP-server, in the root dir is the first version of this OWDM98XP driver (dated 10/19/01), so I daily looked for a newer version... and I totally overlooked the new XP dir. In this dir a newer version was posted 26/10/01! And than I discovered that also 26/10/01 Matrox posted a new driver for my graphics card.


I installed the new WDM-driver and yes! The interlacing-problem was gone! And this new driver supports resolution 720 x 576 (it should be 768 x 576 though, for a perfect 4:3 aspect ratio). I found a little utility for G400/G450-cards to enable overlay for odd resolutions (like 720 x 576) and to set the overscan percentage. It's called DivXG400 ( http://www.tac.ee/~prr/videoutils/ ), but it's not only for Divx and work also on G450 cards (and probably on the new G550 as well). Than I installed the new G450-driver from Matrox and .... BANG! Absolutely perfect picture quality, interlacing gone and being able to capture at the highest resolution. Perfect!


It's really unbelievable that after a year of trying and waiting, and starting this thread yesterday because I was fed up, ON THAT SAME DAY all problems were solved! Miracles DO happen sometimes :)


Vey, I was aware of this scaling problem with ShowShifter and WinTV, but this only relates to the viewing window, not to recordings. It's not a problem for me, because overlay mode on the secondary display works perfectly now with ShowShifter (I haven't tried the new version of WinTV yet, because I hardly use it, I use ShowShifter and DScaler).


I've been testing and tuning all night with the new drivers and the utility, so I'm sorry for this late reaction :)


SHS and Vey, thanks both of you!


Mkanet, although I'm in capturing heaven now, maybe you can let Hauppauge know that this 720 x 576 resolution should be 768 x 576. That's the only bug left, as far as I can see now (but I'm still testing). I can live with it, but it would be nice if they changed it.


Sorry for the agitated first post, I was really frustrated. But as I said, miracles do happen :)


Regards,

Johan
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #7 ·
> Hmm. I must not be doing things right since it seems to be bothering my recordings in ShowShifter as well. Probably a video card problem. (SiS-730)


Sorry, you are right. It DID bother my recordings as well, but after upgrading to this new driver, the recordings are OK. If you look at the recording picture-by-picture you still see some interlacing and blur at high movement, but that's normal. It is invisible when playing back at normal speed.


Yes, I have Amcap, but since ShowShifter works OK now for me, I don't use it anymore. I have used it for testing purposes.


This new de-interlacing feature under XP sounds very interesting. It's about time to upgrade, I guess. But I'll make a multi-boot configuration first, so i can check if all the hardware and software I have works flawlessly under XP.


Thanks Vey.


Regards,

Johan
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #8 ·
This de-interlacing option is a feature of the new WDM-driver and works under Win98SE as well! :) It is enabled by default for full-screen mode. Now I understand why this new driver solved my interlacing problem :D


The new WinTV application also works perfectly under Win98SE. The PQ is great, but for some reason the PQ is even better with ShowShifter.


Boy, this is great stuff! Hauppauge finally delivered a very good driver. Now add 768 x 576 support and I'm set...


Regards,

Johan
 

·
Registered
Joined
·
1,631 Posts
Johan,

Are you saying that interlacing has gone away in ShowShifter? Full Screen or with all size screens? I still have it in Win2k and ME in ShowShifter.


I want to do a complete uninstall and reinstall and then see what happens.


ATI had this interlacing problem in ShowShifter licked in their BT829 drivers that came out in March. Maybe Hauppauge is finally catching up?
 

·
Registered
Joined
·
4 Posts
Vey, yes, the interlacing is gone in ShowShifter, but only in full-screen mode. For other TV-window sizes ShowShifter takes the highest available resolution from the WDM-driver and then downsizes to the window size. This doesn't work perfectly and results in interlacing and other imperfections. It seems that the developers of SS are working on a solution for this. It will be implemented in the new version, which, so I heared, will be available soon.


Just to be sure de-interlacing is enabled in the WDM-driver: install the new WinTV-application, start it and go to Preferences, tab Deinterlacing and check 'deinterlacing' for full-screen mode and for all other window sizes.


Regards,

Johan
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top