AVS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
688 Posts
Discussion Starter · #1 ·
When I play a DVD or DVD ISO, a dialog pops up and forces me to select either Windows Media Center or TotalMedia Theater for playback.


Is there a way I can always force DVDs to play in Windows Media Center and get rid of the dialog box completely?
 

·
Registered
Joined
·
1,650 Posts

Quote:
Originally Posted by woody777 /forum/post/18187788


Windows 7... and launching from inside Media Center.

Don't know how to turn it off.

But I do know it doesn't happen with DVD folders; only with discs.

And of course an ISO will be considered as a disc.

I've never seen a setting inside MC for default player, only a global setting in Windows.

There might be a way if you want to try it:

Download and install " Media Center Studio ". It is a MC editing program which allows you to change/delete/add icons & extras to MC. Inside there would be a folder for 'Play DVD'. I'm not certain of this since I only tried it in Vista and it was for Blu-Ray & HD-DVD not for DVD.

But give it a shot and see what you find. There's a reset button if something gets screwed up.
 

·
Registered
Joined
·
688 Posts
Discussion Starter · #5 ·
I'll give Media Center Studio a try.


You are correct though... I can launch a DVD folder from MediaBrowser and it just plays using WMC. That's what I'm looking for with the actual DVD disc.


Same with Blu-rays. It acts like it wants to autoplay when I put in a BD disc, but then it never does. I have to manually go into the movie library and select the disc.
 

·
Registered
Joined
·
1,650 Posts

Quote:
Originally Posted by woody777 /forum/post/18189270


Same with Blu-rays. It acts like it wants to autoplay when I put in a BD disc, but then it never does. I have to manually go into the movie library and select the disc.

Now that you should be able to fix with MCS. There should be a Blu-Ray header in MC. Just drag the TMT icon under that header and it will set it as the default player for Blu-Ray inside MC.

Again, I never did this in Win 7, only in Vista.
 

·
Registered
Joined
·
688 Posts
Discussion Starter · #7 ·
I got Blu-rays to autoplay correctly. I was using the trial version of AnyDVD and the pop-up reminding me was apparently disrupting the process. I purchased a key and all is well.


I found a little registry hack that let me add WMC to the autoplay list Windows 7. I set DVDs to autoplay in WMC. That eliminated the little pop-up that says "play disc," but it still goes the screen that makes me decide between WMC and TMT3.


I installed Media Center Studio and I see where it sets BDs and HD-DVDs to autoplay in TMT3, but I can't see anything that lets me do the same with DVDs.


I can't be the only one bugged by this, can I?
 
1 - 7 of 7 Posts
Top