AVS Forum banner

261 - 280 of 730 Posts

·
Registered
Joined
·
228 Posts
I just wanted to add that I finished the install of my Monoprice unit this weekend and my whole family loves it! I ended up getting a Denon AVR-X2100W because of it's multi-zone capability and it works perfectly! Kids were watching Dust to Glory in 5.1 in the living room while the wife was listening to the radio in the kitchen and I was listening to internet radio in the back yard, everyone was happy!

All I need now is the Android app and it will be perfect!
Do you have any iOS devices? That all will be available before you know it. The UI will be very functional, very precise, and fast access to key tasks.
 

·
Registered
Joined
·
228 Posts
Was doing some Googling and ran across this app, searched back few pages and didnt see any links to it. Anyways has anyone tried it? I'm about ready to order the iTach Flex IP and serial cable.

http://www.tinystarship.com/home-audio/

In the app store for $5 and looks pretty nice.
Naturally I have. UI is not very intuitive or well designed. Not scalable to multiple devices. And requires iTach Flex. A lot of the reasons we decided to build an app ourselves.
 

·
Registered
Joined
·
267 Posts
Was doing some Googling and ran across this app, searched back few pages and didnt see any links to it. Anyways has anyone tried it? I'm about ready to order the iTach Flex IP and serial cable.

http://www.tinystarship.com/home-audio/

In the app store for $5 and looks pretty nice.
There's a thread here about that app and an active user that developed it, @naevity. I agree it looks pretty nice and is only $5 (estimated price of the other one still in development is $20, but the developer could confirm plans.). Here's the other thread:

http://www.avsforum.com/forum/36-home-v-distribution/2208241-monoprice-whole-home-audio-controller-ios-app.html
 

·
Registered
Joined
·
161 Posts
Naturally I have. UI is not very intuitive or well designed. Not scalable to multiple devices. And requires iTach Flex. A lot of the reasons we decided to build an app ourselves.
I understand your 2nd / 3rd points, but I'm curious what your reasoning is for the first one? I think i did a nice job designing it. Just curious if there is anything I can improve upon.
 

·
Registered
Joined
·
11 Posts
@naevity

Just got the iTach Flex installed and hooked up but cant find any documentation about the serial settings needing or recommended. I went ahead and purchased your app, seems to be fine for what I'm needing. However one nice thing would to allow a dns name in the public/away settings. This way I can use a DYN DNS type of service for my changing IP with my ISP.

EDIT: I tried email your support from within the app and got a bounce back, I then sent an email from your website with the above info.

Thanks!
 

·
Registered
Joined
·
161 Posts
@naevity

Just got the iTach Flex installed and hooked up but cant find any documentation about the serial settings needing or recommended. I went ahead and purchased your app, seems to be fine for what I'm needing. However one nice thing would to allow a dns name in the public/away settings. This way I can use a DYN DNS type of service for my changing IP with my ISP.

EDIT: I tried email your support from within the app and got a bounce back, I then sent an email from your website with the above info.

Thanks!
Good idea on the DNS name, i think I just have to change the keyboard type and run some tests. I'll also check on that email, it should be working, unless I never created it :)
 

·
Registered
Joined
·
11 Posts
Awesome thanks!

Any setting suggestions on the iTach Flex for serial settings?

I'm having issues getting the app to connect to the audio matrix. Any ideas on what to try?
 

·
Registered
Joined
·
6 Posts
Just got the iTach Flex installed and hooked up but cant find any documentation about the serial settings needing or recommended. I went ahead and purchased your app, seems to be fine for what I'm needing. However one nice thing would to allow a dns name in the public/away settings. This way I can use a DYN DNS type of service for my changing IP with my ISP.

EDIT: I tried email your support from within the app and got a bounce back, I then sent an email from your website with the above info.

Thanks!
I bought your app as well, and cant find any info on the serial settings either. The app either times out or crashes depending on the setting, can not get it to work. Please help and provide the settings. I have also tried email but had no reply at all (thanks Phil Collins).
 

·
Registered
Joined
·
11 Posts
I was able to get the app connected when on my local network/wifi, however if I turned of wifi and used public settings it would never connect. I do have my port forward/firewall and ip settings correct. Also the app was very intermittent, sometimes if I closed out and went back in it would report false settings or not connect. Only way to make it connect correctly was to force close the app.

A feature request would be to change the UI on the app to display the volume number. I have a good idea based on the number how loud it is but the slider bar is hard to tell on the volume level.

Thanks!
 

·
Registered
Joined
·
6 Posts
I was able to get the app connected when on my local network/wifi, however if I turned of wifi and used public settings it would never connect. I do have my port forward/firewall and ip settings correct. Also the app was very intermittent, sometimes if I closed out and went back in it would report false settings or not connect. Only way to make it connect correctly was to force close the app.

A feature request would be to change the UI on the app to display the volume number. I have a good idea based on the number how loud it is but the slider bar is hard to tell on the volume level.

Thanks!
Nutt318, can you help me out? What did you have to do to get the app working on your local network? What are your RS232 settings for the Flex? Did you have to set up anything on your router for the app to be able to communicate with the Flex? Any help greatly appreciated!

Best,

Mark
 

·
Registered
Joined
·
11 Posts
Settings are below for what worked on my local network.

Serial
Cable Type: RS232
Baud Rate: 9600
Flow Control: None
Duplex: Half
Parity: None
Data Bits: 8
Stop Bits: 1
Gender Changer: False

If you get it working I'm curious if you experiment intermittent connection with the app and the audio matrix.
 

·
Registered
Joined
·
161 Posts
Nutt318, can you help me out? What did you have to do to get the app working on your local network? What are your RS232 settings for the Flex? Did you have to set up anything on your router for the app to be able to communicate with the Flex? Any help greatly appreciated!

Best,

Mark
Hi Mark,

sorry for the hastle, my inbox freaked out and I was not getting any emails from 1/3 - 1/7. As Nutt318 said, the problem is most likely the baud rate, it needs to be set to 9600. This is the default baud rate of the monoprice app. You can change it, but any time it loses power it defaults back to 9600, so I decided to just code the app accordingly.
 

·
Registered
Joined
·
6 Posts
Settings are below for what worked on my local network.

Serial
Cable Type: RS232
Baud Rate: 9600
Flow Control: None
Duplex: Half
Parity: None
Data Bits: 8
Stop Bits: 1
Gender Changer: False

If you get it working I'm curious if you experiment intermittent connection with the app and the audio matrix.
Thanks very much, tried it with those settings and still no go. I'm thinking my flex may be defective, I'm getting a new one.
 

·
Registered
Joined
·
6 Posts
Hi Mark,

sorry for the hastle, my inbox freaked out and I was not getting any emails from 1/3 - 1/7. As Nutt318 said, the problem is most likely the baud rate, it needs to be set to 9600. This is the default baud rate of the monoprice app. You can change it, but any time it loses power it defaults back to 9600, so I decided to just code the app accordingly.
No, baud rate was right. Think my unit may be defective.
 
261 - 280 of 730 Posts
Top