AVS Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I'll try to keep this as short as possible...


Back in February my 5080 starting acting funny, getting stuck in loops and locking up once a day or so. The symptoms were closer to a bad hard disk than any of the problems I read about here, so I called SonicBlue for an Advance Replacement unit, as stated in the Warranty book. Since the unit was still working, that could have allowed me to keep all the programming on the unit, and simply transfer it to the replacement one.


The Supervisor, Angela W. in the US tech support office told me that they were not doing Advance replacements anymore, and got me an RMA number. She said they ship 2nd day, so it should only be three or four days from when they get my unit until I get it back. Maybe a total of ten days without the Replay. Over the next few weeks, I bought a 120 GB hard drive, got DVArchive working, and moved over all my shows.


On March 21, I shipped the unit back to Memphis. It arrived and was signed for on March 26. I called on the 28th to ask if I could get a tracking number for the returned unit, and was told that there was a 5 business day turn around, but the replacement should be sent the next week. Just to be complete, I got a new case number to track the return.


I called early the next week and spoke with a Monica in the India office and asked about getting a tracking number. She told me that the unit had not been sent out, because there is a 10 to 12 business day turn around. I was upset about this, but since the sale announcement I can understand some confusion and delays. She put me on hold for a while to talk to a supervisor. She came back and assured me that the unit would be sent back, and it should arrive April 10th. She gave me a new case number.


I called again today (April 8) to get a tracking number, since it would have to be shipped today to arrive by April 10. This time the CS rep in India (did not catch his name) explained that it was not shipped because there is a 10 to 15 business day processing time. He said that due to the company issues, they stopped shipping units for 7 to 10 days (which means that they had stopped when I called the week before and did not tell me). He also went to the supervisor and came back and assured me that my unit would be sent and I should get it in another 7 business days (April 17). In case I do not get it, I got another case number...


Has anyone else here had a problem like this? I don't have monthly service charges to get credited or anything since I have the lifetime, so what compensation can I get for them taking weeks longer than they promised? At this point I am not even sure if I will ever get it back. Every week I am told it will be one more week.:mad:
 

· Registered
Joined
·
1,384 Posts
One thing we've learned... if you call support, get India and don't like what you hear, call back during U.S. business hours and hope for Oklahoma.


They seem to know what's going on (in addition to Lyndon)


Robert
 

· Registered
Joined
·
110 Posts
My third 5080 too one month to be replaced. They said there was a mixup on my RMA. I received my new rebuilt unit and it works fine. It took me at least 5 phone calls and about 4 emails to get and andwer from Lynden
 

· Registered
Joined
·
429 Posts
I was having some weird issues with my machine displaying no color shortly after I bought it, so I sent it back in early January.


After several phone calls to customer service (or "tech support" depending on who answered the phone in India), I received a new 5040 at the end of February. I had to threaten a lawsuit to be taken seriously.


One and a half months later and I'm a happy Replay customer!
 

· Registered
Joined
·
124 Posts
I bought a DOA 4504 back in January. It took three weeks of calling India before I convinced them to give me an RMA. It felt as though someone had carefully worked out a set of tasks for me to perform before I could get the coveted RMA. And yes I know how to reboot the machine, do a cold boot, etc. (I have eight other Replays)


I shipped the deck to them in TN Feb 12, they signed for it Feb 19th; cost me $13.50 for UPS Ground from Los Angeles.


Weeks have gone by and no repaired or exchanged deck has ever emerged. If I get the US phone people they are friendly and act helpful, often calling me back every few days to tell they are still working on finding it. When I get India I get new homework assignments. (the latest guy wanted a list of all the serial numbers of all my other decks so he could tell which one they had in for repair) Sometimes they want my tracking number (was signed for by "Cooper"; one guy insisted to know whether the deck was lifetime or monthly and no amount of explanation could convince him that the deck arrived dead and could not be activated.


It is now April 9th, about 3 months since I bought the deck and there's no sign of an exchange. Now I see they're sending 5040s to 4504 purchasers, that would be terrible.


ReplayLyndon, I don't know if there's anything you can do, my Case number is 423683 and the deck I sent in might be serial number L2AA7001143. (but who knows anymore)


Please help.....
 

· Registered
Joined
·
14 Posts
I sent my 5040 back via UPS last Tuesday. They received it on Thursday. Today (Monday) I received the replacement via Federal Express. That is only six days!


Of course, I won't know if it works until I get home and set it up. Since the old one had lifetime authorization, I will probably have to call to get that set up on the new one.
 

· Registered
Joined
·
13 Posts
Discussion Starter · #11 ·
Yeah, that is how my swap was supposed to go. Lyndon found my ticket and got them to send my unit. It showed up today, and just like you I will find out tonight if my lifetime subscription was transferred.


Thanks Lyndon!
 

· Registered
Joined
·
124 Posts
Yep, me too. No unit for 3+ months and thanks to Lyndon a deck showed up in today's FedEx. I'm happy I finally got a deck, but you have to wonder about a company where the only good (no make that great) service is on a non-company website.....
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top