AVS Forum banner

19901 - 19920 of 30694 Posts

·
Registered
Joined
·
218 Posts
I've been having a weird issue with my Apple TV 4k 32GB ever since I got it which was over a year ago and I still have not found the cause. Often within the last 1-2 minutes of a movie or TV show in the Netflix, iTunes Movies, and iTunes TV Shows apps there is about a 3-4 second video freeze but the audio continues uninterrupted then several frames are skipped ahead. My TV is a Sony 40" 1080p LED TV. I have Match Frame Rate set to off in my Apple TV 4k even though my TV supports True Cinema 24p. My TV's Scene Select is set to Cinema mode with Cinemotion (there is no on, just Auto or off) on Auto for that input. Sometimes this stutter happens within seconds of the start of the ending credits if the ending credits is short enough duration but it's usually during the ending credits. I've tried another 32GB and two 64GB Apple TV 4ks as well and they both experience the same issue. I don't know if this happens in the Vudu app in the Apple TV 4k as well since I hardly ever use Vudu. When I replay the part of the video where it stuttered, it does not stutter again, so for sure it's not an encoding issue with the video. Also this issue seems to happen in the iTunes Movies and iTunes TV shows apps only when Quick Start is turned on but the Quick Start setting has no effect on the Netflix app and it still happens in Netflix with Quick Start off. I also tried different 4k High Speed HDMI cables, ethernet cables, and HDMI inputs on my TV but that did not resolve this issue. Also someone else in my family has an Apple TV 4k as well and does not experience this issue and is using a different internet, so I'm thinking that it may be an issue with my network or my internet. Anyone else experiencing this kind stutter issue near the end of streaming movies and TV shows in the Netflix, iTunes Movies, and iTunes TV shows apps in the Apple TV 4k?
 

·
Registered
Joined
·
20 Posts
Hi,

I recently purchased an ATV 4K, and if I'm impressed with stability and picture quality, I struggled with my harmony remote integration.
I'm used to kodi no raspberry, and I have a custom remote mapping to handle quick access to some features: download subtitle, subtitle delay plus and delay minus.
I have a lot of TV shows, whom french subtitles are not synchronized.
So I need to synchronize them at each advertising break: no way to go to the video settings -> subtitles settings -> delay, I need a one button click solution!

MrMc has a keymap editor, but even if my harmony is synced as a 'mac computer' (= mac bluetooth keyboard), no keys work, except arrows keys and space.
In infuse, I didn't find any remote mapping, nor subtitles delay adjustment.
No idea about plex.

So is there a way to deal with harmony and atv, to add some customization facilities ?
Or all applications follow the apple guidelines and have very few limited gesture/key support?
 

·
Registered
Joined
·
2,501 Posts
Hmmm, I've always had Yamaha receivers, an older model and a new one, and there's never been in input issue with an ATV4 or ATV4k, ever. Most strange.
But don't you have "HDMI Control" turned off on your Yamaha? I do.
 

·
Registered
Joined
·
336 Posts
Small correction. There are currently no applications that can play Dolby Vision, so far Multilayer Dolby Vision is restricted to hardware devices.
I just tried again. Sony x930e TV connected to a Denon x2200w AVR. ATV 4K also connected to AVR. An HDfury Vertex between AVR and TV. ATV set to 4K SDR, 4:4:4, YCbCr, Match Content for both Range and Frame Rate.
Denon has been updated to support DV and HLG and the x930e recently updated to Oreo.

Using MrMC, playing the LG Demo DolbyVision Trailer streaming from my NAS, Dolby Vision is triggered. TV displays the correct DV Logo on screen and Vertex shows
4K23.973 422 BT2020 12b DV 297MHz 2.2

I was surprised as well,

As a side, Infuse (which I agree is a great app) shows the same file as SDR. Still looks great!
 

·
Registered
Joined
·
3,557 Posts
Hi,



I recently purchased an ATV 4K, and if I'm impressed with stability and picture quality, I struggled with my harmony remote integration.

I'm used to kodi no raspberry, and I have a custom remote mapping to handle quick access to some features: download subtitle, subtitle delay plus and delay minus.

I have a lot of TV shows, whom french subtitles are not synchronized.

So I need to synchronize them at each advertising break: no way to go to the video settings -> subtitles settings -> delay, I need a one button click solution!



MrMc has a keymap editor, but even if my harmony is synced as a 'mac computer' (= mac bluetooth keyboard), no keys work, except arrows keys and space.

In infuse, I didn't find any remote mapping, nor subtitles delay adjustment.

No idea about plex.



So is there a way to deal with harmony and atv, to add some customization facilities ?

Or all applications follow the apple guidelines and have very few limited gesture/key support?


Not sure which Harmony you have but if it’s hub based try this “beta” device. A lot of use this.

https://support.myharmony.com/en-us/harmony-experience-with-apple-tv#appleTVBT



Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
20 Posts

·
Premium Member
Joined
·
10,243 Posts
Discussion Starter #19,907
S I really do not know why you can't except that it was causing the issue... not everything or anything else in the system. No amount of otherwise technically correct analysis can change the source of the problem.
Presumably because you don't understand how it works you've drawn the wrong conclusion. Or your ATV is defective. Or, despite your assurances, you have something misconfigured. It's impossible for me to know. But the first diagnostic step is using a CEC sniffer to see what's actually being sent by all the devices on the bus.

Nothing you've described is unique to the ATV. I had similar "random" behavior from a Chromecast Ultra and the LG 970 player neither of which had switchable CEC.

As I've said (now repeatedly) with CEC control off the ATV responds to enumeration and sends enumeration. It does not send a one touch play command and that's the only thing an "AVR" should use to switch inputs.
 

·
Premium Member
Joined
·
2,503 Posts
I've been having a weird issue with my Apple TV 4k 32GB ever since I got it which was over a year ago and I still have not found the cause. Often within the last 1-2 minutes of a movie or TV show in the Netflix, iTunes Movies, and iTunes TV Shows apps there is about a 3-4 second video freeze but the audio continues uninterrupted then several frames are skipped ahead. My TV is a Sony 40" 1080p LED TV. I have Match Frame Rate set to off in my Apple TV 4k even though my TV supports True Cinema 24p. My TV's Scene Select is set to Cinema mode with Cinemotion (there is no on, just Auto or off) on Auto for that input. Sometimes this stutter happens within seconds of the start of the ending credits if the ending credits is short enough duration but it's usually during the ending credits. I've tried another 32GB and two 64GB Apple TV 4ks as well and they both experience the same issue. I don't know if this happens in the Vudu app in the Apple TV 4k as well since I hardly ever use Vudu. When I replay the part of the video where it stuttered, it does not stutter again, so for sure it's not an encoding issue with the video. Also this issue seems to happen in the iTunes Movies and iTunes TV shows apps only when Quick Start is turned on but the Quick Start setting has no effect on the Netflix app and it still happens in Netflix with Quick Start off. I also tried different 4k High Speed HDMI cables, ethernet cables, and HDMI inputs on my TV but that did not resolve this issue. Also someone else in my family has an Apple TV 4k as well and does not experience this issue and is using a different internet, so I'm thinking that it may be an issue with my network or my internet. Anyone else experiencing this kind stutter issue near the end of streaming movies and TV shows in the Netflix, iTunes Movies, and iTunes TV shows apps in the Apple TV 4k?
That is peculiar, and sounds like it's specific to your TV; so have you tried setting the ATV to Match Frame Rate=ON, and/or your TV's Cinemotion=OFF? I would think the way you should have it would be:
  • Match Frame Rate=ON in the ATV, and
  • Cinemotion=ON in the TV,
but I would try every possible combination, because who knows? (I would also try the "offical" thread for your particular TV)

HTH
 

·
Registered
Joined
·
3,557 Posts
I have the harmony companion, with the bluetooth hub.

The "beta atv" device doesn't give any extra buttons (that are not on siri remote), and "mac computer" letter keys don't work in MrMc


Ok, I hadn’t realized that you already tried it. I also didn’t realize you were using the Siri remote. As you know then, that in addition to Bluetooth you get the task switcher, power off (sleep) and a few other commands not on your current Harmony Apple device or the Siri remote. Here’s a screen shot of available commands that are assignable to buttons. Also gestures can be customized for skipping.
Infuse has subtitle adjustments including time offset. See attached screenshots.
I also have MrMC but haven’t looked at the key-mappings as I much prefer Infuse.





Sent from my iPhone using Tapatalk
 
  • Like
Reactions: brotony

·
Registered
Joined
·
20 Posts
Ok, I hadn’t realized that you already tried it. I also didn’t realize you were using the Siri remote. As you know then, that in addition to Bluetooth you get the task switcher, power off (sleep) and a few other commands not on your current Harmony Apple device or the Siri remote. Here’s a screen shot of available commands that are assignable to buttons. Also gestures can be customized for skipping.
Infuse has subtitle adjustments including time offset. See attached screenshots.
I also have MrMC but haven’t looked at the key-mappings as I much prefer Infuse.

Sent from my iPhone using Tapatalk
I'll give Harmony beta ATV another try this week-end.
If skip or fast forward/rewind commands work, and could be mapped in MrMc, it could be ok.
(I'll use direction key only to small/big step forward, as in kodi)

Infuse tends to be more sexy to my eyes, but if I have to go in the menu for subtitles delay, it'll be a no go.
Thanks
 

·
Registered
Joined
·
3,557 Posts
I'll give Harmony beta ATV another try this week-end.

If skip or fast forward/rewind commands work, and could be mapped in MrMc, it could be ok.

(I'll use direction key only to small/big step forward, as in kodi)



Infuse tends to be more sexy to my eyes, but if I have to go in the menu for subtitles delay, it'll be a no go.

Thanks


Yes, Infuse is, IMHO, the best of the best. Those menus I’m showing are accessible by pressing the down arrow on a per movie basis (as it should be) and it should remember your settings so it’s once and done.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
20 Posts
Yes, Infuse is, IMHO, the best of the best. Those menus I’m showing are accessible by pressing the down arrow on a per movie basis (as it should be) and it should remember your settings so it’s once and done.
I saw those menus last time, but missed the "time offset" setting (too much wine as diner I guess :))
I just posted in Infuse topic to know if it is (or will be) possible to assign remote gesture or key to delay subtitle.
 

·
Registered
Joined
·
16,321 Posts
But don't you have "HDMI Control" turned off on your Yamaha? I do.
Yes I do. I have ARC/CEC (HDMI Control, etc) disabled on all of my devices. In fact, the only device that you can't disable CEC is on my new LG UBK90 blu-ray UHD player. However, with the receiver and tv disabled for ARC/CEC there aren't any issues when the UBK90 attempts to send a CEC command.
 

·
Registered
Joined
·
2,501 Posts
Yes I do. I have ARC/CEC (HDMI Control, etc) disabled on all of my devices. In fact, the only device that you can't disable CEC is on my new LG UBK90 blu-ray UHD player. However, with the receiver and tv disabled for ARC/CEC there aren't any issues when the UBK90 attempts to send a CEC command.
Yeah, that's what I expected. The guy you were replying to had CEC on to enable ARC I believe.
 

·
Registered
Joined
·
16,321 Posts
Yeah, that's what I expected. The guy you were replying to had CEC on to enable ARC I believe.
Ah, I missed that. Thanks. I'm hoping that with the newer tv's and players that have ARC and CEC separated from each other, that at least the ARC-related issues will go away (with the exception of distance) and we'll be just left with CEC issues, which are easily managed with the use of a Harmony remote. Or at least until CEC Extensions is fully implemented with HDMI 2.1.
 

·
Registered
Joined
·
1,475 Posts
I think these are split out in many devices already. Even my 4 year old Vizio in the guest room has them as separate "toggles".

Ah, I missed that. Thanks. I'm hoping that with the newer tv's and players that have ARC and CEC separated from each other, that at least the ARC-related issues will go away (with the exception of distance) and we'll be just left with CEC issues, which are easily managed with the use of a Harmony remote. Or at least until CEC Extensions is fully implemented with HDMI 2.1.
 

·
Registered
Joined
·
218 Posts
That is peculiar, and sounds like it's specific to your TV; so have you tried setting the ATV to Match Frame Rate=ON, and/or your TV's Cinemotion=OFF? I would think the way you should have it would be:
  • Match Frame Rate=ON in the ATV, and
  • Cinemotion=ON in the TV,
but I would try every possible combination, because who knows? (I would also try the "offical" thread for your particular TV)

HTH

I tried those settings as well and still the issue persists.
 

·
Registered
Joined
·
302 Posts
I've had my new ATV 4k for about a week, and it mostly works fine. However, when I choose to play an Amazon Prime title from the AppleTV app, I end up with a blank grey screen. If I first enter the Amazon app, the title plays as expected. Any suggestions would be appreciated. Thanks!
 

·
Registered
Joined
·
9,471 Posts
I've had my new ATV 4k for about a week, and it mostly works fine. However, when I choose to play an Amazon Prime title from the AppleTV app, I end up with a blank grey screen. If I first enter the Amazon app, the title plays as expected. Any suggestions would be appreciated. Thanks!
I had that today. I don't remember that ever happening before.

I think they will fix that quick ... it seems new.
 
19901 - 19920 of 30694 Posts
Top