AVS Forum banner

2541 - 2560 of 2801 Posts

·
Registered
B&W 805 D3, HTM2D3, Rotel RSP-1576MKII, RMB-1585, ARCAM AV40, PA720
Joined
·
301 Posts
After being fed up with the bugs on my Arcam AV40 and it still not properly working on channels 13/14 with DLBC, I had to return it today.

We are going to be without a processor so our theater will be down, but we just cannot take the inconsistent reliability anymore of this processor, despite getting a great deal on it.

To anyone who's considering Arcam, I would say if you have the patience for the new firmware updates and have an open mind with bugs/troubleshooting and you can get a great deal from a dealer like i did, it may be worth it.

For us, life is way too short so we are going to most likely go with the Monoprice HTP-1 since we love our reliable amp from them. It is currently backordered though. If we decide not to get that, then we will do the Marantz 8805, but we are leaning towards paying more for the Monoprice (HTP-1 is more for us because our dealer doesn't offer a discount for Monoprice but they offer one on the Marantz).

I truly hope Arcam works out the bugs for you guys and thanks for always replying to my concerns and remarks regarding my AV40.
Did you finally end up getting the Marantz?
 

·
Premium Member
Integra DTR40.3, Monitor Gold 60, Oppo, Xbox X, PS4 Pro, TIVO HD Premier and SONY 400 Mega Disc
Joined
·
11 Posts
What’s the current state of Dolby Atmos from AppleTV 4K with the Arcam AV40, I heard before there were issues where it wouldn’t play back? I now have a Rotel processor (1576 MKII w/ Dirac) but experiencing issues with the Atmos as well, no signal. 5.1 is fine when switched to that on AppleTV4k. Was considering going back to Arcam with the AV40 in mind.
So you have the NEW that was just announced? Its having Atmos problems ...WoW!! That is not a cheap unit. You would think that they could have gotten things corrected seeing where everyone else has fumbled.
 

·
Registered
Joined
·
1,528 Posts
Did you finally end up getting the Marantz?
I just went with the Monoprice HTP-1 so I could stick with Dirac. I just got it in the mail so hopefully it is worth the upgrade, especially in price over the Arcam AV40. The Monoprice HTP-1 was almost double the price of the Arcam because of Arcam's dealer pricing.
 

·
Registered
B&W 805 D3, HTM2D3, Rotel RSP-1576MKII, RMB-1585, ARCAM AV40, PA720
Joined
·
301 Posts
I just went with the Monoprice HTP-1 so I could stick with Dirac. I just got it in the mail so hopefully it is worth the upgrade, especially in price over the Arcam AV40 (got it around dealer price vs Monoprice retail).
PM’d you
 
  • Like
Reactions: iStorm

·
Registered
Joined
·
978 Posts
What’s the current state of Dolby Atmos from AppleTV 4K with the Arcam AV40, I heard before there were issues where it wouldn’t play back? I now have a Rotel processor (1576 MKII w/ Dirac) but experiencing issues with the Atmos as well, no signal. 5.1 is fine when switched to that on AppleTV4k. Was considering going back to Arcam with the AV40 in mind.
On the Arcam the current firmware has problem with Dolby Atmos

If you get a AV40 do not upgrade. Dolby Atmos will run fine on Apple TV with the Firmware the unit comes with.

When the next firmware is relased I would wait to upgrade. Hopefully someone here will be willing to be the guinea pig and let everyone know if the problems are fixed and the unit runs pretty much reliable.

Sent from my SM-F916U1 using Tapatalk
 

·
Premium Member
Joined
·
1,573 Posts
What’s the current state of Dolby Atmos from AppleTV 4K with the Arcam AV40, I heard before there were issues where it wouldn’t play back? I now have a Rotel processor (1576 MKII w/ Dirac) but experiencing issues with the Atmos as well, no signal. 5.1 is fine when switched to that on AppleTV4k. Was considering going back to Arcam with the AV40 in mind.
It's working well for me, with both Netflix and Disney+. I've only encountered the failure to lock on once, with firmware 1.40.
 

·
Registered
B&W 805 D3, HTM2D3, Rotel RSP-1576MKII, RMB-1585, ARCAM AV40, PA720
Joined
·
301 Posts
On the Arcam the current firmware has problem with Dolby Atmos

If you get a AV40 do not upgrade. Dolby Atmos will run fine on Apple TV with the Firmware the unit comes with.

When the next firmware is relased I would wait to upgrade. Hopefully someone here will be willing to be the guinea pig and let everyone know if the problems are fixed and the unit runs pretty much reliable.

Sent from my SM-F916U1 using Tapatalk
Now when you guys say there are issues with Atmos, what are they exactly? My issue right now with the Rotel RSP-1576MKII is that it shows "No audio" on the unit and there is 0 sound. I have to resort setting the ATV4k to DD5.1 to work. Now, I don't have atmos speakers presently, however, my previous receiver/amp which was an arcam still played dolby atmos just not in the height obviously. I called Rotel and TS'd with the tech connecting my surrounds to height to see if that would trigger it and no dice. So that's my dilemma, don't want to make it a Rotel topic in an Arcam thread but, I am considering the av40 so I want to know what I am getting into.
 

·
Registered
Joined
·
978 Posts
Now when you guys say there are issues with Atmos, what are they exactly? My issue right now with the Rotel RSP-1576MKII is that it shows "No audio" on the unit and there is 0 sound. I have to resort setting the ATV4k to DD5.1 to work. Now, I don't have atmos speakers presently, however, my previous receiver/amp which was an arcam still played dolby atmos just not in the height obviously. I called Rotel and TS'd with the tech connecting my surrounds to height to see if that would trigger it and no dice. So that's my dilemma, don't want to make it a Rotel topic in an Arcam thread but, I am considering the av40 so I want to know what I am getting into.
On the latest software 1.40 the unit will show Dolby Atmos and no sound comes out. The work around to to do a rewind and then play. That will bring sound back.

On firmware 1.36 it shows Dolby Atmos and sound comes out right away


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
649 Posts
For those that recently sold and/or bought an AV40, can you send me a PM with what you’d think a reasonable price would be to sell mine? (Not asking for offers, just what people think based off current experience)

It’s used but is in great physical condition, I have the original packaging, all accessories and I’d transfer over my full DLBC account to the buyer.

Trying to figure what it would cost me going to a new processor. Thanks in advance.
Curious if you’re going to jump up to the JBL 75 you mentioned earlier. Your subwoofer section is really impressive. Seaton’s as near-field? That has to be impressive.
 

·
Registered
Joined
·
2,356 Posts
Curious if you’re going to jump up to the JBL 75 you mentioned earlier. Your subwoofer section is really impressive. Seaton’s as near-field? That has to be impressive.
Thanks.

I’m looking at a different direction. My dealer was willing to work with me on an SDP-75, but I still have a hesitation to spend that much on a pre/pro.

(Read: wife saw the price tag and smacked some sense into me)
 

·
Premium Member
Joined
·
649 Posts
Thanks.

I’m looking at a different direction. My dealer was willing to work with me on an SDP-75, but I still have a hesitation to spend that much on a pre/pro.

(Read: wife saw the price tag and smacked some sense into me)
Ha! Totally understandable! I’ll be curious to see which direction you go.
 
  • Like
Reactions: Snowmanick

·
Registered
B&W 805 D3, HTM2D3, Rotel RSP-1576MKII, RMB-1585, ARCAM AV40, PA720
Joined
·
301 Posts
(Like tommarra with his MRX720 I found the Arcam better sounding than my Anthem MRX1120. I had an HTP-1 here in February, and just couldn't get on with the volume control. From what I've read, that still hasn't changed. Most owners don't find it an issue though, but was just a show stopper for me)
What about the HTP-1 and volume control? Haven‘t been able to find anything on that
 

·
Premium Member
Joined
·
1,573 Posts
What about the HTP-1 and volume control? Haven‘t been able to find anything on that
I posted about it in the HTP-1 thread back in Feb/March. The response of the physical knob was very slow, and if you turned it faster (not even that fast) it would read the direction wrong and turn the volume down rather than up. Based on a recent post in the HTP-1 thread by Markus, this still isn't fixed. At the time, the web interface volume control wasn't stable either, but that has been fixed. It was just something I couldn't live with, others haven't been particularly bothered by it.
 

·
Registered
Joined
·
978 Posts
I cant decide between HTP1 and AV40...I do have 4 subs and plan on using DLBC..
Right now the Arcam does not do DLBC correctly. In fact one poster is selling his AV40 because of bugs. Hopefully the next firmware update will fix the problem without introducing new bugs. The good thing about Arcam is that you can go backwards with Firmware.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,443 Posts
I just went with the Monoprice HTP-1 so I could stick with Dirac. I just got it in the mail so hopefully it is worth the upgrade, especially in price over the Arcam AV40. The Monoprice HTP-1 was almost double the price of the Arcam because of Arcam's dealer pricing.
Dealer pricing never cease to amaze. Isn't the AV40 supposed to be like 4-5K? And yet you say it's 1/2 price from HTP-1.
I cant decide between HTP1 and AV40...I do have 4 subs and plan on using DLBC..
Wait at least until the next firmware update to see if it's getting close to functional for what you need. Note the above if you do take that turn.
 

·
Registered
Joined
·
1,223 Posts
Right now the Arcam does not do DLBC correctly. In fact one poster is selling his AV40 because of bugs. Hopefully the next firmware update will fix the problem without introducing new bugs. The good thing about Arcam is that you can go backwards with Firmware.
Any specifics on how DLBC is broken with 1.40?

I am running an AVR30 / DLBC with four subs currently.
 
2541 - 2560 of 2801 Posts
Top