AVS Forum banner

621 - 640 of 2063 Posts

·
Registered
Joined
·
12 Posts
I was having a look at the competition the other day, and saw that NAD also announced a new receiver due to be released before the end of 2019, the T-778.

However, this has been delayed by a couple of months and as far as I'm aware is still not yet available. Interestingly, this also includes Dirac, but its release has been postponed until about the same time as the Dirac module is available for the Arcams.

So I wonder if the cause of the Dirac delay is Dirac itself, and not a fault of Arcam's.

Obviously different strategies between NAD and Arcam, in terms of releasing their hardware as advertised, or while still not feature-complete. Arcam clearly getting a lot of stick for releasing an unstable and incomplete product, whereas I would have thought NAD's strategy would increase expectations and interest. Still, don't see anywhere near as much activity on similar threads dedicated to the NAD receivers.

Personally, although I am really enjoying my AV20, if my dealer allowed it, I'd return my Arcam for the NAD, purely to keep the wife happy, as the NAD unit is smaller and would presumably be a better fit in our cabinet.
Also looking foward to see a test between the new NAD and Arcam AVR's.
 

·
Registered
Joined
·
3,648 Posts
Has anyone noticed that CEC control no longer works in the v95 firmware? After updating, my Apple TV 4K no longer turns off the receiver and TV and the option to set it to do so is grayed out. I believe this is because the Trashcam is somehow preventing CEC control. With CEC control enabled on the Trashcam, it worked fine before the update. Now it doesn't.
Works fine for me with a Samsung TV and V0.95.
 

·
Registered
Joined
·
3,648 Posts
CEC/ARC has not been working for me with previous & current firmware (0.95). I'm using a Samsung Q950R TV and had to resort to using optical
I'm not using ARC. The original poster said CEC wasn't working; CEC is working for me.
 

·
Registered
Joined
·
878 Posts
Discussion Starter #626
Anyone with an AVR10/20/30 that could comment on this:

* Does the unit get hot when idle vs normal usage? Fan ever running?
* Is the boot up time fast?
* What speakers are you using with the AVR, and do you think the AVR is sufficient to drive them?

Feel free to answer any or all of the questions. :)
 

·
Premium Member
Joined
·
6,344 Posts
Anyone with an AVR10/20/30 that could comment on this:

* Does the unit get hot when idle vs normal usage? Fan ever running?
* Is the boot up time fast?
* What speakers are you using with the AVR, and do you think the AVR is sufficient to drive them?

Feel free to answer any or all of the questions. :)
Don't own the Arcam yet but I have checked on them a few times at Best Buy/Magnolia and boot time is like any Denon/Marantz receiver. On Best Buy they are inside a RACK without any ventilation and they run very hot, same as any Denon/Marantz. I'm planing on using the same AIRCOM T10 I have on my Marantz SR6013 and Denon X6500H. Right now all my 7 floor speakers are driven by external amps and the ceiling speakers with the receiver. I'm planing on doing the same with the ARCAM. But because you can not assign internal amps for the 4 ceiling speakers, I'm planing on driving surround and rears with the ARCAM and ceiling with external amps.
 

·
Registered
Joined
·
2,336 Posts
Anyone with an AVR10/20/30 that could comment on this:

* Does the unit get hot when idle vs normal usage? Fan ever running?
* Is the boot up time fast?
* What speakers are you using with the AVR, and do you think the AVR is sufficient to drive them?

Feel free to answer any or all of the questions. :)
I have an AV40, so I can only address the second items. The n my system the AV40 is slower to boot up and send audio to the amps than my previous receiver, a Denon AVR-X7200WA. That said, it’s not an issue and you get used to it fast. I have had processors in the past that took much longer and my JVC pj can drive me nuts at times.
 

·
Registered
Joined
·
1,115 Posts
I cringed when he said he bought it so he can tell the truth. Would he have lied if he got a sample directly from the vendor?
This is exactly the first thought that occurred to me, too, SteveH. I've never found Shane particularly credible or informed, but that statement waved all kinds of red flags for me.
 

·
Registered
Joined
·
1,280 Posts
I suspect that Audiocontrol and JBL are going to hold the release until firmware is stable and most of the bugs are ironed out. The day both start shipping their versions will be the day to buy Arcam too IMO.
 
  • Like
Reactions: Geronimo.USMC

·
Registered
Joined
·
4,550 Posts
I suspect that Audiocontrol and JBL are going to hold the release until firmware is stable and most of the bugs are ironed out. The day both start shipping their versions will be the day to buy Arcam too IMO.
I have been told the SDP 55 are on a ship to the U.S. So I believe they are up for pre-order and will be available once they physically are in the warehouse for distribution. I also am under the impression the JBL will force a firmware update when you first plug it in so it will be on the most current firmware available once they get into user hands.
 

·
Registered
Joined
·
23 Posts
I'm not using ARC. The original poster said CEC wasn't working; CEC is working for me.
I can confirm ARC and CEC work with Samsung QR95. My AVR20 switch correctly from NET to Display when a signal is detected. It outputs a Dobly Digital + Signal when playing an Atmos Netflix source (I do not have Atmos speaker currently, so feature or bug I cannot say).
 

·
Registered
Joined
·
16 Posts
I can confirm ARC and CEC work with Samsung QR95. My AVR20 switch correctly from NET to Display when a signal is detected. It outputs a Dobly Digital + Signal when playing an Atmos Netflix source (I do not have Atmos speaker currently, so feature or bug I cannot say).

It was working for me initially (fresh from the box). Then it suddenly stopped and I've not been able to get it working since (despite a new firmware on both the AVR20 and the Q950R)


:(
 

·
Registered
Joined
·
3,648 Posts
I can confirm ARC and CEC work with Samsung QR95. My AVR20 switch correctly from NET to Display when a signal is detected. It outputs a Dobly Digital + Signal when playing an Atmos Netflix source (I do not have Atmos speaker currently, so feature or bug I cannot say).
Do you have any dropouts when trying to play Witcher Season 1 Atmos or The Irishman? I seem to suffer dropouts on just a few titles consistently, the vast majority of Atmos Netflix titles work perfectly.
 

·
Registered
Joined
·
49 Posts
Hmmmm . . . I’m not even sure how to accurately describe my latest issues on V95. I have an Apple TV 4K into the Arcam AVR30 and then into a Sony A9G. When switching around apps on Apple TV, sometimes the video portion of the signal will drop out. I won’t be able to get the video to reappear without turning the Arcam off and on again. This wasn’t happening with V89.

Even stranger is that I’ll have lip sync issues on an Atmos show like Peaky Blinders (Netflix), then switch to another Atmos show on Apple TV+ (For All Mankind) and the lip sync will be perfect. Then, I powered the Arcam off and on again and Peaky Blinders is perfectly synced while For All Mankind is a little off.

And I can’t for the life of me figure out what happened to CEC control. It was working fine with V89.
 
621 - 640 of 2063 Posts
Top