AVS Forum banner
Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter · #1 ·
argggg. I dunno where else to post this so if anyone knows of a better forum to post this, please let me know.


So I got an Asus tv tuner a while ago and when I first installed it, everything worked fine. But after a while, for some reason it stopped tuning into channel 2 (CBS). I could get SOME vague bits of audio, but mostly it was noise. I tried changing tv tuner drivers, manually adjusting the chan. frequency, etc. but I never got it back. So eventually I let it go.


But, just recently I downloaded dscaler and was fiddling around with it, when I noticed it would tune channel 2! This gave me hope that I could get other programs to tune it properly. But I don't know how! Why would dcsaler be any different?


Thanks for any help!

Ed
 

·
Registered
Joined
·
4,484 Posts
Dscaler has a great auto configure feature that scans the hardware so that it works correctly, maybe it sees your hardware correctly and your other software is either corrupt or out of date? No clue why though.


Jim
 

·
Registered
Joined
·
1,230 Posts
Dscaler bypasses the drivers which is probably a clue. Try your best to cleanly uninstall the drivers and start fresh and that might set you straight.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #4 ·
thanks guys, I'll give the driver reinstall thing another shot.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #5 ·
ok well I know it's been over a month since my last post, but I'm still having the same problem. And to make it worse, the same thing happens on my new ATI e-home wonder!


*sigh* Can someone PLEASE PLEASE help me? I don't understand why two completely different cards would be unable to tune this one channel!
 

·
Registered
Joined
·
529 Posts
Well, if you mentioned whether it was NTSC or PAL (or vaguely specified your location), which OS was in play, the level of DirectX, whether it was OTA or wire-feed, perhaps there would be something on which to work.


But if you are NTSC, DirectX9.0b, using cable and have applied hotfix KB825116 (which was for everybody but NTSC-M), that'll do it. (Tell the tuner driver interface it's being fed from air and CH2 should pop up, but of course you lose the high-end channels).


If so, you need to restore kstvtune.ax from prior to that hotfix.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #7 ·
Keh, that sound suspiciously accurate. I'll try it out
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #8 ·
hmm. didn't work. I tried applying one of MS's hotfixs (KB825116), that didn't help. I also tried replacing all my KSTVTUNE.AX files with the dx9.0a version, that didn't work. Switching my feed from CABLE to ANTENNA just took away all my channels. I'm going to try removing dx9 and reinstalling dx8.1b..


I'm in Los Angeles, using NTSC-M,

WinXP Pro w/ Sp1a

Comcast analog cable
 

·
Registered
Joined
·
529 Posts
Oops, guess I wasn't clear...


NTSC-M (North America) users do not need nor want to apply hotfix KB825116 - that's the cause of the problem. (It installs ver 5.3.1.903 of kstvtune.ax; you want to get back to ver 5.3.1.902.)


When I said that a workaround was to switch to air, I meant that you call up the filter interface for your capture card's tuner (I use Media Player Classic to get at it) and tell it that the input feed is air, not make any actual connection changes.


I'd first do a search on kstvtune.ax and see if there is a 5.3.1.902 version squirreled away somewhere. If so, just copy it to the system32 sub-directory.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #10 ·
hmm, ok. Well, lucky for me I found version 5.3.1.902 on my laptop at work. So I'll try that later after work...


Regarding the CABLE/ANT thing, in my PVR program (I was using GotTV at the time) I was telling it the source was "ANT" when I was autotuning. Is that what you ment?
 

·
Registered
Joined
·
529 Posts
Ant = Air


But I was refering to the tuner filter's UI, not one in a player. (Media Player Classic simply allows one to access the UI's for whatever filters have been linked into the chain.) Another way to approach this is to use Graphedit and load in the tuner filter (under WDM Streaming TV Tuner Devices).


If I understand things, the kstvtune.ax has gobs of frequency tables (not all correct), but some players can create 'override' values in the registry, while others simply use what is there and just test to see if a signal exists.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #12 ·
KSTVTUNE.AX 5.3.1.902 didn't work... How do I get to the tuner filter's menu in media player?


What I don't get is, why am I the only one with this problem? It seems like a driver problem, so why aren't more people posting problems like this?


Thanks for all your help so far Keh
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #13 ·
I don't believe this has to do with noise from the PC. As mentioned above, when I use dscaler, I am able to tune channel 2 perfectly. And I USED to be able to tune channel 2 when I first setup my HTPC. But since then, even after a few HD formats and Windows reinstalls, I can't get it to work. I think it's a software thing, but I just have no idea where to look or what to do about it.
 

·
Registered
Joined
·
529 Posts
Well, most people read the notes and bypassed the hotfix. Of the rest, like myself, who blithely thought 'newer is better', most very quickly discovered CH2's disappearance and backed the hotfix out.


Actually, there is one 'all-fixes upgrade' package that a website puts out monthly that includes this little NTSC disaster without checking the users country code.


Reverting to 902 should have fixed things, unless a version in a location other than system32 has been registered, or your player has picked up the invalid frequency table entry and stuffed it in as a registry override.


Register the 902 version and do an autoscan from the filter's UI. Then tell your player to autoscan if necessary.


Media Player Classic http://sourceforge.net/projects/guliverkli/ isn't a M$ program. It's main virtue here is that it is a brain-dead install (just extract it to a directory of your choosing) and it gives access to the filters. Run the program, click 'file', click 'open device', select your capture (tuner) card. Don't worry about the resultant image or sound, simply right-click on the image to get a drop-down menu, place your cursor on 'filters' to get the sub-menu (which is a list of the directshow filters that have been linked in reverse order, and the tuner filter should be at the bottom). Click on it to get the filter's UI.
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #15 ·
ok. This is what I tried the other night which (of course) didn't work...


I basically followed the instructions given here http://www.snapstream.com/community/...s/customorder/

The instructions explain how to override your channel frequencies by editting your registry.


My Comcrap cable system uses HRC frequencies, though. So I had to manually enter the frequencies from a table I found here: http://www.jneuhaus.com/fccindex/cablech.html


ok. So I did that, went to my PVR software (GotTVPVR) and autoscanned. Every channel showed the frequency override that I entered, EXCEPT CHANNEL 2.


Channel 2 shows some random frequency (52.7 Mhz or something like that), when it SHOULD be 54 Mhz.


I've also tried using GotTV to manually enter a channel with 54Mhz as its frequency and for some reason that doesn't tune properly.


I think I'll try some more registry fiddling (maybe delete the entire tree so no overriding is going on) to see if I can get the frequency for channel 2 to override properly. If that doesn't work, I have a spare harddrive that I try a fresh install on... oh yeah, and if I do reinstall, I'll be sure NOT TO INSTALL DX9.0b :p
 

·
Registered
Joined
·
529 Posts
Are you certain that you've restored 902 (file size ~ 268KB) and removed all evidence of 903 (file size ~275KB)?


Did you get to the filter's UI and switch to air?
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top