AVS Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I was using on-board 780g AMD graphics for a while and had a great HD picture quality on Panasonic plasma. I decided to upgrade to XPS-5670 board, to speed up gaming, but the factory-default video PQ on the 5670 look very pale and bleak, like a budget LCD of old days. I did not change the driver or anything. I tried playing around with brightness/contrast in catalyst, but could not get as good PQ as with on-board chip. Is there something wrong with the board itself, or I need o use some tuning procedure? I'm using DVI->HDMI cable for both boards.
 

·
Registered
Joined
·
7,654 Posts
You should always change the driver when installing a new card. Ati=>Ati or not. Not saying it will for sure fix it. But thats the first thing to do.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·

Quote:
Originally Posted by whiteboy714 /forum/post/19630403


You should always change the driver when installing a new card. Ati=>Ati or not. Not saying it will for sure fix it. But thats the first thing to do.

I don't understand what do you mean by "change the driver". I have the latest catalyst v. 10.11. Change it to what?
 

·
Registered
Joined
·
2,256 Posts
The default ATI settings from 10.7 and up are messed up. Disable those "image enhancement" settings like Flesh Tone correction and most importantly, Dynamic Contrast.
 

·
Registered
Joined
·
270 Posts

Quote:
Originally Posted by UncleV /forum/post/19630503


I don't understand what do you mean by "change the driver". I have the latest catalyst v. 10.11. Change it to what?

u might want to use driver sweeper and then update your driver. or if you are running surround view you still want to download this driver....

http://sites.amd.com/us/game/downloa...n_win7-32.aspx


the onboard igp drivers are different than the discrete gpu drivers.
 

·
Registered
Joined
·
270 Posts

Quote:
Originally Posted by GreenEyez /forum/post/19630526


The default ATI settings from 10.7 and up are messed up. Disable those "image enhancement" settings like Flesh Tone correction and most importantly, Dynamic Contrast.

thanks for this. immediate improvement on my setup.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·

Quote:
Originally Posted by GreenEyez /forum/post/19630526


The default ATI settings from 10.7 and up are messed up. Disable those "image enhancement" settings like Flesh Tone correction and most importantly, Dynamic Contrast.

Thanks, that seems to help quite a bit, although the PQ is still kind of "flat". I noticed that 3200 does not seems to have as many "enhancement" options.
 

·
Registered
Joined
·
3,801 Posts

Quote:
Originally Posted by GreenEyez /forum/post/19630526


The default ATI settings from 10.7 and up are messed up. Disable those "image enhancement" settings like Flesh Tone correction and most importantly, Dynamic Contrast.

Where do you change those? On my CCC, I don't see any of those options...
 

·
Registered
Joined
·
819 Posts
Some of these are under Video - All settings. I don't know where Pixel Format is now, in the new CCC - switched to Nvidia on the HTPC - but should be under Desktops&Displays, right click on bottom icon of tv, Configure.
 

·
Registered
Joined
·
2,256 Posts
Also, try changing the Dinamic range to 0-255, that solves 99% of the washed out collor issues (i presume that was what you were talking about when you said "flat image")
 
1 - 12 of 12 Posts
Top