AVS Forum banner
1 - 4 of 4 Posts

2,495 Posts
Discussion Starter · #1 ·
Okay bit of background...

Used to have an ATi HD 4830 in my main HTPC which crapped out (started getting artifacts with HA on when playing videos, as well as in other 2D content). So I RMA'd the card with XFX.

Now in the meantime I had an HD 5670 in my other HTPC (which is hardly ever used) so I decided while the 4830 was out, I'd put in the 5670. Now my Catalyst drivers were pretty old on the HTPC with the 4830 (everything worked I had no reason to update them really) so I figured the old drivers were not going to support the 5670 so I just uninstalled them before I removed the 4830.

Popped in the 5670 and installed the latest drivers. Everything worked fine but when I tried TMT3 (I have both 3 and 5) I was getting horrible stuttering on playback with audio out set to HDMI - Mix to PCM uncompressed (my receiver only supports LPCM at best) also when stopping playback I got this horrible static noise through my receiver (see below). When I switched it to send the DTS core or to DD or pretty much anything else, playback was fine.

So then I tried TMT5 and it worked fine (no stuttering)--or so I thought. As soon as I pause or skip a chapter or do anything to interrupt the audio stream, when the audio resumes (unpausing for example) I got this extremely loud (like 0dB level?) static/white noise blasted through all the speakers!
Again, switching to any other format worked, but there was a serious problem with LPCM over HDMI.

I tried swapping to Realtek's version of the HDMI driver, to no avail. Chalking it up to some driver issue, I just left it and said I'd deal with it when I got the replacement for the 4830. I just didn't bother using the HTPC for BD playback for the time being.

Fast Forward to this week when I got the return from XFX...

XFX sent me a 6750 to replace my defective 4830. Would have been nicer if they gave me a 6770 lol, but hey the 6750 is faster than and uses a lot less power than my old 4830; not to mention the 6750 is physically a lot smaller too. As everyone knows the 6750/6770 are just 5750/5770 cards with newer BIOS (to support BD3D and whatnot).

So I get around to installing this card (I again removed the drivers when I took out the 5670 as AMD had one revision newer now).

Well guess what? Same exact problem. This time I tried about everything you can think of, and NOTHING has solved the problem

I found this thread (among others on google):

But there's no solution there. This seems to be a somewhat common problem but I can't't find the fix for it. Anyone know what is going on here and how you fix it?

2,495 Posts
Discussion Starter · #2 ·
Sorry to post again but the new forum annoyingly scrolls my screen involuntarily when the message gets so long (can't see what I'm typing), so this is just a post to list some of what I've tried:

(Computer is using Windows 7 SP1 btw.)

-Tried disabling the on-board audio (both digital and analog outs). Problem persists.

-Tried changing every driver setting you can think of. What I found is if I disable exclusive mode (i.e. WASAPI) on the HDMI output, it does eliminate the problem. However it creates two other problems!

One is that the audio gets down/up sampled to whatever the driver is set at for default output and doesn't use PAP I'm assuming (I'm thinking this is what it *always* did with the 4830 because I don't think it supported un-resampled output?). That one is not a big deal. However what is a big deal is the other problem.

The other problem is when I do that, for some unknown reason, it does NOT send the LFE signal (clearly the sub isn't outputting anything and the LFE level indicator on the receiver shows no activity). I have no idea why it does that because it never happened with the 4830. Disabling exclusive mode also prohibits me from using WASAPI streaming when using an audio player and playing [2ch] music (which I do quite a lot from this machine).

-Then I tried changing the HDMI driver up, thinking that if I tried an older version it would work right since I never had any problems with the 4830, audio-wise. I think the latest one is Realtek 2.67 or something. Went back to the driver before (Realtek 2.55) and nothing. Luckily I still had my old HDD with my OS intact, from before I switched to an SSD. So I looked up what driver version I had on the files on that drive (which would be what I had with the 4830 in there). So I went back to that driver (which was the one before 2.55). Again THE SAME STUPID PROBLEM!!!

I don't get it...it can clearly playback the audio fine, so where does this moronic pause problem come from?
When I pause, the audio stops (as it should) but then unpausing it's the horrid noise and then you can't recover from that until you either re-start TMT or switch the audio output type up (but you can't go back to LPCM anyway or it's the dumb noise again).

So at this point I think I've tried just about everything I can think of. Changed drivers, changed every setting imaginable in TMT and Windows, disabled this and that...I even tried using the ATi DVI-HDMI adapter I was using with the 4830 (because it didn't have a native HDMI port) on the DVI port of the 6750, and the audio behaviour is exactly the same. In summary BD playback in TMT3 is totally broken (stuttering) and it's nearly useless in TMT5 (loud noise)...all from going from a 4xxx series to a 5xxx series.

I've seen this referred to as the "pause bug" in a few threads I've searched, but nobody seems to have posted a solution? I'm hoping someone else here has been able to fix the problem? Any help would be appreciated!

2,495 Posts
Discussion Starter · #4 ·

Originally Posted by Nimo  /t/1416025/ati-amd-hd-5xxx-stupid-l...pon-pause-in-tmt-is-there-a-fix#post_22138993

Have you tried the ATi audio driver that came with the video drivers?
Yeah, those were the ones that installed automatically with the ATi (AMD) drivers.

So now that I've wasted my Saturday with this, lol...After a few more hours of playing with it I did find that disabling exclusive mode worked and the LFE was in there properly (have no idea why it was dead before, but it was working just a little while ago when I tried again).

So I can live with that (as I said above that's what it seems my 4830 was doing anyway--not using WASAPI for multi-LPCM output). But this brings me to the other problem above still... That is, I do still require WASAPI streaming for another application.

So now what I need to do really is be able to stop TMT 5 from using exclusive mode/WASAPI even when it is checked in the device properties page. In other words I need it to act like it did when I had a 4830. If anyone has any idea how to do that, I'm all ears. I asked the same question on the Arcsoft forum just now, see if anyone there knows.

I tried using ReClock but that was no help really. What I did find was that if I set ReClock to use DirectSound, that TMT oddly would only send it 2ch audio! I actually think that may be the source of the stupid white noise--I think TMT tries to send 2ch PCM to the receiver after it pauses, and the receiver is still "expecting" a 6ch stream?

Anyway looks like all I need to do now is find away to get TMT to use DirectSound, which may be easier said than done. It's going to be pretty ghetto having to switch exclusive mode on and off for movies and music--that kind of defeats one of the advantages of WASAPI streaming to begin with!
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.