AVS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi, I have a problem where the sound from the receiver disappears when I turn off my tv. My pc is plugged into a Onkyo receiver with HDMI and the receiver into a TV with HDMI, the PC is also plugged into a monitor with VGA. I use the TV for movies, only the receiver for music and the VGA monitor for everything else. I get 8 channel Dolby Digital when my tv and receiver is on and I'm playing a movie. When I play music it changes to 2.0 channel PCM. When I turn the tv off (with the receiver still on) it says 2.0 channel analog but there is NO sound at all.
I have uses the exact setup with my old laptop without problems. Both my laptop, blu ray player, usb device works without problem (2.0 PCM).
I have contacted both MSI and ONKYO with zero results... Been speaking with them for 1 week, really bad support. Onkyo stopped replying and MSI asked questions I already had answered and then advised me to buy a GPU and test.

I want to listen too music without having to turn on my tv.

My setup:
MSI gaming 5 motherboard
Intel i7 4790K CPU
Windows 8.1 PRO
For the moment no GPU or soundcard.
Onkyo TX-NR515

Update: I updated som drivers and now the PC can't find the receiver at all if the TV is off. It's just blank space in Audio device. The input in the reciever now says Unkown isntead of analog when the tv is off.

I have taken some screenshots: The first pictures is my new PC with the tv on. The second with the tv off. The third with my old laptop.
 

Attachments

·
Moderator
Joined
·
23,017 Posts
It seems the PC thinks there's no HDMI target once the TV is turned off. Most likely 2.0 analog is the default audio "assumption" the receiver displays. Try turning "off" the HDMI Control (RHID) function on the receiver is it's not "off" already. Is your laptop running Windows 8.1 Pro also?

Edit: I just looked at your attachments. It appears the PC is detecting the TV as the HDMI target and not the receiver since there's no hidef audio configured. This matches with what I said above. Some A/V processors and receivers have the ability to pass HDMI "settings" of the processor/receiver back to the HDMI source device or a HDMI display device connected to the processor/receiver. You want the PC to see the receiver HDMI "settings". Turning "off" RHID is the closest thing I could find in your receiver's manual that might force this to happen.

larry
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Hi Larry, many thanks for taking your time. I just checked and the RHID is already turned off. The laptop uses Windows 8.1 (not pro).
But your description to the problem seems like the most logical one.

Robin
 

·
Moderator
Joined
·
23,017 Posts
Hi Larry, many thanks for taking your time. I just checked and the RHID is already turned off. The laptop uses Windows 8.1 (not pro).
But your description to the problem seems like the most logical one.

Robin
Oh, well. Try turning it on. :) A simple thing to try compared to finding some combination of Windows settings that may or may not exist. It's most likely some issue on the PC. Does the PC have an optical or coax output for audio only use? If you don't listen to hirez multichannel music you won't be limited. However I'm not sure how Windows deals with multiple audio setups unless the music player can do the right thing.

larry
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Sadly it didn't help. It's a weird and annoying problem. I don't have optical or coax output. I'm gonna try and see if Windows support have any suggestion. But I have google around alot without finding anyone with the same problem :S
 

·
Registered
Joined
·
11,183 Posts
It's a common problem. Welcome to the world of HDMI.
My TV has a "picture off" setting that I use for playback from my HTPC.
Unless my wife wants to watch the visualizations.
:)
Michael
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Heey my tv had a "Picture off" setting to. That's a diffrent approach to the problem. It dosn't have a fast button for picture off, I have to go thru the settings. But it works.
 
1 - 9 of 9 Posts
Top