AVS Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter · #1 ·
Hi,


I could need some help with the Auzentech Prelude 7.1 drivers!

The driver package over at auzentech.com is out-of-date, sadly but true



There was not that hard to get the updated DTS / Dolby Live / Creative Audio Console etc.. All I needed to do was downloading the latest packages over at Creative.com, un-rar them and add them into the Auzentech driver package, over-writing the existing files located there..


But the driver itself was a bit more tricky, there has been release at least one, if not two driver updates for the Creative X-Fi sound cards that are newer then the current one listed on the Auzentech web-page, and as we all know the Auzentech Prelude and the Creative X-Fi sound cards basicly use the same driver..


So what's needed for making the latest drivers listed at Creative.com to work with the Prelude? I guess it's just a matter of editing the *.inf files and something like that, the same way as you get newer GeForce drivers to work with unsupported GeForce graphic cards. Unfortunately I did manage to do this myself so I hoped someone could help me out with this one!


Ant tip on how to pull this off?

The reason I need the latest drivers is because they are simply superior to the older ones within the Auzentech driver package along with the latest drivers actually working with Windows7 BETA1!


The older drivers included in the Auzentech driver package do install on Windows7, but I'm stuck with Entertainment Mode only and a maximum of 2.1 / 3.1 sound, with the latest Creative drivers it's been confirmed that all the different audio modes is working, along with the 5.1 / 7.1 mode works as it should (which it obviously doesn't with the older driver from Auzentech)


That's why it's rather crucial for me to get the newer Creative drivers to work with the Prelude



I guess when Creative releases a official Win7 driver, it will take ages before Auzentech make a new driver package, if they ever will?
 

·
Registered
Joined
·
4,981 Posts
If you find a solution...post here. Mine doesn't work with DD LIve or DTS connect via SPDIF at all with Win7 beta. It does work with XP. With Win7 it does not see the card even being there...no SPDIF connection. Didn't try anolog tho.
 

·
Registered
Joined
·
163 Posts
Discussion Starter · #4 ·
Tried to contact them without any luck so far


Where do I sign up for that BETA-program?
 

·
Guest
Joined
·
471 Posts

Quote:
Originally Posted by RamGuy /forum/post/15545913


Tried to contact them without any luck so far


Where do I sign up for that BETA-program?

Their support staff is on the slow side in my experience also. It took them almost a week to reply saying I had a known issue and to wait for the next driver release... sigh


Unfortunately, you can only get beta drivers by registering. When you go to the driver download page, on the right side it says "However, if you do register , you can receive News and Updates as soon as they are available."


Since I last look a few months ago, it seems like they changed the wording a bit. It used to specifically say to get beta drivers you had to register.
 
1 - 5 of 5 Posts
Top