AVS Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter · #1 ·
I have had my 307 for 2 years with no problems.


My center and right front channels have gone silent. Once and a while I can switch inputs or surround modes and they will work normally However, most of the time they are not working. Has anyone experienced this problem?


Does anyone know if I can fix this on my own?


What is B&K's turnaround for a warranty issue?
 

·
Registered
Joined
·
197 Posts
Ive never had this problem. I sent my 307 in to replace a bad video board and got it back in 2-3 weeks, not bad. I doubt you could fix it unless you had any spare B&K parts layin around. Sounds like you have a processor problem if the amp works in some modes and not others.
 

·
Registered
Joined
·
2,689 Posts
Sounds like something that B&K should look at.


I'd contact them and arrange for service. If it is in the budget, send $499 along with the receiver and have them do the '507' upgrade as well.
 

·
Registered
Joined
·
364 Posts
Discussion Starter · #4 ·
Thanks guys. I will call for a RA number in the morning. Out of curiosity... how is the upgrade? Is it worth it? Can you tell the difference with the new DACs? Is DTS ES discrete a big improvement of matrix ES? I heard that B&K upgrade disables the red indicator on the right of the display showing DTS or Dolby Digital is this true? Any comments would be appreciated.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top