AVS Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
I updated my Samsung BD-P1000 from 1.1 to 1.4 today and the center channel is gone. Is there anywhere I can download the 1.3 firmware?


Thanks

Mike
 

·
Registered
Joined
·
6,213 Posts

Quote:
Originally Posted by brez /forum/post/13017502


I updated my Samsung BD-P1000 from 1.1 to 1.4 today and the center channel is gone. Is there anywhere I can download the 1.3 firmware?


Thanks

Mike

Did you go back through your setup menus after performing the install?
 

·
Registered
Joined
·
1,025 Posts

Quote:
Originally Posted by TrevorS /forum/post/13030035


Did you go back through your setup menus after performing the install?

Trevor's right. You need to completely reset all your options after performing an update. The unit automatically resets to "default" on all parameters. I learned this after having the same kind of oh-**** experience.


Lee
 

·
Registered
Joined
·
104 Posts
Discussion Starter #4
Trevor, Lee,


I went through the setup after The firmware update, still no center chanel. Is there any place I can get the 1.3 update?


Thanks

Mike
 

·
Registered
Joined
·
1,805 Posts
I still have the file on my hard drive. If you want I can try to email it to you as a download or if that doesn't work, send you the disc.
 

·
Registered
Joined
·
141 Posts
Please let us know how this works for you. I have a BD-P1000 and have not loaded the latest update yet.


How do you roll back the firmware? Do you have to reset the player to factory settings first?


Thanks,
 

·
Registered
Joined
·
1 Posts
I have this same issue. Any positive results?

Here's what I wrote at DVDTown and High Def Digest:


I upgraded my firmware to the latest (v. 1/4) a few days ago. Now, I am having playback issues on a few discs--namely "3:10 to Yuma", which played fine a few days before the upgrade. Now the bottom of the video is on the top and the top is on the bottom. The disc works perfectly once every six or seven times I put the disc in. Odd.


Also, all discs with uncompressed PCM mixes are messed up when sent through bitstream (never had this issue before). The front channels are in the back and back channels are in the front. I reset everything and even reinstalled the firmware and still had the issue. I can only assume they are the result of a bug in the firmware.


I called Samsung about the bugs, but I got an annoying hour-long run-around as no one there seemed to know what the heck I was talking about. One of the techs didn't even know what "3:10 to Yuma" was. He was like "3, 2, 1, Yeah?" I was supposed to get transfered to a high-level tech, but it never happened. I was hung up on every time.


If someone knows a better way to report the bug (a direct phone number, website or email link), let me know. I'd love to call and report it directly to someone who actually knows what the heck firmware is (most of the tech support "techs" had no idea what firmware was!?!).


I love the BD-P1000 and this is really the first time I've had an issue with that player (I bought the player 'used' so I didn't live though the initial playback issues with the player). At least I've got my PS3 to fall back on. It's my main player, but I still have a fondness for this set top player.


I've heard a few insider rumblings that this firmware wasn't so hot, but has anyone else experiencing issues like this with their firmware update?


Let me know....
 

·
Registered
Joined
·
141 Posts
Hi All,


I noticed that Samsung has a new firmware version 1.5 (updated 02/28/08).


Has anyone tried to load this update?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #10

Quote:
Originally Posted by badboi /forum/post/13043353


I still have the file on my hard drive. If you want I can try to email it to you as a download or if that doesn't work, send you the disc.


badboi,


I sent the BD-P1000 in to be repaired. I'll see when it comes back. I have a second BD-P1000 that is using firmware 1.1. I haven't used it for over a year, I'll see how it goes. I may still need the 1.3 if you can send it, Ill let you know.


Thanks

Mike
 

·
Registered
Joined
·
4,182 Posts

Quote:
Originally Posted by bbibb /forum/post/13263426


Hi All,


I noticed that Samsung has a new firmware version 1.5 (updated 02/28/08).


Has anyone tried to load this update?

I installed v1.5 yesterday. It worked fine afterward with the one movie I watched.
 

·
Registered
Joined
·
3,830 Posts
Does anyone know if 1.5 fixes the front and back channels being reversed as some of us have experienced?
 
  • Like
Reactions: korsjs
1 - 12 of 12 Posts
Top