AVS Forum banner

41 - 48 of 48 Posts

·
Registered
Joined
·
1 Posts
Thanks for all the info on this thread. Ordered a fan replacement on ebay. Seems like this fan is only available in China, and there are no direct replacements or fans with similar specs from another company or any in the states. Will have to wait the month to get the replacement and report in success or failure.
My symptoms are after running the service menu and looking at the fan speeds, fan #1 operates fine for 10 mins and then starts slowing down, despite the call for speed to be maintained at 3500 rpm, then get the dreaded 2 red lights shut down.
 

·
Registered
Joined
·
1 Posts
Did your old lamp explode? If it did, I can almost guarantee there are glass shards in the blower fan. The blower fan is Fan #3 . I wanted to attach a screenshot from the service manual showing which fans are which, but AVS Forum won't let me post images with fewer than 5 posts. So here's the fan breakdown:

  1. Fan #1: Lamp exhaust
  2. Fan #2: Power fan
  3. Fan #3 : Blower fan
  4. Fan #4: Inlet fan

Here's a YouTube disassembly video by someone who had that exact problem: watch?v=BCAGhq_QYrA I would post the full URL, but again, AVS Forum isn't allowing me to post links since I have fewer than 5 posts :serious:
Registered to say thank you for the post! This was the case.
So to confirm if your old lamp exploded there are shards in the blower fan. Open everything and remove them! The lights will go out and the projector will work just fine. In my case the projector is w2000 but it was the same. Just be careful when you are putting back the motherboard over the power supply there are those 10pins connectors on the bottom so line them up, or else you will have no power light at all.
Thanks again.

the whole disassembly/ assembly is about half an hour.
 

·
Registered
Joined
·
2 Posts
BenQ HT1075
I replaced Fan #1 5 months ago now Fan #4 shows 0 RPM on my projector.
Does anyone know the Part number of Product link for Fan #4?
 

·
Registered
Joined
·
1 Posts
I have the problem of power down after 5 minutes
found this. look at the fan 18:50 that is what I believe is wrong with mine, I will attempt to clean this fan tomorrow, see if its that simple a fix
 

·
Registered
Joined
·
1 Posts
Ahoj i am Czech and my english is verry bad iam so sorry for english . The projector warmed up after cleaning in the service and it always turned off after 7 minutes the lamp cooled down and then the projector turned on and the red lamp lit. The lamp is lit 1450h. and the fans spun at 4500RPM. It wasn't clear to me, but when I drove the machine to a cleaning service, everything was fine. After weeks of reading the forum, I got angry and opened my projector and found a flaw in the front fan being turned, which was blowing inwards. I turned it so that the arrow of the fan pointed out and assembled the device. The projector is working, not humming and is well ventilated and the speed is 1900-2100 RPM. service might know this but don't you think? I'm a layman, but I don't hesitate to start everything, and if I knew I wouldn't go into that projector, I still had to. nice day Honza
 

·
Registered
Joined
·
1 Posts
BenQ HT1075
I replaced Fan #1 5 months ago now Fan #4 shows 0 RPM on my projector.
Does anyone know the Part number of Product link for Fan #4?
I have fan#4 showing 0 rpm, but I can see it spinning. I have taken it apart several times, and find that it works for hours and then it starts shutting off in about 3 min. Fan #4. I did notice some moisture residue and rust around the connectors. I cleaned it several times, but maybe something is wrong with the fan. Next time I open it I will get the part number.
 

·
Registered
Joined
·
2 Posts
Hello guys, I found a weird regularity with overheating error. Placing projector normally, it overheats after 3-4 minutes, but after placing it upside down, it works well. It seems, these holes are important for cooling (?):

3143494

Maybe a small external (inhaust) fan may help with a cooling... But I am not sure about this method because it will increase dust amount inside. Anyway, it worth the try.

my model is 1080st+
 
41 - 48 of 48 Posts
Top