AVS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone. I am a n00b projector owner; after doing some research I picked up the BENQ 1080ST+ about a month ago. Unfortunately, I run into an overheating problem (and I have not seen anyone discuss this problem for this model here - do link me to a relevant thread if I missed it).

Several times, and growing more recent, the projector will shut itself of giving me (power)RED (tem)RED (lamp)NONE error, which per the manual (www dot projectorcentral.com/pdf/projector_manual_7265.pdf, sorry for poor link but forum security did not allow anything else through; p.52) means the fans are not working. From some other info I found on the net, this model may have 4 fans, each with a different LED combo attached to it (which is probably why manual lists four error codes for the fan not working, each for a different fan). Indeed, I noted that when it shuts down in such a state, there is no exhaust coming out from the front (when it is working, there is a lot of warm air coming out of that end), and that part of the projector is very warm. The other fans seem to working when it shuts itself down (there is an exhaust from the right side, for example).

I use the projector as my alt screen, for 5-10h each day. I have switched the projector the high altitude mode (which increases the fan speed) which seemed to have helped when this problem first occurred few weeks ago (the manual recommends it anyway for when the projector operates for ~10h a day).

My firmware version is 1.04. The projector is situated on a ground in a recommended horizontal position, the exhaust vents are not blocked, my power should be stable, the room temperature should be around 20-25C I guess. I tried cleaning the projector with the air sprayer, but it didn't seem to have any effect: today the projector turned off with those two red lights after about 20-40m of use the three times I tried using it (and yes, I let it cool down for several minutes or longer before turning it on). Any recommendations?
 

·
Registered
Joined
·
1,375 Posts
One of the fans sounds like it's not spinning up properly. Return to sender!

While you wait for the RMA, you'll probably get away with using High Altitude mode to compensate.
 
1 - 2 of 2 Posts
Top